aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2010-09-28 17:27:49 +0000
committerRenato Botelho <garga@FreeBSD.org>2010-09-28 17:27:49 +0000
commit7a52343a4c5952ac96f297903db8fc36ac3c4fc2 (patch)
treea71b30580862ee29e3d48a51126067c2b33cc5ee /security/clamav
parent6e2d24fd98ecf65a2b3906a5f53cf270f108b482 (diff)
downloadports-7a52343a4c5952ac96f297903db8fc36ac3c4fc2.tar.gz
ports-7a52343a4c5952ac96f297903db8fc36ac3c4fc2.zip
Notes
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile2
-rw-r--r--security/clamav/files/patch-libclamav__pdf.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 40b75fceaf91..18360d5d0ab5 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,7 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.96.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/clamav/files/patch-libclamav__pdf.c b/security/clamav/files/patch-libclamav__pdf.c
new file mode 100644
index 000000000000..ca3e611aa43b
--- /dev/null
+++ b/security/clamav/files/patch-libclamav__pdf.c
@@ -0,0 +1,11 @@
+--- libclamav/pdf.c.orig 2010-09-28 14:19:25.000000000 -0300
++++ libclamav/pdf.c 2010-09-28 14:19:49.000000000 -0300
+@@ -1024,7 +1024,7 @@
+ offset += pdfver - start;
+
+ /* find trailer and xref, don't fail if not found */
+- map_off = map->len - 2048;
++ map_off = (off_t)map->len - 2048;
+ if (map_off < 0)
+ map_off = 0;
+ bytesleft = map->len - map_off;