aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-26 10:15:19 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-26 10:15:19 +0000
commitc842af27e09a6cba65aa2f130cccacfbfe582a4d (patch)
tree576853f60ee84d9e4dba6aa6279220a3b84978d1 /security/clamav
parent1af872aa6b5b81dfe630746041737e3d9eb9d2ba (diff)
downloadports-c842af27e09a6cba65aa2f130cccacfbfe582a4d.tar.gz
ports-c842af27e09a6cba65aa2f130cccacfbfe582a4d.zip
Notes
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile13
-rw-r--r--security/clamav/files/clamav-freshclam.sh7
2 files changed, 9 insertions, 11 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 568478f60ba4..9c8e3d67f957 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= ${DISTVERSION:S/-rc//g:S/-/./g}
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= clamav
@@ -42,9 +43,7 @@ CONFIGURE_ARGS= --with-dbdir=${DATADIR} \
--disable-clamuko \
--disable-clamav \
--enable-bigstack \
- --disable-dependency-tracking \
- --with-user=${CLAMAVUSER} \
- --with-group=${CLAMAVGROUP}
+ --disable-dependency-tracking
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib \
@@ -55,12 +54,12 @@ MAN1= clamscan.1 freshclam.1 sigtool.1 clamdscan.1
MAN5= clamav.conf.5
MAN8= clamd.8 clamav-milter.8
+CONFLICTS= clamav-devel-*
+
CLAMAVUSER?= clamav
CLAMAVGROUP?= clamav
CLAMAV_CLAMD_SOCKET?= /var/run/clamav/clamd
-CLAMAV_MILTER_SOCKET?= /var/run/clmilter.sock
-
-CONFLICTS= clamav-devel-*
+CLAMAV_MILTER_SOCKET?= /var/run/clamav/clmilter.sock
SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%DATADIR%%|${DATADIR}|g' \
@@ -111,8 +110,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr/lib/sendmail|/usr/sbin/sendmail|g' \
${WRKSRC}/clamav-milter/clamav-milter.c
-# @${REINPLACE_CMD} -E -e 's/(_LIBS=.*)-l?pthread -lc_r[[:>:]]/\1${PTHREAD_LIBS}/' \
-
post-build:
@${REINPLACE_CMD} ${SED_CONF} ${BUILD_WRKSRC}/etc/clamav.conf
@${REINPLACE_CMD} ${SED_CONF} ${BUILD_WRKSRC}/etc/freshclam.conf
diff --git a/security/clamav/files/clamav-freshclam.sh b/security/clamav/files/clamav-freshclam.sh
index ea87bd583c50..82cc04997675 100644
--- a/security/clamav/files/clamav-freshclam.sh
+++ b/security/clamav/files/clamav-freshclam.sh
@@ -9,11 +9,11 @@
# KEYWORD: FreeBSD shutdown
#
-# Add the following lines to /etc/rc.conf to enable freshclam:
+# Add the following lines to /etc/rc.conf to enable freshclam daemon:
#
#clamav_freshclam_enable="YES"
#
-# See freshclam(8) for flags
+# See freshclam(1) for flags
#
. %%RC_SUBR%%
@@ -23,11 +23,12 @@ rcvar=`set_rcvar`
command=%%PREFIX%%/bin/freshclam
required_dirs=%%DATADIR%%
+required_files=%%PREFIX%%/etc/freshclam.conf
# set defaults
clamav_freshclam_enable=${clamav_freshclam_enable:-"NO"}
-clamav_freshclam_flags=${clamav_freshclam_flags:-"--checks=1 --datadir=%%DATADIR%% --daemon-notify=%%PREFIX%%/etc/clamav.conf --log=/var/log/clamav/freshclam.log"}
+clamav_freshclam_flags=${clamav_freshclam_flags:-"--daemon-notify=%%PREFIX%%/etc/clamav.conf"}
load_rc_config $name