aboutsummaryrefslogtreecommitdiff
path: root/security/clamav
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2014-05-12 14:01:42 +0000
committerRenato Botelho <garga@FreeBSD.org>2014-05-12 14:01:42 +0000
commit523617a4913c57bca8c6f56b5bb48686393634dd (patch)
treea0d389bdf42a17b240cb55f7c2c2d45ff850b624 /security/clamav
parent23c668ab3eea84314ee2c88ee1f1b39ccab29fe2 (diff)
downloadports-523617a4913c57bca8c6f56b5bb48686393634dd.tar.gz
ports-523617a4913c57bca8c6f56b5bb48686393634dd.zip
Notes
Diffstat (limited to 'security/clamav')
-rw-r--r--security/clamav/Makefile1
-rw-r--r--security/clamav/files/patch-libclamav-c++-llvm62
2 files changed, 63 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 123c8e6bf44d..547d22a00236 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -3,6 +3,7 @@
PORTNAME= clamav
PORTVERSION= 0.98.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
diff --git a/security/clamav/files/patch-libclamav-c++-llvm b/security/clamav/files/patch-libclamav-c++-llvm
new file mode 100644
index 000000000000..7407c8129d6e
--- /dev/null
+++ b/security/clamav/files/patch-libclamav-c++-llvm
@@ -0,0 +1,62 @@
+--- libclamav/c++/llvm/include/llvm/Support/CFG.h.orig
++++ libclamav/c++/llvm/include/llvm/Support/CFG.h
+@@ -27,8 +27,9 @@
+
+ template <class Ptr, class USE_iterator> // Predecessor Iterator
+ class PredIterator : public std::iterator<std::forward_iterator_tag,
+- Ptr, ptrdiff_t> {
+- typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t> super;
++ Ptr, ptrdiff_t, Ptr*, Ptr*> {
++ typedef std::iterator<std::forward_iterator_tag, Ptr, ptrdiff_t, Ptr*,
++ Ptr*> super;
+ typedef PredIterator<Ptr, USE_iterator> Self;
+ USE_iterator It;
+
+@@ -40,6 +41,7 @@
+
+ public:
+ typedef typename super::pointer pointer;
++ typedef typename super::reference reference;
+
+ PredIterator() {}
+ explicit inline PredIterator(Ptr *bb) : It(bb->use_begin()) {
+@@ -50,7 +52,7 @@
+ inline bool operator==(const Self& x) const { return It == x.It; }
+ inline bool operator!=(const Self& x) const { return !operator==(x); }
+
+- inline pointer operator*() const {
++ inline reference operator*() const {
+ assert(!It.atEnd() && "pred_iterator out of range!");
+ return cast<TerminatorInst>(*It)->getParent();
+ }
+@@ -100,10 +102,11 @@
+
+ template <class Term_, class BB_> // Successor Iterator
+ class SuccIterator : public std::iterator<std::bidirectional_iterator_tag,
+- BB_, ptrdiff_t> {
++ BB_, ptrdiff_t, BB_*, BB_*> {
+ const Term_ Term;
+ unsigned idx;
+- typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t> super;
++ typedef std::iterator<std::bidirectional_iterator_tag, BB_, ptrdiff_t, BB_*,
++ BB_*> super;
+ typedef SuccIterator<Term_, BB_> Self;
+
+ inline bool index_is_valid(int idx) {
+@@ -112,6 +115,7 @@
+
+ public:
+ typedef typename super::pointer pointer;
++ typedef typename super::reference reference;
+ // TODO: This can be random access iterator, only operator[] missing.
+
+ explicit inline SuccIterator(Term_ T) : Term(T), idx(0) {// begin iterator
+@@ -142,7 +146,7 @@
+ inline bool operator==(const Self& x) const { return idx == x.idx; }
+ inline bool operator!=(const Self& x) const { return !operator==(x); }
+
+- inline pointer operator*() const { return Term->getSuccessor(idx); }
++ inline reference operator*() const { return Term->getSuccessor(idx); }
+ inline pointer operator->() const { return operator*(); }
+
+ inline Self& operator++() { ++idx; return *this; } // Preincrement