aboutsummaryrefslogtreecommitdiff
path: root/security/clamcour
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-03-13 20:11:19 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-03-13 20:11:19 +0000
commit6dee7aadd206bc514c80d7ae5b6ab6b2da2627cc (patch)
tree8bc202477887df5a3cf81f5a43cc6c0386d5efc4 /security/clamcour
parentd8426aee69f7d3a57a84c4e44d4bf665a4402065 (diff)
downloadports-6dee7aadd206bc514c80d7ae5b6ab6b2da2627cc.tar.gz
ports-6dee7aadd206bc514c80d7ae5b6ab6b2da2627cc.zip
Notes
Diffstat (limited to 'security/clamcour')
-rw-r--r--security/clamcour/Makefile5
-rw-r--r--security/clamcour/files/patch-src__clam.cpp22
2 files changed, 24 insertions, 3 deletions
diff --git a/security/clamcour/Makefile b/security/clamcour/Makefile
index f12b2ff3fa6b..a4a6023be698 100644
--- a/security/clamcour/Makefile
+++ b/security/clamcour/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamcour
PORTVERSION= 0.3.8
+PORTREVISION= 1
CATEGORIES= security mail
MASTER_SITES= http://www.becrux.com/pages/projects/clamcour/
@@ -14,9 +15,7 @@ MAINTAINER= bsd@dino.sk
COMMENT= ClamAV courier filter
BUILD_DEPENDS= courier-config:${PORTSDIR}/mail/courier
-LIB_DEPENDS= clamav.1:${PORTSDIR}/security/clamav
-
-BROKEN= Does not compile
+LIB_DEPENDS= clamav.2:${PORTSDIR}/security/clamav
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/security/clamcour/files/patch-src__clam.cpp b/security/clamcour/files/patch-src__clam.cpp
new file mode 100644
index 000000000000..f9f8414483a8
--- /dev/null
+++ b/security/clamcour/files/patch-src__clam.cpp
@@ -0,0 +1,22 @@
+--- src/clam.cpp.orig Sun Oct 1 20:01:37 2006
++++ src/clam.cpp Tue Feb 20 16:04:03 2007
+@@ -78,8 +78,8 @@
+ memset(&limits,0,sizeof(struct cl_limits));
+ root = NULL;
+
+- if ((err = cl_loaddbdir(cl_retdbdir(), &root, &signo)))
+- throw cException(CLAMAV_CLASS_NAME,CLAMAV_CLASS_NAME,"cl_loaddbdir",err);
++ if ((err = cl_load(cl_retdbdir(), &root, &signo, CL_DB_STDOPT)))
++ throw cException(CLAMAV_CLASS_NAME,CLAMAV_CLASS_NAME,"cl_load",err);
+
+ if ((err = cl_build(root)))
+ throw cException(CLAMAV_CLASS_NAME,CLAMAV_CLASS_NAME,"cl_build",err);
+@@ -214,7 +214,7 @@
+ throw cException(CLAMAV_TASK_NAME,"taskProc","pthread_mutex_lock(dbMutex)",err);
+ cl_free(ptr->root);
+ ptr->root = NULL;
+- cl_loaddbdir(cl_retdbdir(), &(ptr->root), &signo);
++ cl_load(cl_retdbdir(), &(ptr->root), &signo, CL_DB_STDOPT);
+ cl_build(ptr->root);
+ if ((err = pthread_mutex_unlock(&(ptr->dbMutex))))
+ throw cException(CLAMAV_TASK_NAME,"taskProc","pthread_mutex_unlock(dbMutex)",err,1);