aboutsummaryrefslogtreecommitdiff
path: root/security/clamcour
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-15 15:24:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-15 15:24:16 +0000
commit9669e20176bf9d709676ec74b35b0436a28a227c (patch)
tree703689d06d5819c415a7999179931bfb6c3c243c /security/clamcour
parent72b3c9ae3e6a6139fdbf536190a0154c6768a83d (diff)
downloadports-9669e20176bf9d709676ec74b35b0436a28a227c.tar.gz
ports-9669e20176bf9d709676ec74b35b0436a28a227c.zip
Notes
Diffstat (limited to 'security/clamcour')
-rw-r--r--security/clamcour/Makefile33
-rw-r--r--security/clamcour/distinfo3
-rw-r--r--security/clamcour/pkg-descr4
3 files changed, 40 insertions, 0 deletions
diff --git a/security/clamcour/Makefile b/security/clamcour/Makefile
new file mode 100644
index 000000000000..7afab7df5178
--- /dev/null
+++ b/security/clamcour/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: clamcour
+# Whom: Milan Obuch
+# Date created: January 13 2006
+#
+# $FreeBSD$
+#
+
+PORTNAME= clamcour
+PORTVERSION= 0.2.3
+CATEGORIES= security mail
+MASTER_SITES= http://www.becrux.com/pages/projects/clamcour/
+
+MAINTAINER= bsd@dino.sk
+COMMENT= ClamAV courier filter
+
+BUILD_DEPENDS= courier-config:${PORTSDIR}/mail/courier
+LIB_DEPENDS= clamav.1:${PORTSDIR}/security/clamav
+
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ARGS= --with-clamav-config=${LOCALBASE}/bin \
+ --with-courier-config=${LOCALBASE}/bin
+CPPFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+
+MAN1= clamcour.1
+PLIST_FILES= libexec/filters/clamcour
+
+.include <bsd.port.mk>
diff --git a/security/clamcour/distinfo b/security/clamcour/distinfo
new file mode 100644
index 000000000000..feba03569cf4
--- /dev/null
+++ b/security/clamcour/distinfo
@@ -0,0 +1,3 @@
+MD5 (clamcour-0.2.3.tar.gz) = 6ff822e2255d151b15a572a23f2ab0fc
+SHA256 (clamcour-0.2.3.tar.gz) = 9ac1b7f522aede825351d971b2a2b1c1db8c5fd921903c20c2da12df5c3bc157
+SIZE (clamcour-0.2.3.tar.gz) = 308569
diff --git a/security/clamcour/pkg-descr b/security/clamcour/pkg-descr
new file mode 100644
index 000000000000..7963d80e09cf
--- /dev/null
+++ b/security/clamcour/pkg-descr
@@ -0,0 +1,4 @@
+ClamCour is Courier filter using Clam Antivirus to check mail for viruses.
+
+WWW: http://www.clamav.net/
+http://www.becrux.com/index.php?page=projects&name=clamcour