aboutsummaryrefslogtreecommitdiff
path: root/security/clamsmtp
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:02:39 +0000
commit0b881b0ecebc9440a559f1c2b27758488a1188fa (patch)
tree933fd11da647dda8c169bc24693094174bdc0355 /security/clamsmtp
parent928d434bd206738b7213dd9b5802c680794a9b10 (diff)
downloadports-0b881b0ecebc9440a559f1c2b27758488a1188fa.tar.gz
ports-0b881b0ecebc9440a559f1c2b27758488a1188fa.zip
Notes
Diffstat (limited to 'security/clamsmtp')
-rw-r--r--security/clamsmtp/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/security/clamsmtp/Makefile b/security/clamsmtp/Makefile
index e5e75fcef9b7..d649ce557be8 100644
--- a/security/clamsmtp/Makefile
+++ b/security/clamsmtp/Makefile
@@ -1,6 +1,5 @@
# Created by: Cheng-Lung Sung <clsung@dragon2.net>
# $FreeBSD$
-#
PORTNAME= clamsmtp
PORTVERSION= 1.10
@@ -24,31 +23,29 @@ MAN8= clamsmtpd.8
PORTDOCS= README
-OPTIONS= LOCAL_CLAMAV "RUN_DEPEND on security/clamav" on
-OPTIONS+= LOCAL_CLAMAV_DEVEL "RUN_DEPEND on security/clamav-devel" off
+OPTIONS_RADIO= CLAMAV
+OPTIONS_RADIO_CLAMAV= LOCAL_CLAMAV LOCAL_CLAMAV_DEVEL
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT= LOCAL_CLAMAV
+LOCAL_CLAMAV_DESC= RUN_DEPEND on security/clamav
+LOCAL_CLAMAV_DEVEL_DESC= RUN_DEPEND on security/clamav-devel
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_LOCAL_CLAMAV)
+.if ${PORT_OPTIONS:MLOCAL_CLAMAV}
RUN_DEPENDS+= clamav>=0:${PORTSDIR}/security/clamav
.endif
-.if defined(WITH_LOCAL_CLAMAV_DEVEL)
+.if ${PORT_OPTIONS:MLOCAL_CLAMAV_DEVEL}
RUN_DEPENDS+= clamav-devel>=0:${PORTSDIR}/security/clamav-devel
.endif
-.if defined(WITH_LOCAL_CLAMAV) || defined(WITH_LOCAL_CLAMAV_DEVEL)
+.if ${PORT_OPTIONS:MLOCAL_CLAMAV} || ${PORT_OPTIONS:MLOCAL_CLAMAV_DEVEL}
SUB_LIST+= CLAMD=clamd
.else
SUB_LIST+= CLAMD=
.endif
-pre-extract:
-.if defined(WITH_LOCAL_CLAMAV) && defined(WITH_LOCAL_CLAMAV_DEVEL)
- @${ECHO_CMD} "Please select only one clamav port"
- exit 1
-.endif
-
post-patch:
@${REINPLACE_CMD} -e "s,%%PTHREAD_LIBS%%,${PTHREAD_LIBS}," ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s,/var/run/clamav/clamd,/var/run/clamav/clamd.sock," \
@@ -58,7 +55,7 @@ post-patch:
post-install:
@${INSTALL_DATA} ${WRKSRC}/doc/clamsmtpd.conf ${PREFIX}/etc/clamsmtpd.conf-sample
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
@@ -66,4 +63,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/scripts/virus_action.sh ${EXAMPLESDIR}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>