aboutsummaryrefslogtreecommitdiff
path: root/security/cmd5checkpw
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-10-23 22:29:10 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-10-23 22:29:10 +0000
commit79375e77af6c5cc2ffc60a66812098b76b71a2e2 (patch)
tree863dfeddd8ab25b63b0aec3710a37a88385a45ae /security/cmd5checkpw
parent7da06c03c42fda1a2ff33b5c78f648a1f7e44123 (diff)
downloadports-79375e77af6c5cc2ffc60a66812098b76b71a2e2.tar.gz
ports-79375e77af6c5cc2ffc60a66812098b76b71a2e2.zip
Notes
Diffstat (limited to 'security/cmd5checkpw')
-rw-r--r--security/cmd5checkpw/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/security/cmd5checkpw/Makefile b/security/cmd5checkpw/Makefile
index 6406df77ddea..c8400ad0fb62 100644
--- a/security/cmd5checkpw/Makefile
+++ b/security/cmd5checkpw/Makefile
@@ -11,12 +11,11 @@ COMMENT= Checkpassword compatible authentication program that uses CRAM-MD5
OPTIONS_DEFINE= DOCS
-MAN8= cmd5checkpw.8
-
PORTDOCS= CHANGES CREDITS INSTALL README rfc1321.txt rfc2104.txt
-PLIST_FILES= bin/cmd5checkpw etc/poppasswd.dist
+PLIST_FILES= bin/cmd5checkpw \
+ etc/poppasswd.dist \
+ man/man8/cmd5checkpw.8.gz
-NO_STAGE= yes
.include <bsd.port.pre.mk>
post-patch:
@@ -27,13 +26,13 @@ post-patch:
${WRKSRC}/Makefile
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/cmd5checkpw ${PREFIX}/bin
- @${INSTALL_DATA} ${WRKSRC}/poppasswd ${PREFIX}/etc/poppasswd.dist
- @${INSTALL_MAN} ${WRKSRC}/cmd5checkpw.8 ${MANPREFIX}/man/man8
+ @${INSTALL_PROGRAM} ${WRKSRC}/cmd5checkpw ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_DATA} ${WRKSRC}/poppasswd ${STAGEDIR}${PREFIX}/etc/poppasswd.dist
+ @${INSTALL_MAN} ${WRKSRC}/cmd5checkpw.8 ${STAGEDIR}${MANPREFIX}/man/man8
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
. for f in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
. endfor
.endif