aboutsummaryrefslogtreecommitdiff
path: root/security/courier-authlib/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2017-09-28 18:46:27 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2017-09-28 18:46:27 +0000
commit67f777acfe742954b0eefa3997f97eb2bc1711cd (patch)
treea29f609e74e43ec01378e808965b38215c5a35e8 /security/courier-authlib/Makefile
parentc17c5e1d3116a3d089bb673dfa169d86894d3d5f (diff)
Notes
Diffstat (limited to 'security/courier-authlib/Makefile')
-rw-r--r--security/courier-authlib/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index d5f67261ab73..e897b2fd76d3 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -3,7 +3,7 @@
PORTNAME= courier-authlib
PORTVERSION= 0.68.0
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES?= security mail
.if defined(PKGNAMESUFFIX)
MASTER_SITES= SF/courier/authlib/${PORTVERSION}
@@ -34,7 +34,7 @@ OPTIONS_DEFINE+= GDBM
LIB_DEPENDS+= libltdl.so:devel/libltdl \
libcourier-unicode.so:devel/courier-unicode
-USES= iconv gmake libtool perl5 tar:bzip2
+USES= iconv gmake libtool localbase perl5 tar:bzip2
GNU_CONFIGURE= yes
USE_SUBMAKE= yes
@@ -46,9 +46,6 @@ AUTHDAEMONVAR= ${LOCALSTATEDIR}/run/authdaemond
VPOPMAILDIR?= ${LOCALBASE}/vpopmail
USERDB?= ${PREFIX}/etc/userdb
-CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -L${LOCALBASE}/lib
-
CONFIGURE_ARGS= --enable-unicode \
--disable-static \
--without-authcustom \
@@ -71,6 +68,8 @@ PLIST_SUB+= MAILOWN=${MAILOWN} MAILGRP=${MAILGRP}
AUTHMOD= auth${PKGNAMESUFFIX:S/-//:S/gdbm/db/}
.if ${AUTHMOD} == authbase
+RUN_DEPENDS+= ${LOCALBASE}/share/sysconftool/sysconftool:devel/sysconftool
+
CONFIGURE_ARGS+=--with-base --with-authpam --with-authpipe
USERS= ${MAILOWN}
@@ -108,6 +107,7 @@ REMOVE_SUBDIRS+=makedat userdb
.endif
.if ${AUTHMOD} == authldap
+RUN_DEPENDS+= ${LOCALBASE}/share/sysconftool/sysconftool:devel/sysconftool
DOCS= README.ldap
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-authldap
@@ -116,6 +116,7 @@ CONFIGURE_ARGS+=--without-authldap
.endif
.if ${AUTHMOD} == authmysql
+RUN_DEPENDS+= ${LOCALBASE}/share/sysconftool/sysconftool:devel/sysconftool
DOCS= README.authmysql.html README.authmysql.myownquery
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-authmysql \
@@ -126,6 +127,7 @@ CONFIGURE_ARGS+=--without-authmysql
.endif
.if ${AUTHMOD} == authpgsql
+RUN_DEPENDS+= ${LOCALBASE}/share/sysconftool/sysconftool:devel/sysconftool
DOCS= README.authpostgres.html
USES+= pgsql
CONFIGURE_ARGS+=--with-authpgsql