aboutsummaryrefslogtreecommitdiff
path: root/security/courierpassd/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2013-07-27 16:45:26 +0000
committerJohn Marino <marino@FreeBSD.org>2013-07-27 16:45:26 +0000
commit9d823abcefcb0805f30b2fb69677e5e9608c05dc (patch)
tree976f88a9f95968c75251d39fe6efcfddc8de086c /security/courierpassd/Makefile
parentb47325edb2d93a726b151ae81f7ecd3c183f0565 (diff)
downloadports-9d823abcefcb0805f30b2fb69677e5e9608c05dc.tar.gz
ports-9d823abcefcb0805f30b2fb69677e5e9608c05dc.zip
Notes
Diffstat (limited to 'security/courierpassd/Makefile')
-rw-r--r--security/courierpassd/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/security/courierpassd/Makefile b/security/courierpassd/Makefile
index 2388bed64d38..ae00caea88ea 100644
--- a/security/courierpassd/Makefile
+++ b/security/courierpassd/Makefile
@@ -1,15 +1,11 @@
-# New ports collection makefile for: courierpassd
-# Date created: 26th July 2005
-# Whom: Ade Lovett <ade@FreeBSD.org>
-#
+# Created by: Ade Lovett <ade@FreeBSD.org>
# $FreeBSD$
PORTNAME= courierpassd
PORTVERSION= 1.1.2
CATEGORIES= security mail
-#MASTER_SITES= http://www.arda.homeunix.net/store/
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ade
+MASTER_SITES= http://www.arda.homeunix.net/software-downloads/ \
+ LOCAL/ade
MAINTAINER= andrew@arda.homeunix.net
COMMENT= User authentication and password changing daemon utility
@@ -28,25 +24,29 @@ CONFIGURE_ARGS+=--with-minuid=${MINUID} --with-badpassdelay=${DELAY}
MAN8= courierpassd.8
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
pre-everything::
- @${ECHO} ""
+ @${ECHO}
@${ECHO} "###########################################################"
- @${ECHO} ""
+ @${ECHO}
@${ECHO} "The following build options are available:"
- @${ECHO} "
+ @${ECHO}
@${ECHO} " MINUID=uid"
@${ECHO} " Accounts with uids below this value cannot have"
@${ECHO} " their passwords changed. Default value is 100."
- @${ECHO} ""
+ @${ECHO}
@${ECHO} " DELAY=sec"
@${ECHO} " Set the delay after a password change failure."
@${ECHO} " Default is 3 seconds."
- @${ECHO} ""
+ @${ECHO}
@${ECHO} "###########################################################"
- @${ECHO} ""
+ @${ECHO}
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}