aboutsummaryrefslogtreecommitdiff
path: root/security/courierpasswd/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-01 20:46:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-01 20:46:26 +0000
commit6a26ebefa79062306cfd96c913c6ade2bf1353ce (patch)
tree6015c9b38051f4361ad549b1791a759bd2a4a5b3 /security/courierpasswd/Makefile
parentab90a7d8d415413f3800d32eedc815d8462c8e4e (diff)
downloadports-6a26ebefa79062306cfd96c913c6ade2bf1353ce.tar.gz
ports-6a26ebefa79062306cfd96c913c6ade2bf1353ce.zip
Notes
Diffstat (limited to 'security/courierpasswd/Makefile')
-rw-r--r--security/courierpasswd/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/security/courierpasswd/Makefile b/security/courierpasswd/Makefile
new file mode 100644
index 000000000000..406f78443643
--- /dev/null
+++ b/security/courierpasswd/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: courierpasswd
+# Date created: 23th April 2006
+# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
+#
+# $FreeBSD$
+
+PORTNAME= courierpasswd
+PORTVERSION= 1.1.0
+CATEGORIES= security mail
+MASTER_SITES= http://www.arda.homeunix.net/store/
+
+MAINTAINER= andrew@arda.homeunix.net
+COMMENT= User authentication and password changing utility
+
+BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' LDFLAGS='${LDFLAGS}'
+
+MINUID?= 100
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-minuid=${MINUID}
+
+PLIST_FILES= sbin/courierpasswd
+MAN8= courierpasswd.8
+
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "#######################################################################"
+ @${ECHO} ""
+ @${ECHO} " You should set the following build option."
+ @${ECHO} ""
+ @${ECHO} " MINUID=uid Accounts with uids below this value cannot have"
+ @${ECHO} " their passwords changed. Default value is 100."
+ @${ECHO} ""
+ @${ECHO} "#######################################################################"
+ @${ECHO} ""
+
+.include <bsd.port.mk>