aboutsummaryrefslogtreecommitdiff
path: root/security/courierpasswd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-01 20:46:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-01 20:46:26 +0000
commit6a26ebefa79062306cfd96c913c6ade2bf1353ce (patch)
tree6015c9b38051f4361ad549b1791a759bd2a4a5b3 /security/courierpasswd
parentab90a7d8d415413f3800d32eedc815d8462c8e4e (diff)
downloadports-6a26ebefa79062306cfd96c913c6ade2bf1353ce.tar.gz
ports-6a26ebefa79062306cfd96c913c6ade2bf1353ce.zip
Notes
Diffstat (limited to 'security/courierpasswd')
-rw-r--r--security/courierpasswd/Makefile44
-rw-r--r--security/courierpasswd/distinfo3
-rw-r--r--security/courierpasswd/pkg-descr6
3 files changed, 53 insertions, 0 deletions
diff --git a/security/courierpasswd/Makefile b/security/courierpasswd/Makefile
new file mode 100644
index 000000000000..406f78443643
--- /dev/null
+++ b/security/courierpasswd/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: courierpasswd
+# Date created: 23th April 2006
+# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
+#
+# $FreeBSD$
+
+PORTNAME= courierpasswd
+PORTVERSION= 1.1.0
+CATEGORIES= security mail
+MASTER_SITES= http://www.arda.homeunix.net/store/
+
+MAINTAINER= andrew@arda.homeunix.net
+COMMENT= User authentication and password changing utility
+
+BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lintl
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' LDFLAGS='${LDFLAGS}'
+
+MINUID?= 100
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-minuid=${MINUID}
+
+PLIST_FILES= sbin/courierpasswd
+MAN8= courierpasswd.8
+
+pre-fetch:
+ @${ECHO} ""
+ @${ECHO} "#######################################################################"
+ @${ECHO} ""
+ @${ECHO} " You should set the following build option."
+ @${ECHO} ""
+ @${ECHO} " MINUID=uid Accounts with uids below this value cannot have"
+ @${ECHO} " their passwords changed. Default value is 100."
+ @${ECHO} ""
+ @${ECHO} "#######################################################################"
+ @${ECHO} ""
+
+.include <bsd.port.mk>
diff --git a/security/courierpasswd/distinfo b/security/courierpasswd/distinfo
new file mode 100644
index 000000000000..e12d849a18d8
--- /dev/null
+++ b/security/courierpasswd/distinfo
@@ -0,0 +1,3 @@
+MD5 (courierpasswd-1.1.0.tar.gz) = 6bc4d2ad23a58bc6d41edee6d75a7dca
+SHA256 (courierpasswd-1.1.0.tar.gz) = 6b7ad5e3bcb575a0ad0cb8c2f7a139a370799d632989a7bfb6818cb74d21ff8d
+SIZE (courierpasswd-1.1.0.tar.gz) = 288625
diff --git a/security/courierpasswd/pkg-descr b/security/courierpasswd/pkg-descr
new file mode 100644
index 000000000000..e965bf9a776f
--- /dev/null
+++ b/security/courierpasswd/pkg-descr
@@ -0,0 +1,6 @@
+courierpasswd is an authentication and password changing utility
+that uses the courier-authlib authentication library to find user credentials.
+
+Its interface follows that of Daniel J. Bernstein's checkpassword program.
+
+WWW: http://www.arda.homeunix.net/store/