aboutsummaryrefslogtreecommitdiff
path: root/security/courieruserinfo/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-27 08:07:23 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-27 08:07:23 +0000
commitc9c4d0a1c68dc34043b947e4ac77c33ce31beb2e (patch)
tree459a3a484f8a64ee8954d10096e6f73efbe031f6 /security/courieruserinfo/Makefile
parent4adef23672f71942245a56b40b8e689736b48471 (diff)
Notes
Diffstat (limited to 'security/courieruserinfo/Makefile')
-rw-r--r--security/courieruserinfo/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/security/courieruserinfo/Makefile b/security/courieruserinfo/Makefile
new file mode 100644
index 000000000000..c1488c8f5a63
--- /dev/null
+++ b/security/courieruserinfo/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: courieruserinfo
+# Date created: 27th July 2006
+# Whom: Andrew St. Jean <andrew@arda.homeunix.net>
+#
+# $FreeBSD$
+
+PORTNAME= courieruserinfo
+PORTVERSION= 1.1.2
+CATEGORIES= security mail
+MASTER_SITES= http://www.arda.homeunix.net/store/
+
+MAINTAINER= andrew@arda.homeunix.net
+COMMENT= User account information retrieval utility
+
+BUILD_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+RUN_DEPENDS= courierauthconfig:${PORTSDIR}/security/courier-authlib-base
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS='${CPPFLAGS}' LDFLAGS='${LDFLAGS}'
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN8= courieruserinfo.8
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/INSTALL ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>