aboutsummaryrefslogtreecommitdiff
path: root/security/crack/files
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-02-02 01:28:04 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-02-02 01:28:04 +0000
commit7117a1d4ad0f84d5e960408aac36730a062a5510 (patch)
treea50efab612a64dd9a07ec0af8020b35aebf714b4 /security/crack/files
parent49f701302bd284164e30ccf36fd47986148af09a (diff)
This is Alec Muffett's password guessing program.
This version (5.0) supports the 4.4BSD password format, and also FreeBSD's MD5 style passwords.
Notes
Notes: svn path=/head/; revision=5489
Diffstat (limited to 'security/crack/files')
-rw-r--r--security/crack/files/patch-0211
-rw-r--r--security/crack/files/patch-0311
-rw-r--r--security/crack/files/pw-md5.test1
-rw-r--r--security/crack/files/pw.freebsd9
4 files changed, 32 insertions, 0 deletions
diff --git a/security/crack/files/patch-02 b/security/crack/files/patch-02
new file mode 100644
index 000000000000..e25326a25528
--- /dev/null
+++ b/security/crack/files/patch-02
@@ -0,0 +1,11 @@
+--- src/libdes/Makefile.orig Thu Dec 19 01:29:21 1996
++++ src/libdes/Makefile Fri Jan 31 11:14:52 1997
+@@ -10,7 +10,7 @@
+ # If you are on a DEC Alpha, edit des.h and change the DES_LONG
+ # define to 'unsigned int'. I have seen this give a %20 speedup.
+
+-OPTS0= -DRAND -DTERMIO #-DNOCONST
++OPTS0= -DRAND -DTERMIOS #-DNOCONST
+
+ # Version 1.94 has changed the strings_to_key function so that it is
+ # now compatible with MITs when the string is longer than 8 characters.
diff --git a/security/crack/files/patch-03 b/security/crack/files/patch-03
new file mode 100644
index 000000000000..da762f3d7092
--- /dev/null
+++ b/security/crack/files/patch-03
@@ -0,0 +1,11 @@
+--- conf/dictgrps.conf.orig Fri Dec 13 10:32:34 1996
++++ conf/dictgrps.conf Fri Jan 31 11:16:16 1997
+@@ -16,7 +16,7 @@
+ # Dict '2' is created from $CRACK_HOME/dict/2/*
+ # Dict '3' is created from $CRACK_HOME/dict/3/*
+
+-1:/usr/dict/*words* dict/1/*
++1:/usr/share/dict/*words* dict/1/*
+ 2:dict/2/*
+ 3:dict/3/*
+
diff --git a/security/crack/files/pw-md5.test b/security/crack/files/pw-md5.test
new file mode 100644
index 000000000000..456c3f0d24a1
--- /dev/null
+++ b/security/crack/files/pw-md5.test
@@ -0,0 +1 @@
+cracker:$1$KhBa0EkO$k4YYCCiLb9QhAZBa3c8D5/:1000:10000::0:0:Evil &:/home/crack:/bin/csh
diff --git a/security/crack/files/pw.freebsd b/security/crack/files/pw.freebsd
new file mode 100644
index 000000000000..d7a452b96f55
--- /dev/null
+++ b/security/crack/files/pw.freebsd
@@ -0,0 +1,9 @@
+root:$1$48PMy$Z5Vlux.H5dXWhut4ops5b0:0:0::0:0:Charlie &:/root:/bin/csh
+toor:$1$dCzEfMgs$KkX36eGQiWrnOFtSgmgkx1:0:0::0:0:Bourne-again Superuser:/root:
+rootk:$1$BMeXpPVU$2wjGMUeDAKsXDtmmZ4B2E/:0:0::0:0:Clark Kent,phonebooth,1(800)suprman,unlisted:/home/rootk:/usr/local/bin/bash
+daemon:*:1:31::0:0:Owner of many system processes:/root:
+bin:*:3:7::0:0:Binaries Commands and Source,,,:/:/nonexistent
+user1:$1$KodDB$MS2uwh1xkprFUMzkf/h4S.:114:31::0:0:USER1,UCD Med Center,(916) 752-7900,(916) 753-0000:/home/user1:/usr/local/bin/tcsh
+user2:$1$UvfZtw0d$asMyR1VjVjPxKzXsuHkXW1:150:31::0:0:USER2,EUII 22??:/home/user2:/usr/local/bin/tcsh
+user3:$1$ft0ut3he$6PIIPiKHFP4Ddn0Oq9/9e0:204:31::0:0:Bill:/home/user3:/bin/csh
+obrien:$1$0Pode$PeChMbTN/ZSCRPXDsAsYk/:1765:20::0:0:David E. O'Brien,EU-II 3090 & 2244,,n/a:/home/obrien:/usr/local/bin/bash