aboutsummaryrefslogtreecommitdiff
path: root/security/cracklib
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-19 12:55:33 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-19 12:55:33 +0000
commit9d3118a2155178ae357571d5ba9b6845765a3781 (patch)
treecd32a7dd6cae3e27180f31668470c852b914f1de /security/cracklib
parentd134e723440ecb6a8590418df256eb17f9e10f31 (diff)
downloadports-9d3118a2155178ae357571d5ba9b6845765a3781.tar.gz
ports-9d3118a2155178ae357571d5ba9b6845765a3781.zip
Add cracklib 2.7, a library containing a function that can be used in
one's own passwd(8) program to keep users from making guessable passwords by filtering them out at the source. PR: 23392 Submitted by: Andrew J. Korty <ajk@iu.edu>
Notes
Notes: svn path=/head/; revision=36117
Diffstat (limited to 'security/cracklib')
-rw-r--r--security/cracklib/Makefile27
-rw-r--r--security/cracklib/distinfo1
-rw-r--r--security/cracklib/files/patch-Makefile17
-rw-r--r--security/cracklib/pkg-comment1
-rw-r--r--security/cracklib/pkg-descr23
-rw-r--r--security/cracklib/pkg-plist11
6 files changed, 80 insertions, 0 deletions
diff --git a/security/cracklib/Makefile b/security/cracklib/Makefile
new file mode 100644
index 000000000000..3ca07f02c94d
--- /dev/null
+++ b/security/cracklib/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: cracklib
+# Date created: 22 April 2000
+# Whom: ajk@iu.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= cracklib
+PORTVERSION= 2.7
+CATEGORIES= security
+MASTER_SITES= http://www.users.dircon.co.uk/~crypto/download/
+DISTNAME= ${PORTNAME},${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ajk@iu.edu
+
+pre-install:
+ ${INSTALL_DATA} ${WRKSRC}/cracklib/libcrack.a ${PREFIX}/lib
+ ${INSTALL_SCRIPT} ${WRKSRC}/util/mkdict ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/packer ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/testlib ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/testnum ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/teststr ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/util/unpacker ${PREFIX}/bin
+ ${MKDIR} ${PREFIX}/libdata/cracklib
+
+.include <bsd.port.mk>
diff --git a/security/cracklib/distinfo b/security/cracklib/distinfo
new file mode 100644
index 000000000000..ee7d04af8d90
--- /dev/null
+++ b/security/cracklib/distinfo
@@ -0,0 +1 @@
+MD5 (cracklib,2.7.tgz) = 7f810e310c7f2df33d1eaa2b41ab2435
diff --git a/security/cracklib/files/patch-Makefile b/security/cracklib/files/patch-Makefile
new file mode 100644
index 000000000000..927ed5c18fba
--- /dev/null
+++ b/security/cracklib/files/patch-Makefile
@@ -0,0 +1,17 @@
+--- Makefile.orig Sat Apr 22 09:47:37 2000
++++ Makefile Sat Apr 22 09:48:06 2000
+@@ -9,12 +9,12 @@
+ ###
+ # set this to the absolute path (less extn) of compressed dict.
+
+-DICTPATH="/usr/local/lib/pw_dict"
++DICTPATH="/usr/local/libdata/cracklib/pw_dict"
+
+ ###
+ # Set this to the path of one or more files continaing wordlists.
+
+-SRCDICTS=/usr/dict/words
++SRCDICTS=/usr/share/dict/words
+
+ ###
+ # If you have installed the cracklib-dicts directory, use this
diff --git a/security/cracklib/pkg-comment b/security/cracklib/pkg-comment
new file mode 100644
index 000000000000..38fca670c613
--- /dev/null
+++ b/security/cracklib/pkg-comment
@@ -0,0 +1 @@
+Password-checking library
diff --git a/security/cracklib/pkg-descr b/security/cracklib/pkg-descr
new file mode 100644
index 000000000000..304ae31cfd66
--- /dev/null
+++ b/security/cracklib/pkg-descr
@@ -0,0 +1,23 @@
+CrackLib is a library containing a C function (well, lots of functions
+really, but you only need to use one of them) which may be used in a
+"passwd"-like program.
+
+The idea is simple: try to prevent users from choosing passwords that
+could be guessed by "Crack" by filtering them out, at source.
+
+CrackLib is an offshoot of the the version 5 "Crack" software, and
+contains a considerable number of ideas nicked from the new software.
+
+
+NOTE THIS WELL: CrackLib is NOT a replacement "passwd" program.
+CrackLib is a LIBRARY. CrackLib is what trendy marketdroid types would
+probably call an "enabler".
+
+The idea is that you wire it into your _own_ "passwd" program (if you
+have source); alternatively, you wire it into something like "shadow"
+from off of the net. You can use it in other things, too.
+
+
+WWW: http://www.users.dircon.co.uk/~crypto/
+
+Andrew J. Korty <ajk@iu.edu>
diff --git a/security/cracklib/pkg-plist b/security/cracklib/pkg-plist
new file mode 100644
index 000000000000..8e473f70e2eb
--- /dev/null
+++ b/security/cracklib/pkg-plist
@@ -0,0 +1,11 @@
+bin/mkdict
+bin/packer
+bin/testlib
+bin/testnum
+bin/teststr
+bin/unpacker
+lib/libcrack.a
+libdata/cracklib/pw_dict.hwm
+libdata/cracklib/pw_dict.pwd
+libdata/cracklib/pw_dict.pwi
+@dirrm libdata/cracklib