aboutsummaryrefslogtreecommitdiff
path: root/security/crank/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-18 19:43:17 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-18 19:43:17 +0000
commit983ecac135104b60c9f6d37fef2af08f382d7c80 (patch)
tree89bb62c088aa134169512bca991a75470821be51 /security/crank/Makefile
parentdc4ddaa0d0255152d02febd10769608347e26d7e (diff)
Notes
Diffstat (limited to 'security/crank/Makefile')
-rw-r--r--security/crank/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/crank/Makefile b/security/crank/Makefile
new file mode 100644
index 000000000000..8d34a529e7ef
--- /dev/null
+++ b/security/crank/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: Crank
+# Date created: Apr 18, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crank
+PORTVERSION= 0.1.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_GTK= yes
+USE_GMAKE= yes
+
+post-patch:
+.for file in Makefile plugin-src/Makefile
+ @${PERL} -pi -e "s,gtk-config,${GTK_CONFIG},g" ${WRKSRC}/${file}
+.endfor
+ @${PERL} -pi -e "s,plugins,${PREFIX}/lib/crank,g" ${WRKSRC}/crank.h
+ @${PERL} -pi -e "s, -g , ,g" ${WRKSRC}/plugin-src/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/crank ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/lib/crank
+ @${CP} ${WRKSRC}/plugin-src/*.so ${PREFIX}/lib/crank
+
+.include <bsd.port.mk>