aboutsummaryrefslogtreecommitdiff
path: root/security/create-cert/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-19 06:07:08 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-03-19 06:07:08 +0000
commit80745a04fe73c7af6aad34ff853e55df23c2e0e0 (patch)
tree6c4cce0fe415f0d2e9c9256d0faec01ea633a0c7 /security/create-cert/Makefile
parent037864d0dc51bdca5dd2d31f1aa963de93cd0ee2 (diff)
downloadports-80745a04fe73c7af6aad34ff853e55df23c2e0e0.tar.gz
ports-80745a04fe73c7af6aad34ff853e55df23c2e0e0.zip
- Add create-cert 2.0
create-cert is a script that uses openssl(1) to create self-signed host certificates and private keys for fully qualified domain names (FQDNs). PR: ports/155014 Submitted by: Craig Leres <leres@ee.lbl.gov>
Notes
Notes: svn path=/head/; revision=271296
Diffstat (limited to 'security/create-cert/Makefile')
-rw-r--r--security/create-cert/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/security/create-cert/Makefile b/security/create-cert/Makefile
new file mode 100644
index 000000000000..ce68bfad3eaa
--- /dev/null
+++ b/security/create-cert/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: create-cert
+# Date created: 2011-02-24
+# Whom: Craig Leres <leres@ee.lbl.gov>
+#
+# $FreeBSD$
+#
+
+PORTNAME= create-cert
+PORTVERSION= 2.0
+CATEGORIES= security
+MASTER_SITES= ftp://ee.lbl.gov/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.asc
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= leres@ee.lbl.gov
+COMMENT= Create openssl client key and certificates
+
+PLIST_FILES= sbin/create-cert
+
+MAN8= create-cert.8
+
+GNU_CONFIGURE= yes
+
+verify: checksum
+ gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.asc
+
+LICENSE= BSD
+
+.include <bsd.port.mk>