aboutsummaryrefslogtreecommitdiff
path: root/security/crowdsec-firewall-bouncer/Makefile
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2021-07-14 14:08:43 +0000
committerSofian Brabez <sbz@FreeBSD.org>2021-07-14 14:09:23 +0000
commitb1c9888d3381d6d77c21961a8a3008c3bc3db3a2 (patch)
tree88f0ab84e0f6aec3253b6407c1c5b35bf9dd1ce5 /security/crowdsec-firewall-bouncer/Makefile
parent337d0e23c1fac63b3d235bd3171c4d00ce8c810c (diff)
downloadports-b1c9888d3381d6d77c21961a8a3008c3bc3db3a2.tar.gz
ports-b1c9888d3381d6d77c21961a8a3008c3bc3db3a2.zip
Diffstat (limited to 'security/crowdsec-firewall-bouncer/Makefile')
-rw-r--r--security/crowdsec-firewall-bouncer/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/security/crowdsec-firewall-bouncer/Makefile b/security/crowdsec-firewall-bouncer/Makefile
index cc954af98728..60925f445797 100644
--- a/security/crowdsec-firewall-bouncer/Makefile
+++ b/security/crowdsec-firewall-bouncer/Makefile
@@ -1,5 +1,5 @@
PORTNAME= crowdsec-firewall-bouncer
-PORTVERSION= 0.0.12
+PORTVERSION= 0.0.13
DISTVERSIONPREFIX= v
CATEGORIES= security
@@ -19,21 +19,22 @@ GO_MODULE= github.com/crowdsecurity/cs-firewall-bouncer
GO_BUILDFLAGS= -ldflags "-s -w \
-X github.com/crowdsecurity/cs-firewall-bouncer/pkg/version.Version=v${PORTVERSION} \
- -X github.com/crowdsecurity/cs-firewall-bouncer/pkg/version.Tag=freebsd"
+ -X github.com/crowdsecurity/cs-firewall-bouncer/pkg/version.Tag=freebsd \
+ -X github.com/crowdsecurity/cs-firewall-bouncer/pkg/version.BuildDate=`date -u '+%Y-%m-%d_%I:%M:%S%p'`"
SUB_FILES= pkg-message
post-patch:
${REINPLACE_CMD} 's,$${BACKEND},pf,g' \
- ${WRKSRC}/config/cs-firewall-bouncer.yaml
+ ${WRKSRC}/config/crowdsec-firewall-bouncer.yaml
do-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}
- ${INSTALL_DATA} ${WRKSRC}/config/cs-firewall-bouncer.yaml \
- ${STAGEDIR}${ETCDIR}/cs-firewall-bouncer.yaml.sample
+ ${INSTALL_DATA} ${WRKSRC}/config/crowdsec-firewall-bouncer.yaml \
+ ${STAGEDIR}${ETCDIR}/crowdsec-firewall-bouncer.yaml.sample
${INSTALL_PROGRAM} ${WRKDIR}/bin/crowdsec-firewall-bouncer \
- ${STAGEDIR}${PREFIX}/bin/cs-firewall-bouncer
+ ${STAGEDIR}${PREFIX}/bin/crowdsec-firewall-bouncer
.include <bsd.port.mk>