aboutsummaryrefslogtreecommitdiff
path: root/security/cryptlib
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-08-11 02:15:56 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-08-11 02:15:56 +0000
commit1e2010ff54f62c6554eac5823f9d43f377ca3c66 (patch)
tree4c33e119fb1f2e24cf1398facba079cca8b72576 /security/cryptlib
parent9fe7d0aefb167f2faa29f75af805ab56d07dcfaf (diff)
downloadports-1e2010ff54f62c6554eac5823f9d43f377ca3c66.tar.gz
ports-1e2010ff54f62c6554eac5823f9d43f377ca3c66.zip
Notes
Diffstat (limited to 'security/cryptlib')
-rw-r--r--security/cryptlib/Makefile11
-rw-r--r--security/cryptlib/distinfo2
-rw-r--r--security/cryptlib/files/patch-crypt::aes.h15
-rw-r--r--security/cryptlib/files/patch-makefile37
-rw-r--r--security/cryptlib/files/patch-test::testdev.c12
5 files changed, 4 insertions, 73 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
index d8ebeed557f2..d3751d77bfd5 100644
--- a/security/cryptlib/Makefile
+++ b/security/cryptlib/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= cryptlib
-PORTVERSION= 3.1.b4
-PORTREVISION= 1
+PORTVERSION= 3.1.b5
CATEGORIES= security
MASTER_SITES= ftp://ftp.franken.de/pub/crypt/cryptlib/beta/
-DISTNAME= cl31beta04
+DISTNAME= cl31beta05
EXTRACT_SUFX= .zip
MAINTAINER= ports@FreeBSD.org
@@ -23,16 +22,12 @@ EXTRACT_BEFORE_ARGS= -aq
NO_WRKSUBDIR= yes
USE_GMAKE= yes
MAKEFILE= makefile
-MAKE_ARGS= all shared
-USE_REINPLACE= yes
+ALL_TARGET= default FreeBSD shared
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
-post-patch:
- ${REINPLACE_CMD} -e "s,-fomit-frame-pointer -O3,${CFLAGS}," ${WRKSRC}/makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/endian ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcl.a ${WRKSRC}/libcl.so.3.1.0 \
diff --git a/security/cryptlib/distinfo b/security/cryptlib/distinfo
index deb28fdfd6db..bb3bfc6d89e1 100644
--- a/security/cryptlib/distinfo
+++ b/security/cryptlib/distinfo
@@ -1 +1 @@
-MD5 (cl31beta04.zip) = 888b5497adf1c05518900297782af549
+MD5 (cl31beta05.zip) = 17d0d8592ca9313618342f5d8474fd64
diff --git a/security/cryptlib/files/patch-crypt::aes.h b/security/cryptlib/files/patch-crypt::aes.h
deleted file mode 100644
index 7cbd83630474..000000000000
--- a/security/cryptlib/files/patch-crypt::aes.h
+++ /dev/null
@@ -1,15 +0,0 @@
---- crypt/aes.h.orig Tue Jun 17 09:52:19 2003
-+++ crypt/aes.h Tue Jun 17 10:04:23 2003
-@@ -42,7 +42,11 @@
- half the AES code it's the best we can do */
-
- #if ( defined( __GNUC__ ) && ( __GNUC__ >= 2 ) ) || defined( HAS_STDINT_H )
-- #include <stdint.h>
-+ #if defined(__FreeBSD__)
-+ #include <unistd.h>
-+ #elif
-+ #include <stdint.h>
-+ #endif
- #else
- #include "itypes.h"
- #endif /* Systems with C99 headers */
diff --git a/security/cryptlib/files/patch-makefile b/security/cryptlib/files/patch-makefile
deleted file mode 100644
index 37d8260fbb57..000000000000
--- a/security/cryptlib/files/patch-makefile
+++ /dev/null
@@ -1,37 +0,0 @@
---- makefile.orig Tue Jun 17 12:28:06 2003
-+++ makefile Tue Jun 17 13:47:16 2003
-@@ -709,7 +709,7 @@
- $(CC) $(CFLAGS) misc/keyex.c -o $(OBJPATH)keyex.o
-
- $(OBJPATH)keyex_rw.o: $(CRYPT_DEP) $(ASN1_DEP) misc/objinfo.h misc/keyex_rw.c
-- $(CC) $(CFLAGS) misc/keyex_rw.c -o $(OBJPATH)/keyex_rw.o
-+ $(CC) $(CFLAGS) misc/keyex_rw.c -o $(OBJPATH)keyex_rw.o
-
- $(OBJPATH)net_cmp.o: $(CRYPT_DEP) misc/net_cmp.c
- $(CC) $(CFLAGS) misc/net_cmp.c -o $(OBJPATH)net_cmp.o
-@@ -1171,11 +1171,11 @@
- # @make asm_out
- @make $(DEFINES) CC=gcc CFLAGS="$(CFLAGS) -fomit-frame-pointer -O3"
- FreeBSD:
-- @echo "The most common version of this OS uses an incredibly old version of as"
-- @echo "which doesn't handle 486 opcodes, so the asm code is disabled by default."
-- @echo "If you've upgraded to a newer as, uncomment the 'make asm_out' line"
-- @echo "in the FreeBSD section of the makefile to use the much faster asm code."
--# @make asm_out
-+# @echo "The most common version of this OS uses an incredibly old version of as"
-+# @echo "which doesn't handle 486 opcodes, so the asm code is disabled by default."
-+# @echo "If you've upgraded to a newer as, uncomment the 'make asm_out' line"
-+# @echo "in the FreeBSD section of the makefile to use the much faster asm code."
-+ @make asm_out
- @make $(DEFINES) CFLAGS="$(CFLAGS) -fomit-frame-pointer -O3"
- OpenBSD:
- @make asm_out
-@@ -1463,6 +1463,8 @@
- BeOS:
- @make $(DEFINES) CC=mwcc AR="mwcc -xml -o" SLD="mwcc -xms -f crypt.exp"
-
-+all:
-+ @make default
-
- #****************************************************************************
- #* *
diff --git a/security/cryptlib/files/patch-test::testdev.c b/security/cryptlib/files/patch-test::testdev.c
deleted file mode 100644
index 6f0574ff472b..000000000000
--- a/security/cryptlib/files/patch-test::testdev.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- test/testdev.c.orig Fri Jul 18 12:08:02 2003
-+++ test/testdev.c Fri Jul 18 12:08:22 2003
-@@ -849,8 +849,7 @@
- return( status );
- #else
- puts( "Skipping CAW functionality test (uncomment the "
-- "TEST_CAW_FUNCTIONALITY #define\n in " __FILE__ " to enable
-- this)." );
-+ "TEST_CAW_FUNCTIONALITY #define\n in " __FILE__ " to enable this)." );
- #endif /* TEST_CAW_FUNCTIONALITY */
- status = testCryptoDevice( CRYPT_DEVICE_FORTEZZA, "Fortezza card",
- &fortezzaDeviceInfo );