aboutsummaryrefslogtreecommitdiff
path: root/security/cryptlib
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-06-21 06:11:50 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-06-21 06:11:50 +0000
commit73d5734cf154f1cee603c44d3e7b720a094733f2 (patch)
tree7da85128a891c8fbfa6abb82f846731156b4b74a /security/cryptlib
parent2f776792610c78951371095da0d8bc928a026222 (diff)
downloadports-73d5734cf154f1cee603c44d3e7b720a094733f2.tar.gz
ports-73d5734cf154f1cee603c44d3e7b720a094733f2.zip
Notes
Diffstat (limited to 'security/cryptlib')
-rw-r--r--security/cryptlib/Makefile44
-rw-r--r--security/cryptlib/distinfo1
-rw-r--r--security/cryptlib/files/patch-crypt::aes.h15
-rw-r--r--security/cryptlib/files/patch-makefile37
-rw-r--r--security/cryptlib/pkg-descr15
-rw-r--r--security/cryptlib/pkg-message7
-rw-r--r--security/cryptlib/pkg-plist6
7 files changed, 125 insertions, 0 deletions
diff --git a/security/cryptlib/Makefile b/security/cryptlib/Makefile
new file mode 100644
index 000000000000..6dcf45dc453a
--- /dev/null
+++ b/security/cryptlib/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: cryptlib
+# Date created: 17 Jun, 2003
+# Whom: Foxfair Hu <foxfair@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptlib
+PORTVERSION= 3.1
+PORTREVISION= beta4
+CATEGORIES= security
+MASTER_SITES= ftp://ftp.franken.de/pub/crypt/cryptlib/beta/
+DISTNAME= cl31beta04
+EXTRACT_SUFX= .zip
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A powerful security programming toolkit
+
+USE_ZIP= yes
+EXTRACT_BEFORE_ARGS= -aq
+NO_WRKSUBDIR= yes
+USE_GMAKE= yes
+MAKEFILE= makefile
+MAKE_ARGS= all shared
+
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/endian ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/libcl.a ${WRKSRC}/libcl.so.3.1.0 \
+ ${PREFIX}/lib
+ ${LN} -sf ${PREFIX}/lib/libcl.so.3.1.0 ${PREFIX}/lib/libcl.so
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/cryptlib
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/cryptlib
+.endif
+
+post-install:
+ ${STRIP_CMD} ${PREFIX}/bin/endian
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/security/cryptlib/distinfo b/security/cryptlib/distinfo
new file mode 100644
index 000000000000..deb28fdfd6db
--- /dev/null
+++ b/security/cryptlib/distinfo
@@ -0,0 +1 @@
+MD5 (cl31beta04.zip) = 888b5497adf1c05518900297782af549
diff --git a/security/cryptlib/files/patch-crypt::aes.h b/security/cryptlib/files/patch-crypt::aes.h
new file mode 100644
index 000000000000..7cbd83630474
--- /dev/null
+++ b/security/cryptlib/files/patch-crypt::aes.h
@@ -0,0 +1,15 @@
+--- crypt/aes.h.orig Tue Jun 17 09:52:19 2003
++++ crypt/aes.h Tue Jun 17 10:04:23 2003
+@@ -42,7 +42,11 @@
+ half the AES code it's the best we can do */
+
+ #if ( defined( __GNUC__ ) && ( __GNUC__ >= 2 ) ) || defined( HAS_STDINT_H )
+- #include <stdint.h>
++ #if defined(__FreeBSD__)
++ #include <unistd.h>
++ #elif
++ #include <stdint.h>
++ #endif
+ #else
+ #include "itypes.h"
+ #endif /* Systems with C99 headers */
diff --git a/security/cryptlib/files/patch-makefile b/security/cryptlib/files/patch-makefile
new file mode 100644
index 000000000000..37d8260fbb57
--- /dev/null
+++ b/security/cryptlib/files/patch-makefile
@@ -0,0 +1,37 @@
+--- makefile.orig Tue Jun 17 12:28:06 2003
++++ makefile Tue Jun 17 13:47:16 2003
+@@ -709,7 +709,7 @@
+ $(CC) $(CFLAGS) misc/keyex.c -o $(OBJPATH)keyex.o
+
+ $(OBJPATH)keyex_rw.o: $(CRYPT_DEP) $(ASN1_DEP) misc/objinfo.h misc/keyex_rw.c
+- $(CC) $(CFLAGS) misc/keyex_rw.c -o $(OBJPATH)/keyex_rw.o
++ $(CC) $(CFLAGS) misc/keyex_rw.c -o $(OBJPATH)keyex_rw.o
+
+ $(OBJPATH)net_cmp.o: $(CRYPT_DEP) misc/net_cmp.c
+ $(CC) $(CFLAGS) misc/net_cmp.c -o $(OBJPATH)net_cmp.o
+@@ -1171,11 +1171,11 @@
+ # @make asm_out
+ @make $(DEFINES) CC=gcc CFLAGS="$(CFLAGS) -fomit-frame-pointer -O3"
+ FreeBSD:
+- @echo "The most common version of this OS uses an incredibly old version of as"
+- @echo "which doesn't handle 486 opcodes, so the asm code is disabled by default."
+- @echo "If you've upgraded to a newer as, uncomment the 'make asm_out' line"
+- @echo "in the FreeBSD section of the makefile to use the much faster asm code."
+-# @make asm_out
++# @echo "The most common version of this OS uses an incredibly old version of as"
++# @echo "which doesn't handle 486 opcodes, so the asm code is disabled by default."
++# @echo "If you've upgraded to a newer as, uncomment the 'make asm_out' line"
++# @echo "in the FreeBSD section of the makefile to use the much faster asm code."
++ @make asm_out
+ @make $(DEFINES) CFLAGS="$(CFLAGS) -fomit-frame-pointer -O3"
+ OpenBSD:
+ @make asm_out
+@@ -1463,6 +1463,8 @@
+ BeOS:
+ @make $(DEFINES) CC=mwcc AR="mwcc -xml -o" SLD="mwcc -xms -f crypt.exp"
+
++all:
++ @make default
+
+ #****************************************************************************
+ #* *
diff --git a/security/cryptlib/pkg-descr b/security/cryptlib/pkg-descr
new file mode 100644
index 000000000000..3831ec3314f6
--- /dev/null
+++ b/security/cryptlib/pkg-descr
@@ -0,0 +1,15 @@
+cryptlib is a powerful security toolkit which allows even inexperienced
+crypto programmers to easily add encryption and authentication services to
+their software. The high-level interface provides anyone with the ability to
+add strong security capabilities to an application in as little as half an
+hour, without needing to know any of the low-level details which make the
+encryption or authentication work. Because of this, cryptlib dramatically
+reduces the cost involved in adding security to new or existing applications.
+
+cryptlib provides a standardised interface to a number of popular encryption
+algorithms, as well as providing a high-level interface which hides most of
+the implementation details and provides an operating-system-independent
+encoding method which makes it easy to transfer secured data from one operating
+environment to another.
+
+WWW: http://www.cs.auckland.ac.nz/~pgut001/cryptlib/
diff --git a/security/cryptlib/pkg-message b/security/cryptlib/pkg-message
new file mode 100644
index 000000000000..31609383da0e
--- /dev/null
+++ b/security/cryptlib/pkg-message
@@ -0,0 +1,7 @@
+===================================================================
+ For more information, please refer to the original web site:
+
+ http://www.cs.auckland.ac.nz/~pgut001/cryptlib/
+
+ Also, source codes from the distfiles are well explained. UTSL!
+===================================================================
diff --git a/security/cryptlib/pkg-plist b/security/cryptlib/pkg-plist
new file mode 100644
index 000000000000..eb4863e0cec4
--- /dev/null
+++ b/security/cryptlib/pkg-plist
@@ -0,0 +1,6 @@
+bin/endian
+lib/libcl.a
+lib/libcl.so
+lib/libcl.so.3.1.0
+%%PORTDOCS%%share/doc/cryptlib/README
+%%PORTDOCS%%@dirrm share/doc/cryptlib