aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-17 19:35:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-17 19:35:55 +0000
commitee16186324677990bb1e0e3973de5e5786f89527 (patch)
tree559278c02f8e410836557685a9747067ab41e983 /security/cryptopp/Makefile
parent8a798e41adffa58a681d5757cca96531b78f5c90 (diff)
Update to 5.2
Fix build with gcc-3.4 Assign maintainership to submitter. PR: ports/69204 Submitted by: Xin LI <delphij@frontfree.net>
Notes
Notes: svn path=/head/; revision=113869
Diffstat (limited to 'security/cryptopp/Makefile')
-rw-r--r--security/cryptopp/Makefile34
1 files changed, 7 insertions, 27 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 8a2356bf5210..807622028d7f 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= cryptopp
-PORTVERSION= 5.1
-PORTREVISION= 2
+PORTVERSION= 5.2
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.eskimo.com/~weidai/ \
@@ -17,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= crypto${PORTVERSION:S/.//g}
EXTRACT_SUFX= .zip
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= delphij@FreeBSD.org.cn
COMMENT= A free C++ class library of Cryptographic Primitives
NO_WRKSUBDIR= yes
@@ -26,27 +25,6 @@ EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
- argnames.h asn.h base64.h basecode.h bench.h \
- blowfish.h blumshub.h cast.h cbcmac.h channels.h \
- config.h crc.h cryptlib.h default.h des.h dh.h dh2.h \
- diamond.h dmac.h dsa.h ec2n.h eccrypto.h ecp.h \
- elgamal.h eprecomp.h esign.h factory.h files.h \
- filters.h fips140.h fltrimpl.h gf256.h gf2_32.h gf2n.h \
- gfpcrypt.h gost.h gzip.h haval.h hex.h hmac.h \
- hrtimer.h ida.h idea.h integer.h iterhash.h lubyrack.h \
- luc.h mars.h md2.h md4.h md5.h md5mac.h mdc.h misc.h \
- modarith.h modes.h modexppc.h mqueue.h mqv.h \
- nbtheory.h network.h nr.h oaep.h oids.h osrng.h \
- panama.h pch.h pkcspad.h polynomi.h pssr.h pubkey.h \
- pwdbased.h queue.h rabin.h randpool.h rc2.h rc5.h \
- rc6.h rijndael.h ripemd.h rng.h rsa.h rw.h safer.h \
- seal.h secblock.h seckey.h serpent.h sha.h shark.h \
- simple.h skipjack.h smartptr.h socketft.h square.h \
- strciphr.h tea.h tiger.h trdlocal.h trunhash.h \
- twofish.h validate.h wait.h wake.h winpipes.h words.h \
- xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
-
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386" && ${ARCH} != "alpha"
@@ -59,9 +37,11 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
${MKDIR} ${PREFIX}/include/cryptopp
-.for H in ${HEADERFILES}
- ${INSTALL_DATA} ${WRKSRC}/$H ${PREFIX}/include/cryptopp
-.endfor
+ (for i in `${FIND} ${WRKSRC}/ -name '*.h' \
+ -and -not -name 'dll.h' \
+ -and -not -name 'resource.h'`; do \
+ ${INSTALL_DATA} $$i ${PREFIX}/include/cryptopp; \
+ done)
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cryptopp
${CP} ${WRKSRC}/Readme.txt ${PREFIX}/share/doc/cryptopp/README