aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp/Makefile
diff options
context:
space:
mode:
authorFoxfair Hu <foxfair@FreeBSD.org>2003-04-12 03:23:03 +0000
committerFoxfair Hu <foxfair@FreeBSD.org>2003-04-12 03:23:03 +0000
commit732c8be689466b4a33e9a2613c36efd29ce41368 (patch)
tree7ea63ba366fc5ebcf620ede9c613cd771f3684e8 /security/cryptopp/Makefile
parente0dc5dd5fdb4d647860560807256b7ee272febcb (diff)
downloadports-732c8be689466b4a33e9a2613c36efd29ce41368.tar.gz
ports-732c8be689466b4a33e9a2613c36efd29ce41368.zip
Notes
Diffstat (limited to 'security/cryptopp/Makefile')
-rw-r--r--security/cryptopp/Makefile43
1 files changed, 26 insertions, 17 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 2214e25290f0..da0b889ecedb 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -6,15 +6,18 @@
#
PORTNAME= cryptopp
-PORTVERSION= 4.1
+PORTVERSION= 5.1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.eskimo.com/~weidai/
+ http://www.eskimo.com/~weidai/ \
+ http://gd.tuwien.ac.at/privacy/crypto/libs/cryptlib/ \
+ http://www.mirrors.wiretapped.net/security/cryptography/libraries/cryptolib/
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= crypto${PORTVERSION:S/.//g}
+EXTRACT_SUFX= .zip
MAINTAINER= greid@ukug.uk.freebsd.org
-COMMENT= A free C++ class library of cryptographic schemes
+COMMENT= A free C++ class library of Cryptographic Primitives
NO_WRKSUBDIR= yes
USE_ZIP= yes
@@ -22,24 +25,29 @@ EXTRACT_BEFORE_ARGS= -aq
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-HEADERFILES= 3way.h adler32.h aes.h algebra.h arc4.h asn.h base64.h \
- bench.h blowfish.h blumgold.h blumshub.h cast.h cbc.h \
- cbcmac.h channels.h config.h crc.h cryptlib.h des.h \
- default.h dh.h dh2.h diamond.h dmac.h dsa.h ec2n.h \
- eccrypto.h ecp.h elgamal.h eprecomp.h files.h gf256.h \
- filters.h gf2_32.h gf2n.h gost.h gzip.h haval.h hex.h \
- hmac.h hrtimer.h ida.h idea.h integer.h iterhash.h \
- lubyrack.h luc.h mars.h md2.h md5.h md5mac.h mdc.h \
- misc.h modarith.h modes.h modexppc.h mqueue.h mqv.h \
+HEADERFILES= 3way.h adler32.h aes.h algebra.h algparam.h arc4.h \
+ argnames.h asn.h base64.h basecode.h bench.h \
+ blowfish.h blumshub.h cast.h cbcmac.h channels.h \
+ config.h crc.h cryptlib.h default.h des.h dh.h dh2.h \
+ diamond.h dmac.h dsa.h ec2n.h eccrypto.h ecp.h \
+ elgamal.h eprecomp.h esign.h factory.h files.h \
+ filters.h fips140.h fltrimpl.h gf256.h gf2_32.h gf2n.h \
+ gfpcrypt.h gost.h gzip.h haval.h hex.h hmac.h \
+ hrtimer.h ida.h idea.h integer.h iterhash.h lubyrack.h \
+ luc.h mars.h md2.h md4.h md5.h md5mac.h mdc.h misc.h \
+ modarith.h modes.h modexppc.h mqueue.h mqv.h \
nbtheory.h network.h nr.h oaep.h oids.h osrng.h \
panama.h pch.h pkcspad.h polynomi.h pssr.h pubkey.h \
- queue.h rabin.h randpool.h rc2.h rc5.h rc6.h \
- rijndael.h ripemd.h rng.h rsa.h rw.h safer.h \
- sapphire.h seal.h secshare.h serpent.h sha.h shark.h \
- skipjack.h smartptr.h socketft.h square.h tea.h \
- tiger.h twofish.h validate.h wake.h winpipes.h words.h \
+ pwdbased.h queue.h rabin.h randpool.h rc2.h rc5.h \
+ rc6.h rijndael.h ripemd.h rng.h rsa.h rw.h safer.h \
+ seal.h secblock.h seckey.h serpent.h sha.h shark.h \
+ simple.h skipjack.h smartptr.h socketft.h square.h \
+ strciphr.h tea.h tiger.h trdlocal.h trunhash.h \
+ twofish.h validate.h wait.h wake.h winpipes.h words.h \
xormac.h xtr.h xtrcrypt.h zdeflate.h zinflate.h zlib.h
+pre-install:
+ strip ${WRKSRC}/cryptest
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cryptest ${PREFIX}/bin
${INSTALL_DATA} ${WRKSRC}/libcryptopp.a ${PREFIX}/lib
@@ -50,6 +58,7 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/cryptopp
${CP} ${WRKSRC}/README.txt ${PREFIX}/share/doc/cryptopp/README
+ ${CP} ${WRKSRC}/License.txt ${PREFIX}/share/doc/cryptopp/License
.endif
.include <bsd.port.mk>