aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2-gssapi
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2013-12-25 18:05:51 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2013-12-25 18:05:51 +0000
commit64249e8f856785cacd656873fce57e3135dce6a4 (patch)
tree20001a0bdf7d76e94c58d1ad492953ef1cfc3eaf /security/cyrus-sasl2-gssapi
parent3665fc013807f87a6c5c962cd9284a098bc8bfb5 (diff)
downloadports-64249e8f856785cacd656873fce57e3135dce6a4.tar.gz
ports-64249e8f856785cacd656873fce57e3135dce6a4.zip
Notes
Diffstat (limited to 'security/cyrus-sasl2-gssapi')
-rw-r--r--security/cyrus-sasl2-gssapi/Makefile87
-rw-r--r--security/cyrus-sasl2-gssapi/pkg-descr3
2 files changed, 90 insertions, 0 deletions
diff --git a/security/cyrus-sasl2-gssapi/Makefile b/security/cyrus-sasl2-gssapi/Makefile
new file mode 100644
index 000000000000..c2ba3857023d
--- /dev/null
+++ b/security/cyrus-sasl2-gssapi/Makefile
@@ -0,0 +1,87 @@
+# $FreeBSD$
+
+PORTNAME= gssapi
+PORTVERSION= 2.1.26
+#PORTREVISION= 0
+CATEGORIES= security ipv6
+MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/
+PKGNAMEPREFIX= cyrus-sasl-
+DISTNAME= ${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= SASL GSSAPI authentication plugin
+
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+
+CYRUS_SASL2_DIR=${MASTERDIR}/../cyrus-sasl2
+DISTINFO_FILE= ${CYRUS_SASL2_DIR}/distinfo
+PATCHDIR= ${CYRUS_SASL2_DIR}/files
+INSTALL_WRKSRC= ${WRKSRC}/plugins
+
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= libtool
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
+ --with-plugindir=${PREFIX}/lib/sasl2 \
+ --with-dbpath=${PREFIX}/etc/sasldb2 \
+ --with-lib-subdir=lib \
+ --includedir=${PREFIX}/include \
+ --enable-static \
+ --with-rc4=openssl
+CONFIGURE_ARGS+=--with-dblib=none \
+ --disable-anon \
+ --disable-cram \
+ --disable-digest \
+ --disable-krb4 \
+ --disable-ntlm \
+ --disable-otp \
+ --disable-plain \
+ --disable-scram
+
+MAKE_ENV+= INSTALL_STRIP_FLAG=${STRIP}
+
+OPTIONS_SINGLE= KERBEROS
+OPTIONS_SINGLE_KERBEROS=BASE HEIMDAL MIT
+OPTIONS_DEFAULT= BASE
+BASE_DESC= Use Heimdal in base
+BASE_CONFIGURE_ENABLE= gssapi
+HEIMDAL_DESC= Use Heimdal from ports
+HEIMDAL_CONFIGURE_ON= --enable-gssapi=${PREFIX} --with-gss_impl=heimdal
+HEIMDAL_BUILD_DEPENDS= ${PREFIX}/lib/libgssapi.so:${PORTSDIR}/security/heimdal
+HEIMDAL_RUN_DEPENDS= ${HEIMDAL_BUILD_DEPENDS}
+HEIMDAL_LDFLAGS= "-R${PREFIX}/lib"
+MIT_DESC= Use MIT Kerberos V5
+MIT_CONFIGURE_ON= --enable-gssapi=${PREFIX} --with-gss_impl=mit
+MIT_LIB_DEPENDS= libkrb5support.0:${PORTSDIR}/security/krb5
+MIT_LDFLAGS= "-R${PREFIX}/lib"
+
+PLIST_FILES= lib/sasl2/libgssapiv2.a \
+ lib/sasl2/libgssapiv2.la \
+ lib/sasl2/libgssapiv2.so \
+ lib/sasl2/libgssapiv2.so.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MHEIMDAL}
+PLIST_FILES+= lib/sasl2/libgs2.a \
+ lib/sasl2/libgs2.la \
+ lib/sasl2/libgs2.so \
+ lib/sasl2/libgs2.so.3
+.endif
+
+.if ${OPENSSLBASE} == /usr
+CONFIGURE_ARGS+=--with-openssl=yes
+.else
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+.endif
+
+do-build:
+ cd ${WRKSRC}/include && ${MAKE}
+ cd ${WRKSRC}/plugins && ${MAKE}
+
+.include <bsd.port.post.mk>
diff --git a/security/cyrus-sasl2-gssapi/pkg-descr b/security/cyrus-sasl2-gssapi/pkg-descr
new file mode 100644
index 000000000000..729dbd44f930
--- /dev/null
+++ b/security/cyrus-sasl2-gssapi/pkg-descr
@@ -0,0 +1,3 @@
+SASL GSSAPI authentication plugin
+
+WWW: http://cyrusimap.web.cmu.edu/