aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2-saslauthd
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2007-08-07 16:46:22 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2007-08-07 16:46:22 +0000
commita60962f145ccefb6be8003c5ef4b06edc23d3abb (patch)
tree7b62adf10cb543261372ae08ca9773285f302754 /security/cyrus-sasl2-saslauthd
parent1018eae50cf5929b1ce35466025b71603690f15f (diff)
downloadports-a60962f145ccefb6be8003c5ef4b06edc23d3abb.tar.gz
ports-a60962f145ccefb6be8003c5ef4b06edc23d3abb.zip
Notes
Diffstat (limited to 'security/cyrus-sasl2-saslauthd')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile26
1 files changed, 9 insertions, 17 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 8f6dd8445e41..babbca15e653 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -42,16 +42,14 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-rc4=openssl \
--with-saslauthd=${SASLAUTHD_RUNPATH}
-.if defined(WITH_BDB_VER)
-.if ${WITH_BDB_VER} == 4
-USE_BDB= 40
-.elif ${WITH_BDB_VER} != 3 && ${WITH_BDB_VER} != 41 && \
- ${WITH_BDB_VER} != 42 && ${WITH_BDB_VER} != 43 && \
- ${WITH_BDB_VER} != 44 && ${WITH_BDB_VER} != 45 && ${WITH_BDB_VER} != 46
-IGNORE= "cannot install: WITH_BDB_VER must be 3, 4, 41, 42, 43, 44, 45 or 46"
-.endif
-USE_BDB?= ${WITH_BDB_VER}
-BDB_SUFFIX?= ${WITH_BDB_VER}
+OPTIONS= BDB "Use Berkeley DB" off \
+ OPENLDAP "Use OpenLDAP" off \
+ HTTPFORM "Enable HTTP form authentication" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BDB)
+USE_BDB= yes
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
--with-bdb-incdir=${BDB_INCLUDE_DIR} \
--with-bdb=${BDB_LIB_NAME}
@@ -59,14 +57,10 @@ CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
CONFIGURE_ARGS+=--with-dblib=ndbm
.endif
+.if defined(WITH_OPENLDAP)
.if defined(WITH_OPENLDAP_VER)
-WITH_OPENLDAP= yes
WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
.endif
-.if defined(WITH_OPENLDAP)
-.if defined(WANT_OPENLDAP_VER) && ${WANT_OPENLDAP_VER} == 12
-BROKEN= "this port requires OpenLDAP >= 2.0"
-.endif
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
.endif
@@ -75,8 +69,6 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
CONFIGURE_ARGS+=--enable-httpform
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.so)
CONFIGURE_ARGS+=--enable-gssapi=${KRB5_HOME} --with-gss_impl=mit
.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)