aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2004-05-28 17:47:34 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2004-05-28 17:47:34 +0000
commit359c6f9dd858cc213e6c43d8da8f507def11b184 (patch)
tree99186246e9d5d4a933caf0650d480b70896ecaaf /security/cyrus-sasl2/Makefile
parent7e7c243aa9f57543da19f079513c94e49f3be5d3 (diff)
Notes
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index e1fb872bd731..4e2cbf0a3fbc 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -98,7 +98,17 @@ CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}
CONFIGURE_ARGS+=--without-pgsql
.endif
-.if defined(WITH_MYSQL) || defined(WITH_PGSQL)
+.if defined(WITH_SQLITE)
+PATCH_SITES= ${MASTER_SITE_LOCAL}
+PATCH_SITE_SUBDIR= nork
+PATCHFILES= cyrus-sasl2-sqlite.20040529.diff
+LIB_DEPENDS+= sqlite.2:${PORTSDIR}/databases/sqlite
+CONFIGURE_ARGS+=--with-sqlite=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--without-sqlite
+.endif
+
+.if defined(WITH_MYSQL) || defined(WITH_PGSQL) || defined(WITH_SQLITE)
CONFIGURE_ARGS+=--enable-sql
.else
SQL= "@comment "
@@ -239,14 +249,14 @@ post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${MKDIR} ${DOCSDIR}/html
-.for file in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
-.for file in ${DOC2}
- @${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.for f in ${DOC2}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
.endfor
-.for file in ${HTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${file}.html ${DOCSDIR}/html
+.for f in ${HTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f}.html ${DOCSDIR}/html
.endfor
@${INSTALL_DATA} ${FILESDIR}/Sendmail.README ${DOCSDIR}
.endif