aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2004-01-15 21:08:57 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2004-01-15 21:08:57 +0000
commitacbb60393b5ce14960d9b449f6d9675dc6da87a8 (patch)
tree38e797eea4978f17e3b40a80280d1907f42ac3ae /security/cyrus-sasl2/Makefile
parent9244f0350480549703c655b03f5398524f9f581d (diff)
Notes
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 3d54ce530892..5bbf56d276ab 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -47,7 +47,6 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--includedir=${PREFIX}/include \
--mandir=${MANPREFIX}/man \
--enable-static \
- --enable-login \
--enable-auth-sasldb \
--with-openssl=${OPENSSLBASE} \
--with-rc4=openssl \
@@ -104,6 +103,17 @@ CONFIGURE_ARGS+=--with-devrandom=/dev/urandom
CONFIGURE_ARGS+=--enable-alwaystrue
.endif
+.if defined(WITHOUT_LOGIN)
+LOGIN= "@comment "
+.else
+CONFIGURE_ARGS+=--enable-login
+.endif
+
+.if defined(WITHOUT_PLAIN)
+CONFIGURE_ARGS+=--disable-plain
+PLAIN= "@comment "
+.endif
+
.if defined(WITHOUT_OTP)
CONFIGURE_ARGS+=--disable-otp
OTP= "@comment "
@@ -182,6 +192,8 @@ HTDOCS= advanced appconvert gssapi index install macosx mechanisms \
options plugprog programming readme sysadmin upgrading windows
PLIST_SUB= PREFIX=${PREFIX} \
+ LOGIN=${LOGIN} \
+ PLAIN=${PLAIN} \
OTP=${OTP} \
CRAM=${CRAM} \
DIGEST=${DIGEST} \