aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2003-05-16 08:12:37 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2003-05-16 08:12:37 +0000
commite3080ee5ce4284233560821cea7064a43c03e620 (patch)
tree4ce6d1a865a4c4f5669b722b41289a74429b83c4 /security/cyrus-sasl2/Makefile
parent2aec1563c97832ae9d52e57db907f507ceb2a40c (diff)
Notes
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index e54dcba3179f..be2bc1036042 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -88,23 +88,38 @@ NTLM= "@comment "
CONFIGURE_ARGS+= --enable-ntlm
.endif
-.if defined(KRB5_HOME) && exists(${KRB5_HOME})
+.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)
CONFIGURE_ARGS+= --enable-gssapi=${KRB5_HOME}
-.elif defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME})
+.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
CONFIGURE_ARGS+= --enable-gssapi=${HEIMDAL_HOME}
+.elif !defined(WITHOUT_GSSAPI) && defined(MAKE_KERBEROS5) && exists(/usr/lib/libkrb5.a)
+CONFIGURE_ARGS+= --enable-gssapi
.else
CONFIGURE_ARGS+= --disable-gssapi
GSSAPI= "@comment "
.endif
-.if exists(/usr/lib/libkrb.a) && !defined(WITHOUT_KERBEROS)
+.include <bsd.port.pre.mk>
+
+# KERBEROS 4 was removed in FreeBSD 5.0-CURRENT
+.if ${OSVERSION} > 500105
+.if defined(WITH_KERBEROS4)
+LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
+CONFIGURE_ARGS+= --enable-krb4=${LOCALBASE}/krb4
+.else
+CONFIGURE_ARGS+= --disable-krb4
+EBONES= "@comment "
+.endif
+.elif exists(/usr/lib/libkrb.a) && defined(MAKE_KERBEROS4) && !defined(WITHOUT_KERBEROS4)
CONFIGURE_ARGS+= --enable-krb4
+.elif !exists(/usr/lib/libkrb.a) && defined(WITH_KERBEROS4)
+LIB_DEPENDS+= krb.2:${PORTSDIR}/security/krb4
+CONFIGURE_ARGS+= --enable-krb4=${LOCALBASE}/krb4
.else
CONFIGURE_ARGS+= --disable-krb4
EBONES= "@comment "
.endif
-.include <bsd.port.pre.mk>
.include "${PORTSDIR}/security/openssl/bsd.openssl.mk"
.if !defined(WITH_OPENSSL_BASE)
CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE}