aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2/Makefile
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2016-02-26 07:51:37 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2016-02-26 07:51:37 +0000
commit718dd9ecd9a07e2178dfe72beb686d0ac73ef9d3 (patch)
tree119c20dc9c484d3cae7cacef016b4eb454711670 /security/cyrus-sasl2/Makefile
parent97c0313fe84d31581032ea2de702f068e7c1994a (diff)
downloadports-718dd9ecd9a07e2178dfe72beb686d0ac73ef9d3.tar.gz
ports-718dd9ecd9a07e2178dfe72beb686d0ac73ef9d3.zip
Notes
Diffstat (limited to 'security/cyrus-sasl2/Makefile')
-rw-r--r--security/cyrus-sasl2/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index c93b0a57b10b..d8ea63812029 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -40,11 +40,11 @@ CPE_VENDOR= cmu
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= ALWAYSTRUE AUTHDAEMOND DOCS KEEP_DB_OPEN \
- OBSOLETE_CRAM_ATTR BDB MYSQL PGSQL
+ OBSOLETE_CRAM_ATTR SASLAUTHD BDB MYSQL PGSQL
OPTIONS_RADIO= SQLITE
OPTIONS_RADIO_SQLITE= SQLITE2 SQLITE3
-OPTIONS_GROUP= MECH
-OPTIONS_GROUP_MECH= CRAM DIGEST LOGIN NTLM OTP PLAIN SCRAM
+OPTIONS_GROUP= PLUGIN
+OPTIONS_GROUP_PLUGIN= CRAM DIGEST GSSAPI LOGIN NTLM OTP PLAIN SCRAM SRP
OPTIONS_DEFAULT= AUTHDAEMOND OBSOLETE_CRAM_ATTR CRAM DIGEST \
LOGIN NTLM OTP PLAIN SCRAM
OPTIONS_SUB= yes
@@ -90,6 +90,17 @@ PLAIN_DESC= PLAIN authentication
PLAIN_CONFIGURE_ENABLE= plain
SCRAM_DESC= SCRAM authentication
SCRAM_CONFIGURE_ENABLE= scram
+GSSAPI_DESC= GSSAPI authentication
+GSSAPI_RUN_DEPENDS= \
+ cyrus-sasl-gssapi>=2.1.26:${PORTSDIR}/security/cyrus-sasl2-gssapi
+LDAPDB_DESC= LDAPDB plugin
+LDAPDB_RUN_DEPENDS= \
+ cyrus-sasl-ldapdb>=2.1.26:${PORTSDIR}/security/cyrus-sasl2-ldapdb
+SASLAUTHD_DESC= use of the saslauth daemon
+SASLAUTHD_RUN_DEPENDS= saslauthd:${PORTSDIR}/security/cyrus-sasl2-saslauthd
+SRP_DESC= SRP authentication
+SRP_RUN_DEPENDS= \
+ cyrus-sasl-srp>=2.1.26:${PORTSDIR}/security/cyrus-sasl2-srp
.include <bsd.port.pre.mk>