aboutsummaryrefslogtreecommitdiff
path: root/security/cyrus-sasl2
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2016-02-27 05:15:57 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2016-02-27 05:15:57 +0000
commit90e622d893f8606f7d66b3793bda59def1b58c01 (patch)
treeb35e92edcec92b58617ae55bb043d37546925c16 /security/cyrus-sasl2
parent77ba0faeb4122e143025dea2503aece7addda71d (diff)
downloadports-90e622d893f8606f7d66b3793bda59def1b58c01.tar.gz
ports-90e622d893f8606f7d66b3793bda59def1b58c01.zip
Notes
Diffstat (limited to 'security/cyrus-sasl2')
-rw-r--r--security/cyrus-sasl2/Makefile120
-rw-r--r--security/cyrus-sasl2/Makefile.common214
2 files changed, 220 insertions, 114 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 77661d3897a1..c0ce9340f809 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -1,42 +1,14 @@
# $FreeBSD$
-PORTNAME= cyrus-sasl
-PORTVERSION= 2.1.26
PORTREVISION= 12
-CATEGORIES= security ipv6
-MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
- http://cyrusimap.org/releases/
-MAINTAINER= ume@FreeBSD.org
COMMENT= RFC 2222 SASL (Simple Authentication and Security Layer)
-LICENSE= BSD4CLAUSE
-LICENSE_FILE= ${WRKSRC}/COPYING
-
USES= cpe libtool:keepla pathfix perl5
USE_PERL5= patch
-USE_LDCONFIG= yes
-USE_OPENSSL= yes
-GNU_CONFIGURE= yes
-
-CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
- --with-configdir=${PREFIX}/lib/sasl2:${PREFIX}/etc/sasl2 \
- --with-plugindir=${PREFIX}/lib/sasl2 \
- --with-dbpath=${PREFIX}/etc/sasldb2 \
- --with-lib-subdir=lib \
- --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
- --includedir=${PREFIX}/include \
- --enable-static \
- --enable-auth-sasldb \
- --with-rc4=openssl \
- --with-saslauthd=${SASLAUTHD_RUNPATH} \
- --disable-gssapi \
- --disable-krb4
-MAKE_ENV+= INSTALL_STRIP_FLAG=${STRIP}
-
-DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}2
-CPE_VENDOR= cmu
+CONFIGURE_ARGS+=--enable-auth-sasldb \
+ --with-saslauthd=${SASLAUTHD_RUNPATH}
NO_OPTIONS_SORT= yes
OPTIONS_DEFINE= ALWAYSTRUE AUTHDAEMOND DOCS KEEP_DB_OPEN \
@@ -48,14 +20,14 @@ OPTIONS_GROUP_PLUGIN= ANONYMOUS CRAM DIGEST LOGIN NTLM OTP PLAIN SCRAM
OPTIONS_DEFAULT= ANONYMOUS AUTHDAEMOND OBSOLETE_CRAM_ATTR CRAM DIGEST \
LOGIN NTLM OTP PLAIN SCRAM
OPTIONS_SUB= yes
-ALWAYSTRUE_DESC= the alwaystrue password verifier
+ALWAYSTRUE_DESC= Alwaystrue password verifier (discouraged)
ALWAYSTRUE_CONFIGURE_ENABLE=alwaystrue
-AUTHDAEMOND_DESC= use of authdaemon
+AUTHDAEMOND_DESC= Use of authdaemon
AUTHDAEMOND_CONFIGURE_ON=--with-authdaemond=/var/run/authdaemond/socket
AUTHDAEMOND_CONFIGURE_OFF=--with-authdaemond=no
KEEP_DB_OPEN_DESC= Keep handle to Berkeley DB open
KEEP_DB_OPEN_CONFIGURE_ENABLE=keep-db-open
-OBSOLETE_CRAM_ATTR_DESC=cmusaslsecretCRAM-MD5 property
+OBSOLETE_CRAM_ATTR_DESC=cmusaslsecretCRAM-MD5 auxprop property
OBSOLETE_CRAM_ATTR_CONFIGURE_OFF=--enable-obsolete_cram_attr=no
BDB_USE= BDB=yes
BDB_CONFIGURE_ON= --with-dblib=berkeley \
@@ -69,7 +41,6 @@ MYSQL_CONFIGURE_OFF= --without-mysql
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ON= --with-pgsql=${LOCALBASE}
PGSQL_CONFIGURE_OFF= --without-pgsql
-SQLITE2_DESC= SQLite 2 database
SQLITE2_USE= SQLITE=2
SQLITE2_CONFIGURE_ON= --with-sqlite=${LOCALBASE}
SQLITE2_CONFIGURE_OFF= --without-sqlite
@@ -93,83 +64,4 @@ PLAIN_CONFIGURE_ENABLE= plain
SCRAM_DESC= SCRAM authentication
SCRAM_CONFIGURE_ENABLE= scram
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MBDB}
-INVALID_BDB_VER=2
-SASLDB_NAME= sasldb2
-.else
-SASLDB_NAME= sasldb2.db
-.endif
-
-.if ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL} || \
- ${PORT_OPTIONS:MSQLITE2} || ${PORT_OPTIONS:MSQLITE3}
-CONFIGURE_ARGS+=--enable-sql
-.else
-SQL= "@comment "
-.endif
-
-.if ${ARCH} == "amd64"
-CPPFLAGS+= -fPIC
-.endif
-
-.if ${OPENSSLBASE} == /usr
-CONFIGURE_ARGS+=--with-openssl=yes
-.else
-CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
-.endif
-
-SASLAUTHD_RUNPATH?= /var/run/saslauthd
-
-CYRUS_USER?= cyrus
-CYRUS_GROUP?= cyrus
-
-DOCS= AUTHORS COPYING ChangeLog INSTALL INSTALL.TXT NEWS README
-
-DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-xx.txt \
- draft-ietf-sasl-anon-xx.txt draft-ietf-sasl-crammd5-xx.txt \
- draft-ietf-sasl-gssapi-xx.txt draft-ietf-sasl-plain-xx.txt \
- draft-ietf-sasl-rfc2222bis-xx.txt draft-ietf-sasl-rfc2831bis-xx.txt \
- draft-ietf-sasl-saslprep-xx.txt draft-murchison-sasl-login-xx.txt \
- draft-newman-sasl-c-api-xx.txt rfc1321.txt rfc1939.txt rfc2104.txt \
- rfc2195.txt rfc2222.txt rfc2243.txt rfc2245.txt rfc2289.txt \
- rfc2444.txt rfc2595.txt rfc2831.txt rfc2945.txt rfc3174.txt \
- server-plugin-flow.fig testing.txt
-
-HTDOCS= advanced appconvert components gssapi index install macosx \
- mechanisms options plugprog programming readme sysadmin upgrading \
- windows
-
-SUB_FILES= pkg-deinstall pkg-install pkg-message
-SUB_LIST= CYRUS_USER=${CYRUS_USER} CYRUS_GROUP=${CYRUS_GROUP} \
- SASLDB=${SASLDB_NAME}
-
-PLIST_SUB+= PREFIX=${PREFIX} \
- SQL=${SQL} \
- DOCSDIR=${DOCSDIR:S/^${PREFIX}\///}
-
-post-patch:
-# Try to unbreak parallel (-jX) builds, part 1: make build commands atomic
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${PERL} -w0pi.bak \
- -e 's/(^\@am__fastdepCC_TRUE\@.*?) \
- \n\@am__fastdepCC_TRUE\@\s+(.*?)$$/$$1 && $$2/mgx'
-# Part 2: prevent intermediate *.Tpo output files clash (use unique names)
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${PERL} -wpi.bak \
- -e 's/\$$\*\.Tpo/$$&.$$./g'
-
-post-install-DOCS-on:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
-.for f in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
-.for f in ${DOC2}
- @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
-.for f in ${HTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${f}.html \
- ${STAGEDIR}${DOCSDIR}/html
-.endfor
- @${INSTALL_DATA} ${FILESDIR}/Sendmail.README \
- ${STAGEDIR}${DOCSDIR}
-
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../../security/cyrus-sasl2/Makefile.common"
diff --git a/security/cyrus-sasl2/Makefile.common b/security/cyrus-sasl2/Makefile.common
new file mode 100644
index 000000000000..5324c3c17980
--- /dev/null
+++ b/security/cyrus-sasl2/Makefile.common
@@ -0,0 +1,214 @@
+# $FreeBSD$
+
+PORTNAME= cyrus-sasl
+PORTVERSION= 2.1.26
+CATEGORIES= security ipv6
+MASTER_SITES= ftp://ftp.cyrusimap.org/cyrus-sasl/ \
+ http://cyrusimap.org/releases/
+
+MAINTAINER= ume@FreeBSD.org
+
+LICENSE= BSD4CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+USE_LDCONFIG= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS+=--sysconfdir=${PREFIX}/etc \
+ --with-configdir=${PREFIX}/lib/sasl2:${PREFIX}/etc/sasl2 \
+ --with-plugindir=${PREFIX}/lib/sasl2 \
+ --with-dbpath=${PREFIX}/etc/sasldb2 \
+ --with-lib-subdir=lib \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
+ --includedir=${PREFIX}/include \
+ --enable-static \
+ --with-rc4=openssl
+CONFIGURE_ARGS+=--disable-anon \
+ --disable-cram \
+ --disable-digest \
+ --disable-gssapi \
+ --disable-krb4 \
+ --disable-ntlm \
+ --disable-otp \
+ --disable-plain \
+ --disable-scram
+MAKE_ENV+= INSTALL_STRIP_FLAG=${STRIP}
+
+DOCSDIR= ${PREFIX}/share/doc/cyrus-sasl2
+
+CPE_VENDOR= cmu
+
+SASLAUTHD_RUNPATH?= /var/run/saslauthd
+
+CYRUS_USER?= cyrus
+CYRUS_GROUP?= cyrus
+
+CYRUS_SASL2_DIR=${MASTERDIR}/../../security/cyrus-sasl2
+DISTINFO_FILE= ${CYRUS_SASL2_DIR}/distinfo
+PATCHDIR= ${CYRUS_SASL2_DIR}/files
+
+.if defined(PKGNAMESUFFIX)
+CYRUS_BUILD_TARGET= ${PKGNAMESUFFIX:S/^-//}
+.else
+CYRUS_BUILD_TARGET= ${PORTNAME}
+.endif
+
+.if ${CYRUS_BUILD_TARGET} != "cyrus-sasl" && ${CYRUS_BUILD_TARGET} != "saslauthd"
+
+INSTALL_WRKSRC= ${WRKSRC}/plugins
+LIB_DEPENDS= libsasl2.so:${PORTSDIR}/security/cyrus-sasl2
+USES= libtool:build
+CONFIGURE_ARGS+=--with-dblib=none
+
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OPENSSLBASE} == /usr
+CONFIGURE_ARGS+=--with-openssl=yes
+.else
+CONFIGURE_ARGS+=--with-openssl=${OPENSSLBASE}
+.endif
+
+.if ${CYRUS_BUILD_TARGET} == "cyrus-sasl"
+
+.if ${PORT_OPTIONS:MBDB}
+INVALID_BDB_VER=2
+SASLDB_NAME= sasldb2
+.else
+SASLDB_NAME= sasldb2.db
+.endif
+
+.if ${PORT_OPTIONS:MMYSQL} || ${PORT_OPTIONS:MPGSQL} || \
+ ${PORT_OPTIONS:MSQLITE2} || ${PORT_OPTIONS:MSQLITE3}
+CONFIGURE_ARGS+=--enable-sql
+.else
+SQL= "@comment "
+.endif
+
+.if ${ARCH} == "amd64"
+CPPFLAGS+= -fPIC
+.endif
+
+DOCS= AUTHORS COPYING ChangeLog INSTALL INSTALL.TXT NEWS README
+
+DOC2= ONEWS TODO draft-burdis-cat-srp-sasl-xx.txt \
+ draft-ietf-sasl-anon-xx.txt draft-ietf-sasl-crammd5-xx.txt \
+ draft-ietf-sasl-gssapi-xx.txt draft-ietf-sasl-plain-xx.txt \
+ draft-ietf-sasl-rfc2222bis-xx.txt draft-ietf-sasl-rfc2831bis-xx.txt \
+ draft-ietf-sasl-saslprep-xx.txt draft-murchison-sasl-login-xx.txt \
+ draft-newman-sasl-c-api-xx.txt rfc1321.txt rfc1939.txt rfc2104.txt \
+ rfc2195.txt rfc2222.txt rfc2243.txt rfc2245.txt rfc2289.txt \
+ rfc2444.txt rfc2595.txt rfc2831.txt rfc2945.txt rfc3174.txt \
+ server-plugin-flow.fig testing.txt
+
+HTDOCS= advanced appconvert components gssapi index install macosx \
+ mechanisms options plugprog programming readme sysadmin upgrading \
+ windows
+
+SUB_FILES= pkg-deinstall pkg-install pkg-message
+SUB_LIST= CYRUS_USER=${CYRUS_USER} CYRUS_GROUP=${CYRUS_GROUP} \
+ SASLDB=${SASLDB_NAME}
+
+PLIST_SUB+= PREFIX=${PREFIX} \
+ SQL=${SQL} \
+ DOCSDIR=${DOCSDIR:S/^${PREFIX}\///}
+
+post-patch:
+# Try to unbreak parallel (-jX) builds, part 1: make build commands atomic
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${PERL} -w0pi.bak \
+ -e 's/(^\@am__fastdepCC_TRUE\@.*?) \
+ \n\@am__fastdepCC_TRUE\@\s+(.*?)$$/$$1 && $$2/mgx'
+# Part 2: prevent intermediate *.Tpo output files clash (use unique names)
+ @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${PERL} -wpi.bak \
+ -e 's/\$$\*\.Tpo/$$&.$$./g'
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
+.for f in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+.for f in ${DOC2}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
+.endfor
+.for f in ${HTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${f}.html \
+ ${STAGEDIR}${DOCSDIR}/html
+.endfor
+ @${INSTALL_DATA} ${FILESDIR}/Sendmail.README \
+ ${STAGEDIR}${DOCSDIR}
+
+.elif ${CYRUS_BUILD_TARGET} == "saslauthd"
+
+.if ${PORT_OPTIONS:MBDB}
+INVALID_BDB_VER=2
+.endif
+
+.if ${PORT_OPTIONS:MOPENLDAP}
+.if defined(WITH_OPENLDAP_VER)
+WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
+.endif
+.endif
+
+.if ${PORT_OPTIONS:MGSSAPI_BASE} || ${PORT_OPTIONS:MGSSAPI_HEIMDAL} || \
+ ${PORT_OPTIONS:MGSSAPI_MIT}
+CONFIGURE_ARGS+=--enable-gssapi
+.endif
+
+.if ${SASLAUTHD_RUNPATH} != /var/run/saslauthd
+RUNPATH= "@comment "
+.endif
+
+DOCS= AUTHORS COPYING ChangeLog INSTALL LDAP_SASLAUTHD NEWS README
+
+PLIST_SUB= PREFIX=${PREFIX} \
+ DOCSDIR=${DOCSDIR:S/^${PREFIX}\///} \
+ RUNPATH=${RUNPATH}
+
+SUB_LIST+= SASLAUTHD_RUNPATH=${SASLAUTHD_RUNPATH}
+
+do-build:
+ cd ${WRKSRC}/include && ${MAKE}
+ cd ${WRKSRC}/sasldb && ${MAKE}
+ cd ${WRKSRC}/saslauthd && ${MAKE}
+ cd ${WRKSRC}/saslauthd && ${MAKE} saslcache
+ cd ${WRKSRC}/saslauthd && ${MAKE} testsaslauthd
+
+post-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/saslauthd/saslcache \
+ ${STAGEDIR}${PREFIX}/sbin/saslcache
+ @${INSTALL_PROGRAM} ${WRKSRC}/saslauthd/testsaslauthd \
+ ${STAGEDIR}${PREFIX}/sbin/testsaslauthd
+.if ${SASLAUTHD_RUNPATH} != /var/run/saslauthd
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "SASLAUTHD_RUNPATH was specified."
+ @${ECHO_MSG} "Make sure you create ${SASLAUTHD_RUNPATH}."
+ @${ECHO_MSG} ""
+.else
+ @${MKDIR} ${STAGEDIR}/var/run/saslauthd
+.endif
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/saslauthd
+.for file in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/saslauthd/${file} \
+ ${STAGEDIR}${DOCSDIR}/saslauthd
+.endfor
+
+.else # plugin
+
+LIBTOOL= ${LOCALBASE}/bin/libtool
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e "/^LIBTOOL=/s|\$$(top_builddir)/libtool|${LIBTOOL}|g" \
+ ${WRKSRC}/configure
+
+do-build:
+ cd ${WRKSRC}/include && ${MAKE}
+ cd ${WRKSRC}/plugins && ${MAKE}
+
+.endif
+
+.include <bsd.port.post.mk>