aboutsummaryrefslogtreecommitdiff
path: root/security/denyhosts/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-11-11 06:45:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-11-11 06:45:58 +0000
commitae2d2d0b04d18c1504043e8378d3b51a13493687 (patch)
tree220ce6b85dd83f2a44b8a3703a4e4f6b8ec2af2c /security/denyhosts/Makefile
parentac777b3b67fa50ad2650c47023430d0b2c356bde (diff)
downloadports-ae2d2d0b04d18c1504043e8378d3b51a13493687.tar.gz
ports-ae2d2d0b04d18c1504043e8378d3b51a13493687.zip
Notes
Diffstat (limited to 'security/denyhosts/Makefile')
-rw-r--r--security/denyhosts/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/security/denyhosts/Makefile b/security/denyhosts/Makefile
new file mode 100644
index 000000000000..e4ba941658a7
--- /dev/null
+++ b/security/denyhosts/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: denyhosts
+# Date created: 04 November 2005
+# Whom: Janos Mohacsi <janos.mohacsi@bsd.hu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= denyhosts
+PORTVERSION= 1.1.2
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= DenyHosts-${PORTVERSION}
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= Script to thwart ssh attacks
+
+USE_REINPLACE= yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+DOC_FILES= CHANGELOG.txt LICENSE.txt README.txt
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
+ ${WRKSRC}/daemon-control-dist \
+ ${WRKSRC}/denyhosts.cfg-dist \
+ ${WRKSRC}/setup.py
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>