aboutsummaryrefslogtreecommitdiff
path: root/security/denyhosts/files
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2005-11-11 06:45:58 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2005-11-11 06:45:58 +0000
commitae2d2d0b04d18c1504043e8378d3b51a13493687 (patch)
tree220ce6b85dd83f2a44b8a3703a4e4f6b8ec2af2c /security/denyhosts/files
parentac777b3b67fa50ad2650c47023430d0b2c356bde (diff)
Notes
Diffstat (limited to 'security/denyhosts/files')
-rw-r--r--security/denyhosts/files/patch-daemon-control-dist18
-rw-r--r--security/denyhosts/files/patch-denyhosts.cfg-dist45
-rw-r--r--security/denyhosts/files/patch-setup.py26
3 files changed, 89 insertions, 0 deletions
diff --git a/security/denyhosts/files/patch-daemon-control-dist b/security/denyhosts/files/patch-daemon-control-dist
new file mode 100644
index 000000000000..7f9363ff2cb7
--- /dev/null
+++ b/security/denyhosts/files/patch-daemon-control-dist
@@ -0,0 +1,18 @@
+
+$FreeBSD$
+
+--- daemon-control-dist.orig
++++ daemon-control-dist
+@@ -11,9 +11,9 @@
+ #### Edit these to suit your configuration ####
+ ###############################################
+
+-DENYHOSTS_BIN = "/usr/bin/denyhosts.py"
+-DENYHOSTS_LOCK = "/var/lock/subsys/denyhosts"
+-DENYHOSTS_CFG = "/usr/share/denyhosts/denyhosts.cfg"
++DENYHOSTS_BIN = "%%PREFIX%%/bin/denyhosts.py"
++DENYHOSTS_LOCK = "/var/run/denyhosts"
++DENYHOSTS_CFG = "%%PREFIX%%/share/denyhosts/denyhosts.cfg"
+
+
+ ###############################################
diff --git a/security/denyhosts/files/patch-denyhosts.cfg-dist b/security/denyhosts/files/patch-denyhosts.cfg-dist
new file mode 100644
index 000000000000..49f7b56fb701
--- /dev/null
+++ b/security/denyhosts/files/patch-denyhosts.cfg-dist
@@ -0,0 +1,45 @@
+
+$FreeBSD$
+
+--- denyhosts.cfg-dist.orig
++++ denyhosts.cfg-dist
+@@ -9,10 +9,10 @@
+ # argument
+ #
+ # Redhat:
+-SECURE_LOG = /var/log/secure
++#SECURE_LOG = /var/log/secure
+ #
+ # Mandrake or FreeBSD:
+-#SECURE_LOG = /var/log/auth.log
++SECURE_LOG = /var/log/auth.log
+ #
+ # SuSE:
+ #SECURE_LOG = /var/log/messages
+@@ -23,10 +23,10 @@
+ # HOSTS_DENY: the file which contains restricted host access information
+ #
+ # Most operating systems:
+-HOSTS_DENY = /etc/hosts.deny
++#HOSTS_DENY = /etc/hosts.deny
+ #
+ # Some BSD (FreeBSD) Unixes:
+-#HOSTS_DENY = /etc/hosts.allow
++HOSTS_DENY = /etc/hosts.allow
+ #
+ # Another possibility (also see the next option):
+ #HOSTS_DENY = /etc/hosts.evil
+@@ -157,10 +157,10 @@
+ # running at a time.
+ #
+ # Redhat/Fedora:
+-LOCK_FILE = /var/lock/subsys/denyhosts
++#LOCK_FILE = /var/lock/subsys/denyhosts
+ #
+-# Debian
+-#LOCK_FILE = /var/run/denyhosts.pid
++# Debian (and FreeBSD)
++LOCK_FILE = /var/run/denyhosts.pid
+ #
+ # Misc
+ #LOCK_FILE = /tmp/denyhosts.lock
diff --git a/security/denyhosts/files/patch-setup.py b/security/denyhosts/files/patch-setup.py
new file mode 100644
index 000000000000..0e959b394b81
--- /dev/null
+++ b/security/denyhosts/files/patch-setup.py
@@ -0,0 +1,26 @@
+
+$FreeBSD$
+
+--- setup.py.orig
++++ setup.py
+@@ -7,7 +7,7 @@
+ from glob import glob
+
+
+-libpath = "/usr/share/denyhosts"
++libpath = "%%PREFIX%%/share/denyhosts"
+
+ #########################################################################
+
+@@ -24,10 +24,7 @@
+ data_files=[(libpath, glob("denyhosts.cfg-dist")),
+ (libpath, glob("denyhosts-daemon-initscript")),
+ (libpath, glob("setup.py")),
+- (libpath, glob("daemon-control-dist")),
+- (libpath, glob("CHANGELOG.txt")),
+- (libpath, glob("README.txt")),
+- (libpath, glob("LICENSE.txt"))],
++ (libpath, glob("daemon-control-dist"))],
+ license="GPL",
+ ##extra_path='denyhosts',
+ long_description="""