aboutsummaryrefslogtreecommitdiff
path: root/security/didentd/Makefile
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-10-20 14:32:35 +0000
committerClive Lin <clive@FreeBSD.org>2001-10-20 14:32:35 +0000
commit99436422e819bb14eae3bd35a1c86b977ddfbb2a (patch)
tree276c01e5b6683af3fc1e40a2705cd9b9185907a8 /security/didentd/Makefile
parente1b6983dda1aba4cd71f5cbe6e879505170de0e6 (diff)
downloadports-99436422e819bb14eae3bd35a1c86b977ddfbb2a.tar.gz
ports-99436422e819bb14eae3bd35a1c86b977ddfbb2a.zip
Notes
Diffstat (limited to 'security/didentd/Makefile')
-rw-r--r--security/didentd/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/didentd/Makefile b/security/didentd/Makefile
new file mode 100644
index 000000000000..aa75c5d5091e
--- /dev/null
+++ b/security/didentd/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: publicfile
+# Date created: 15 Oct 2001
+# Whom: Doobee R. Tzeck
+#
+# $FreeBSD$
+#
+
+PORTNAME= didentd
+PORTVERSION= 0.2
+CATEGORIES= security
+MASTER_SITES= http://untergrund.bewaff.net/~drt/c0re.jp/c0de/didentd/ http://c0re.jp/c0de/didentd/
+
+MAINTAINER= drt@un.bewaff.net
+
+RUN_DEPENDS= tcpserver:${PORTSDIR}/sysutils/ucspi-tcp
+
+ALL_TARGET= all
+INSTALL_TARGET= install
+
+post-patch:
+ ${PERL} -pi -e 's,%%LOCALBASE%%,${LOCALBASE},g' ${WRKSRC}/Makefile
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/BLURB ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/INSTALL ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/INTERNALS ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/README ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/THANKS ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/TODO ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/WHY-ENCRYPT ${PREFIX}/share/doc/didentd
+ ${INSTALL_MAN} ${WRKSRC}/WHY-TAP ${PREFIX}/share/doc/didentd
+.endif
+
+.include <bsd.port.mk>