aboutsummaryrefslogtreecommitdiff
path: root/security/digest/Makefile
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-03-09 21:24:50 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-03-09 21:24:50 +0000
commit34f7d6f3ccd11f84b01f1b2f098aacd9a48e5d9c (patch)
tree9e52341783acba8ca329d70cf491109c7230f508 /security/digest/Makefile
parentc8091bb624f55ee6949ac0b5996b7bea5bcea7f9 (diff)
Notes
Diffstat (limited to 'security/digest/Makefile')
-rw-r--r--security/digest/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/digest/Makefile b/security/digest/Makefile
new file mode 100644
index 000000000000..a00e1d21f00a
--- /dev/null
+++ b/security/digest/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: digest
+# Date created: 2001-03-09
+# Whom: trevor
+#
+# $NetBSD: Makefile,v 1.4 2001/03/07 23:03:19 kim Exp $
+# $FreeBSD$
+#
+
+PORTNAME= digest
+PORTVERSION= 20010302
+CATEGORIES= security sysutils
+MASTER_SITES= #
+DISTFILES=
+EXTRACT_ONLY=
+
+MAINTAINER= trevor@FreeBSD.org
+
+CFLAGS+= "-DVERSION=${PORTVERSION}"
+MAKE_ENV+= BINDIR=${LOCALBASE}/bin MANDIR=${LOCALBASE}/man
+MAN1= digest.1
+PLIST= ${WRKDIR}/pkg-plist
+WRKSRC= ${WRKDIR}
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ cd ${FILESDIR} && pax -r -w * ${WRKSRC}
+
+pre-install:
+ ${ECHO} bin/digest > ${PLIST}
+
+post-install:
+ ${INSTALL_MAN} ${FILESDIR}/digest.1 ${PREFIX}/man/man1/
+
+.include <bsd.port.mk>