aboutsummaryrefslogtreecommitdiff
path: root/security/dirbuster
diff options
context:
space:
mode:
authorNiels Heinen <niels@FreeBSD.org>2010-03-09 21:52:06 +0000
committerNiels Heinen <niels@FreeBSD.org>2010-03-09 21:52:06 +0000
commitc5684cbb743882f13cf349211b51e6154c8dd37e (patch)
treea72625dacc7d256623e992d31d371c1d388e45e0 /security/dirbuster
parentb434c5de9468a27e4c53850d971d1f903d3248cc (diff)
OWASP DirBuster is a multi threaded java application designed to
brute force directories and files names on web/application servers. Approved by: itetcu (mentor) Feature safe: yes WWW: http://www.owasp.org/index.php/Category:OWASP_DirBuster_Project
Notes
Notes: svn path=/head/; revision=250782
Diffstat (limited to 'security/dirbuster')
-rw-r--r--security/dirbuster/Makefile41
-rw-r--r--security/dirbuster/distinfo3
-rw-r--r--security/dirbuster/files/dirbuster.sh7
-rw-r--r--security/dirbuster/pkg-descr7
-rw-r--r--security/dirbuster/pkg-plist25
5 files changed, 83 insertions, 0 deletions
diff --git a/security/dirbuster/Makefile b/security/dirbuster/Makefile
new file mode 100644
index 000000000000..5f0e4c25d420
--- /dev/null
+++ b/security/dirbuster/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: dirbuster
+# Date created: 2010-03-08
+# Whom: Niels Heinen
+#
+# $FreeBSD$
+#
+
+PORTNAME= dirbuster
+PORTVERSION= 1.0r1
+CATEGORIES= security java
+MASTER_SITES= SF/${PORTNAME}/DirBuster%20%28jar%20%2B%20lists%29/1.0-RC1/
+DISTNAME= DirBuster-1.0-RC1
+
+MAINTAINER= niels@FreeBSD.org
+COMMENT= DirBuster allows file and directory brute forcing on web servers
+
+USE_ZIP= YES
+USE_JAVA= YES
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ ${RM} ${WRKSRC}/${DISTNAME}.sh
+ ${RM} ${WRKSRC}/${DISTNAME}.bat
+
+pre-install:
+ @${SED} -e 's:%%PATH%%:${DATADIR}/:' \
+ -e 's:%%JAVA_CMD%%:${JAVA}:' \
+ -e 's:%%DIRBUSTER%%:${DATADIR}/${DISTNAME}.jar:' \
+ < ${FILESDIR}/${PORTNAME}.sh > ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/* ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/security/dirbuster/distinfo b/security/dirbuster/distinfo
new file mode 100644
index 000000000000..75c793d7858d
--- /dev/null
+++ b/security/dirbuster/distinfo
@@ -0,0 +1,3 @@
+MD5 (DirBuster-1.0-RC1.zip) = c777986249dccb9285fb85015e28f146
+SHA256 (DirBuster-1.0-RC1.zip) = da80d17bd363bc60d3e7216a3c43329617cbd620ac55e55e2751bd3177d09ea1
+SIZE (DirBuster-1.0-RC1.zip) = 6903482
diff --git a/security/dirbuster/files/dirbuster.sh b/security/dirbuster/files/dirbuster.sh
new file mode 100644
index 000000000000..61cc01091c48
--- /dev/null
+++ b/security/dirbuster/files/dirbuster.sh
@@ -0,0 +1,7 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+
+cd %%PATH%%
+exec %%JAVA_CMD%% -jar -Xmx256m %%DIRBUSTER%% "$@"
diff --git a/security/dirbuster/pkg-descr b/security/dirbuster/pkg-descr
new file mode 100644
index 000000000000..aff96f9656b9
--- /dev/null
+++ b/security/dirbuster/pkg-descr
@@ -0,0 +1,7 @@
+DirBuster is a multi threaded java application designed to brute
+force directories and files names on web/application servers. Often
+is the case now of what looks like a web server in a state of default
+installation is actually not, and has pages and applications hidden
+within. DirBuster attempts to find these.
+
+WWW: http://www.owasp.org/index.php/Category:OWASP_DirBuster_Project
diff --git a/security/dirbuster/pkg-plist b/security/dirbuster/pkg-plist
new file mode 100644
index 000000000000..77f517436929
--- /dev/null
+++ b/security/dirbuster/pkg-plist
@@ -0,0 +1,25 @@
+bin/dirbuster
+%%DATADIR%%/lib/swing-layout-1.0.3.jar
+%%DATADIR%%/lib/commons-codec-1.3.jar
+%%DATADIR%%/lib/commons-httpclient-3.1.jar
+%%DATADIR%%/lib/commons-logging-1.1.1.jar
+%%DATADIR%%/lib/commons-logging-api-1.1.1.jar
+%%DATADIR%%/lib/java-getopt-1.0.13.jar
+%%DATADIR%%/lib/jericho-html-2.6.jar
+%%DATADIR%%/lib/jh.jar
+%%DATADIR%%/lib/jhall.jar
+%%DATADIR%%/lib/jhbasic.jar
+%%DATADIR%%/lib/jsearch.jar
+%%DATADIR%%/lib/looks-2.2.0.jar
+%%DATADIR%%/lib/BrowserLauncher2-1_3.jar
+%%DATADIR%%/directory-list-lowercase-2.3-small.txt
+%%DATADIR%%/directory-list-lowercase-2.3-medium.txt
+%%DATADIR%%/directory-list-2.3-small.txt
+%%DATADIR%%/directory-list-2.3-medium.txt
+%%DATADIR%%/directory-list-1.0.txt
+%%DATADIR%%/directories.jbrofuzz
+%%DATADIR%%/apache-user-enum-2.0.txt
+%%DATADIR%%/apache-user-enum-1.0.txt
+%%DATADIR%%/DirBuster-1.0-RC1.jar
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/