aboutsummaryrefslogtreecommitdiff
path: root/security/drweb-qmail
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-07-31 09:20:28 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-07-31 09:20:28 +0000
commitcf93c0b6d71bfb6edac38be6a9ceeea83ba44c85 (patch)
tree87712827cd28dbdac338fb6eb338fbebd79b8153 /security/drweb-qmail
parent33ef7afe164d908cc2724a8dfb12158a7e5af908 (diff)
downloadports-cf93c0b6d71bfb6edac38be6a9ceeea83ba44c85.tar.gz
ports-cf93c0b6d71bfb6edac38be6a9ceeea83ba44c85.zip
Notes
Diffstat (limited to 'security/drweb-qmail')
-rw-r--r--security/drweb-qmail/Makefile84
-rw-r--r--security/drweb-qmail/distinfo1
-rw-r--r--security/drweb-qmail/files/patch-etc::drweb::drweb_qmail.conf83
-rw-r--r--security/drweb-qmail/pkg-descr3
-rw-r--r--security/drweb-qmail/pkg-message9
-rw-r--r--security/drweb-qmail/pkg-plist56
6 files changed, 236 insertions, 0 deletions
diff --git a/security/drweb-qmail/Makefile b/security/drweb-qmail/Makefile
new file mode 100644
index 000000000000..72b13247ac68
--- /dev/null
+++ b/security/drweb-qmail/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: drweb-qmail
+# Date created: 5 February 2003
+# Whom: Denis N. Peplin <info@volginfo.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drweb_qmail
+PORTVERSION= 4.29.12
+PORTREVISION= 1
+CATEGORIES= security mail
+MASTER_SITES= ftp://ftp.drweb.ru/pub/unix/
+DISTNAME= drweb-qmail-${PORTVERSION}-F-freebsd4
+
+MAINTAINER= info@volginfo.ru
+COMMENT= Qmail client for DrWeb antivirus suite
+
+RUN_DEPENDS= ${DRWEB_PREFIX}/drwebd:${PORTSDIR}/security/drweb \
+ ${QMAIL_PREFIX}/bin/qmail-queue:${PORTSDIR}/mail/qmail
+
+ONLY_FOR_ARCHS= i386
+NO_BUILD= YES
+RESTRICTED= "non-commercial or evaluation use"
+NO_CDROM= ${RESTRICTED}
+
+WRKSRC= ${WRKDIR}/drweb-qmail
+
+QMAIL_PREFIX?= /var/qmail
+QMAIL_NOFILES?= qnofiles
+
+DRWEB_WRKDIR= /var/drweb
+DRWEB_PREFIX= ${PREFIX}/drweb
+
+PW_CMD?= /usr/sbin/pw
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You can use QMAIL_PREFIX (default value is /var/qmail) and QMAIL_NOFILES (default value is qnofiles) options."
+ @${ECHO_MSG} ""
+
+BINOWN= drweb
+BINGRP= qmail
+BINMODE= 4711
+
+do-install:
+ ${PW_CMD} usermod drweb -G ${QMAIL_NOFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/opt/drweb/qmail-queue \
+ ${QMAIL_PREFIX}/bin/qmail-queue.drweb
+ ${INSTALL_DATA} ${WRKSRC}/etc/drweb/addresses.conf \
+ ${DRWEB_PREFIX}/addresses.conf-dist
+ ${INSTALL_DATA} ${WRKSRC}/etc/drweb/drweb_qmail.conf \
+ ${DRWEB_PREFIX}/drweb_qmail.conf-dist
+ ${INSTALL_DATA} ${WRKSRC}/etc/drweb/users.conf \
+ ${DRWEB_PREFIX}/users.conf-dist
+ ${INSTALL_DATA} ${WRKSRC}/etc/drweb/viruses.conf \
+ ${DRWEB_PREFIX}/viruses.conf-dist
+ if [ ! -f ${DRWEB_PREFIX}/addresses.conf ] ; then \
+ ${CP} ${DRWEB_PREFIX}/addresses.conf-dist \
+ ${DRWEB_PREFIX}/addresses.conf; \
+ fi
+ if [ ! -f ${DRWEB_PREFIX}/drweb_qmail.conf ] ; then \
+ ${CP} ${DRWEB_PREFIX}/drweb_qmail.conf-dist \
+ ${DRWEB_PREFIX}/drweb_qmail.conf; \
+ fi
+ if [ ! -f ${DRWEB_PREFIX}/users.conf ] ; then \
+ ${CP} ${DRWEB_PREFIX}/users.conf-dist \
+ ${DRWEB_PREFIX}/users.conf; \
+ fi
+ if [ ! -f ${DRWEB_PREFIX}/viruses.conf ] ; then \
+ ${CP} ${DRWEB_PREFIX}/viruses.conf-dist \
+ ${DRWEB_PREFIX}/viruses.conf; \
+ fi
+ ${MKDIR} -m 755 ${DRWEB_WRKDIR}
+ ${MKDIR} -m 770 ${DRWEB_WRKDIR}/infected ${DRWEB_WRKDIR}/spool
+ ${CHOWN} drweb:drweb ${DRWEB_WRKDIR}
+ ${CHOWN} drweb:${QMAIL_NOFILES} ${DRWEB_WRKDIR}/infected \
+ ${DRWEB_WRKDIR}/spool
+ ${CP} -R ${WRKSRC}/etc/drweb/templates ${PREFIX}/drweb
+ ${CP} -R ${WRKSRC}/opt/drweb/doc/qmail ${PREFIX}/drweb/doc
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/drweb-qmail/distinfo b/security/drweb-qmail/distinfo
new file mode 100644
index 000000000000..c860262ecf18
--- /dev/null
+++ b/security/drweb-qmail/distinfo
@@ -0,0 +1 @@
+MD5 (drweb-qmail-4.29.12-F-freebsd4.tar.gz) = d59d9e5f9c6773676676d4c357aaac3e
diff --git a/security/drweb-qmail/files/patch-etc::drweb::drweb_qmail.conf b/security/drweb-qmail/files/patch-etc::drweb::drweb_qmail.conf
new file mode 100644
index 000000000000..a95986c7b22d
--- /dev/null
+++ b/security/drweb-qmail/files/patch-etc::drweb::drweb_qmail.conf
@@ -0,0 +1,83 @@
+--- etc/drweb/drweb_qmail.conf.orig Fri Jul 18 16:49:32 2003
++++ etc/drweb/drweb_qmail.conf Fri Jul 18 16:56:33 2003
+@@ -17,7 +17,7 @@
+ # Address = local:/usr/local/drweb/run/drwebd.skt
+ # Address = pid:/usr/local/drweb/run/drwebd.pid
+ # Address = pid:/var/drweb/run/drwebd.pid, inet:3000@backup_server.example.com
+-Address = inet:3000@localhost
++Address = local:/usr/local/drweb/run/drwebd.sock
+
+ # Enable/disable caching resolved daemon host
+ # (useful only if daemon uses TCP/IP communications)
+@@ -69,7 +69,7 @@
+ DenyOnOne = yes
+
+ # List with rules for users or domains to block scanning
+-DenyList = /etc/drweb/users.conf
++DenyList = /usr/local/drweb/users.conf
+
+ # Directory used for story temporary files
+ Spool = /var/drweb/spool
+@@ -204,10 +204,10 @@
+ FilterMail = DrWEB-DAEMON@example.com
+
+ # List of unnotificable viruses
+-UnnotificableVirusesList = /etc/drweb/viruses.conf
++UnnotificableVirusesList = /usr/local/drweb/viruses.conf
+
+ # List of unnotificable addresses
+-UnnotificableAddressesList = /etc/drweb/addresses.conf
++UnnotificableAddressesList = /usr/local/drweb/addresses.conf
+
+ # Quarantine directory.
+ # The infected files could be moved in that dir
+@@ -237,15 +237,15 @@
+ RcptsNotify = yes
+
+ # Files with notification templates
+-SenderTemplate = /etc/drweb/templates/en-ru/qmail/virus-sender.msg
+-AdminTemplate = /etc/drweb/templates/en-ru/qmail/virus-admin.msg
+-RcptsTemplate = /etc/drweb/templates/en-ru/qmail/virus-rcpts.msg
++SenderTemplate = /usr/local/drweb/templates/en-ru/qmail/virus-sender.msg
++AdminTemplate = /usr/local/drweb/templates/en-ru/qmail/virus-admin.msg
++RcptsTemplate = /usr/local/drweb/templates/en-ru/qmail/virus-rcpts.msg
+
+ [SkipNotifications]
+ SenderNotify = yes
+ AdminNotify = no
+ RcptsNotify = no
+-SenderTemplate = /etc/drweb/templates/en-ru/qmail/skip-sender.msg
++SenderTemplate = /usr/local/drweb/templates/en-ru/qmail/skip-sender.msg
+ AdminTemplate =
+ RcptsTemplate =
+
+@@ -253,16 +253,16 @@
+ SenderNotify = yes
+ AdminNotify = yes
+ RcptsNotify = no
+-SenderTemplate = /etc/drweb/templates/en-ru/qmail/archive-sender.msg
+-AdminTemplate = /etc/drweb/templates/en-ru/qmail/archive-admin.msg
++SenderTemplate = /usr/local/drweb/templates/en-ru/qmail/archive-sender.msg
++AdminTemplate = /usr/local/drweb/templates/en-ru/qmail/archive-admin.msg
+ RcptsTemplate =
+
+ [ErrorNotifications]
+ SenderNotify = yes
+ AdminNotify = yes
+ RcptsNotify = no
+-SenderTemplate = /etc/drweb/templates/en-ru/qmail/error-sender.msg
+-AdminTemplate = /etc/drweb/templates/en-ru/qmail/error-admin.msg
++SenderTemplate = /usr/local/drweb/templates/en-ru/qmail/error-sender.msg
++AdminTemplate = /usr/local/drweb/templates/en-ru/qmail/error-admin.msg
+ RcptsTemplate =
+
+ [RuleFilterNotifications]
+@@ -270,7 +270,7 @@
+ AdminNotify = yes
+ RcptsNotify = no
+ SenderTemplate =
+-AdminTemplate = /etc/drweb/templates/en-ru/qmail/rule-admin.msg
++AdminTemplate = /usr/local/drweb/templates/en-ru/qmail/rule-admin.msg
+ RcptsTemplate =
+
+ ###################
diff --git a/security/drweb-qmail/pkg-descr b/security/drweb-qmail/pkg-descr
new file mode 100644
index 000000000000..376e1a984c02
--- /dev/null
+++ b/security/drweb-qmail/pkg-descr
@@ -0,0 +1,3 @@
+Qmail client for DrWeb antivirus suite
+
+WWW: http://www.dials.ru/english/
diff --git a/security/drweb-qmail/pkg-message b/security/drweb-qmail/pkg-message
new file mode 100644
index 000000000000..ddc9fd2f32a1
--- /dev/null
+++ b/security/drweb-qmail/pkg-message
@@ -0,0 +1,9 @@
+This port based on proxing qmail-queue component of Qmail. You can
+enable this port by two different ways:
+
+1. Move qmail-queue to qmail-queue.original, then move
+ qmail-queue.drweb to qmail-queue.
+2. If Qmail built WITH_QMAILQUEUE_PATCH, You can set
+ QMAILQUEUE variable to full path of qmail-queue.drweb,
+ then specify old qmail-queue in drweb_qmail.conf instead
+ of default qmail-queue.original. Read Qmail docs for details.
diff --git a/security/drweb-qmail/pkg-plist b/security/drweb-qmail/pkg-plist
new file mode 100644
index 000000000000..13292daf26a4
--- /dev/null
+++ b/security/drweb-qmail/pkg-plist
@@ -0,0 +1,56 @@
+@unexec if [ -f %D/drweb/addresses.conf ] && cmp -s %D/drweb/addresses.conf %D/drweb/addresses.conf-dist; then rm -f %D/drweb/addresses.conf; fi
+drweb/addresses.conf-dist
+@exec if [ ! -f %D/drweb/addresses.conf ] ; then cp -p %D/%F %B/addresses.conf; fi
+drweb/doc/qmail/addresses_list.rus.txt
+drweb/doc/qmail/addresses_list.txt
+drweb/doc/qmail/conf_file.rus.txt
+drweb/doc/qmail/conf_file.txt
+drweb/doc/qmail/notify.rus.txt
+drweb/doc/qmail/notify.txt
+drweb/doc/qmail/readme
+drweb/doc/qmail/readme.rus
+drweb/doc/qmail/users_list.rus.txt
+drweb/doc/qmail/users_list.txt
+drweb/doc/qmail/viruses_list.rus.txt
+drweb/doc/qmail/viruses_list.txt
+@unexec if [ -f %D/drweb/drweb_qmail.conf ] && cmp -s %D/drweb/drweb_qmail.conf %D/drweb/drweb_qmail.conf-dist; then rm -f %D/drweb/drweb_qmail.conf; fi
+drweb/drweb_qmail.conf-dist
+@exec if [ ! -f %D/drweb/drweb_qmail.conf ] ; then cp -p %D/%F %B/drweb_qmail.conf; fi
+drweb/templates/en-ru/admin_archive.msg
+drweb/templates/en-ru/admin_error.msg
+drweb/templates/en-ru/admin_rule.msg
+drweb/templates/en-ru/admin_virus.msg
+drweb/templates/en-ru/qmail/archive-admin.msg
+drweb/templates/en-ru/qmail/archive-sender.msg
+drweb/templates/en-ru/qmail/error-admin.msg
+drweb/templates/en-ru/qmail/error-sender.msg
+drweb/templates/en-ru/qmail/rule-admin.msg
+drweb/templates/en-ru/qmail/skip-sender.msg
+drweb/templates/en-ru/qmail/virus-admin.msg
+drweb/templates/en-ru/qmail/virus-rcpts.msg
+drweb/templates/en-ru/qmail/virus-sender.msg
+drweb/templates/en-ru/rcpts_virus.msg
+drweb/templates/en-ru/sender_archive.msg
+drweb/templates/en-ru/sender_error.msg
+drweb/templates/en-ru/sender_skip.msg
+drweb/templates/en-ru/sender_virus.msg
+@unexec if [ -f %D/drweb/users.conf ] && cmp -s %D/drweb/users.conf %D/drweb/users.conf-dist; then rm -f %D/drweb/users.conf; fi
+drweb/users.conf-dist
+@exec if [ ! -f %D/drweb/users.conf ] ; then cp -p %D/%F %B/users.conf; fi
+@unexec if [ -f %D/drweb/viruses.conf ] && cmp -s %D/drweb/viruses.conf %D/drweb/viruses.conf-dist; then rm -f %D/drweb/viruses.conf; fi
+drweb/viruses.conf-dist
+@exec if [ ! -f %D/drweb/viruses.conf ] ; then cp -p %D/%F %B/viruses.conf; fi
+@dirrm drweb/templates/en-ru/qmail
+@dirrm drweb/templates/en-ru
+@dirrm drweb/templates
+@dirrm drweb/doc/qmail
+@cwd /var
+qmail/bin/qmail-queue.drweb
+@exec mkdir -m 755 %D/drweb
+@exec mkdir -m 770 %D/drweb/infected
+@exec mkdir -m 770 %D/drweb/spool
+@exec chown drweb:drweb %D/drweb
+@exec chown drweb:qnofiles %D/drweb/infected %D/drweb/spool
+@dirrm drweb/infected
+@dirrm drweb/spool
+@dirrm drweb