aboutsummaryrefslogtreecommitdiff
path: root/security/drweb-sendmail/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2001-10-03 07:34:32 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2001-10-03 07:34:32 +0000
commite8858fa43c672918e4cda83e01a838b91ba27e75 (patch)
tree9a724c44d1eea93d0127ffce9188fa54243767dd /security/drweb-sendmail/Makefile
parent354e14d45e60032367b8e7e4977e0035757b9949 (diff)
downloadports-e8858fa43c672918e4cda83e01a838b91ba27e75.tar.gz
ports-e8858fa43c672918e4cda83e01a838b91ba27e75.zip
Notes
Diffstat (limited to 'security/drweb-sendmail/Makefile')
-rw-r--r--security/drweb-sendmail/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/security/drweb-sendmail/Makefile b/security/drweb-sendmail/Makefile
index 4754a1309dc0..f8803b90d780 100644
--- a/security/drweb-sendmail/Makefile
+++ b/security/drweb-sendmail/Makefile
@@ -7,6 +7,7 @@
PORTNAME= drweb_sendmail
PORTVERSION= 4.26
+PORTREVISION= 1
CATEGORIES= security mail
MASTER_SITES= http://www.drweb.ru/ftp/web_pub/
DISTNAME= drwebd-${PORTVERSION}-freebsd4
@@ -24,10 +25,13 @@ INST_PREFIX= ${PREFIX}/${PORTNAME}
SENDMAIL_DIR= /usr/src/contrib/sendmail
LIBSMUTIL_DIR= /usr/src/lib/libsmutil
DOC_DIR= ${PREFIX}/share/doc/drweb-sendmail
+
+.if !defined(WITH_DRWEBSMF_HOSTNAME)
.if defined(BATCH)
-HOSTNAME= your.domain.name
+WITH_DRWEBSMF_HOSTNAME= your.domain.name
.else
-HOSTNAME!= hostname
+WITH_DRWEBSMF_HOSTNAME!=hostname
+.endif
.endif
.if exists( ${SENDMAIL_DIR}/include/libmilter/mfapi.h )
@@ -89,11 +93,11 @@ post-build:
${ECHO} /tmp; \
${ECHO} y; \
${ECHO} ; \
- ${ECHO} postmaster@${HOSTNAME}; \
+ ${ECHO} postmaster@${WITH_DRWEBSMF_HOSTNAME}; \
${ECHO} y; \
${ECHO} y; \
${ECHO} d; \
- ${ECHO} a; \
+ ${ECHO} t; \
${ECHO} t; \
${ECHO} t; \
${ECHO} a; \
@@ -111,10 +115,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/drwebdc ${PREFIX}/drweb/
cd ${WRKSRC}/../sendmail; \
${INSTALL_DATA} readme.* sendmail.*.addon ${DOC_DIR}
- ${SED} 's#!!PREFIX!!#${PREFIX}#g;s#!!HOSTNAME!!#${HOSTNAME}#g' \
+ ${SED} 's#!!PREFIX!!#${PREFIX}#g;s#!!HOSTNAME!!#${WITH_DRWEBSMF_HOSTNAME}#g' \
< ${FILESDIR}/drweb-smf.sh >${WRKSRC}/drweb-smf.sh
# drwebsmf.sh instead drweb-smf.sh to start after drwebd.sh
- ${INSTALL_DATA} ${WRKSRC}/drweb-smf.sh ${PREFIX}/etc/rc.d/drwebsmf.sh-dist
+ ${INSTALL_SCRIPT} ${WRKSRC}/drweb-smf.sh ${PREFIX}/etc/rc.d/drwebsmf.sh
post-install:
@echo