aboutsummaryrefslogtreecommitdiff
path: root/security/drweb/Makefile
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2003-06-07 09:04:36 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2003-06-07 09:04:36 +0000
commit9e869c01de619118bd7d9a62df789d48bec03d8b (patch)
tree4e1de51004c5e5991d620783f76fcb976295632b /security/drweb/Makefile
parentcfd66e6432e7098b0eecfaaa8ea04fd7b5495aa4 (diff)
Notes
Diffstat (limited to 'security/drweb/Makefile')
-rw-r--r--security/drweb/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index 807b5d645c1f..17ce5a9264eb 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= drweb
-PORTVERSION= 4.29.2
+PORTVERSION= 4.29.5
CATEGORIES= security
-MASTER_SITES= ftp://ftp.drweb.ru/pub/unix/
+MASTER_SITES= ftp://ftp.drweb.ru/pub/unix/${PORTVERSION}/
DISTFILES= ${MAIN_NAME}.tar.gz
MAINTAINER= anton@chelcom.ru
@@ -19,6 +19,7 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/${MAIN_NAME}/install
+LIB_DEPENDS+= c.4:${PORTSDIR}/misc/compat4x
# Needed for update.pl
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
@@ -30,7 +31,9 @@ do-install:
@cd ${DRWEB_PREFIX}; ${RM} -f drweb drwebd bases/* updates/*
${TAR} -cf - -C ${WRKSRC}/opt/drweb . | \
${TAR} -xf - -C ${DRWEB_PREFIX} \
- --exclude "*.key" --exclude "update/update.pl*"
+ --exclude "*.key" \
+ --exclude "*.static" \
+ --exclude "update/update.pl*"
${TAR} -cf - -C ${WRKSRC}/var/drweb bases | \
${TAR} -xf - -C ${DRWEB_PREFIX}
chmod 755 ${DRWEB_PREFIX}/bases ${DRWEB_PREFIX}/doc \