aboutsummaryrefslogtreecommitdiff
path: root/security/drweb
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-13 15:03:40 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2005-10-13 15:03:40 +0000
commit5b692052a3f0d33a24ffb3b36deaa4059ff47dd5 (patch)
tree3a4c6a573af4ef4840a15e52d0a7739671e881fe /security/drweb
parentc9d9748b760882612e4184b5376f3d2093fc42d6 (diff)
downloadports-5b692052a3f0d33a24ffb3b36deaa4059ff47dd5.tar.gz
ports-5b692052a3f0d33a24ffb3b36deaa4059ff47dd5.zip
Notes
Diffstat (limited to 'security/drweb')
-rw-r--r--security/drweb/Makefile79
-rw-r--r--security/drweb/distinfo8
-rw-r--r--security/drweb/files/drweb.sh3
-rw-r--r--security/drweb/files/patch-aa145
-rw-r--r--security/drweb/files/patch-ab20
-rw-r--r--security/drweb/files/patch-ac29
-rw-r--r--security/drweb/pkg-install16
-rw-r--r--security/drweb/pkg-message8
-rw-r--r--security/drweb/pkg-plist67
9 files changed, 86 insertions, 289 deletions
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index c5eb54ab51c2..7194fa980c35 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= drweb
-PORTVERSION= 4.32.2
-PORTREVISION= 1
+PORTVERSION= 4.33
CATEGORIES= security
-MASTER_SITES= ftp://ftp.drweb.ru/pub/unix/FreeBSD/49/ \
- ftp://ftp.drweb.ru/pub/unix/FreeBSD/53/
+MASTER_SITES= ftp://ftp.drweb.ru/pub/drweb/unix/FreeBSD/411/ \
+ ftp://ftp.drweb.ru/pub/drweb/unix/FreeBSD/54/
MAINTAINER= support@spectrum.ru
COMMENT= DrWeb antivirus suite
@@ -23,9 +22,9 @@ RUN_DEPENDS= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd49
+DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd411
.else
-DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd53
+DISTNAME= ${PORTNAME}-${PORTVERSION}-freebsd54
.if ${OSVERSION} >= 600000
LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
.endif
@@ -34,53 +33,39 @@ LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
WRKSRC= ${WRKDIR}/${DISTNAME}
DRWEB_PREFIX= ${PREFIX}/${PORTNAME}
-
-pre-everything::
- @${ECHO_MSG} ""
- @${ECHO_MSG} "Warning!"
- @${ECHO_MSG} "4.32* version not supported in the .key files of 4.31* version and older."
- @${ECHO_MSG} "Press Ctrl-C if you want to stop installation."
- @${ECHO_MSG} ""
+DRWEB_VARPREFIX=/var/drweb
do-install:
- -@${INSTALL} -dv -o ${BINOWN} -g ${BINGRP} ${DRWEB_PREFIX}
- @cd ${DRWEB_PREFIX}; ${RM} -f drweb drwebd bases/* updates/*; ${MKDIR} updates
- ${TAR} -cf - -C ${WRKSRC}/usr/local/drweb . | \
+ ${INSTALL} -dv -m 0750 ${DRWEB_PREFIX}
+ ${INSTALL} -dv -m 0750 ${PREFIX}/etc/drweb
+ ${INSTALL} -dv -m 0750 ${DRWEB_VARPREFIX}
+ ${RM} -f ${WRKSRC}${LOCALBASE}/drweb/update.pl
+ ${TAR} -cf - -C ${WRKSRC}${LOCALBASE}/drweb . | \
${TAR} -xf - -C ${DRWEB_PREFIX} \
- --exclude "*.static" \
- --exclude "update/update.pl*"
- ${TAR} -cf - -C ${WRKSRC}/var/drweb bases | \
- ${TAR} -xf - -C ${DRWEB_PREFIX}
- ${CHMOD} 755 ${DRWEB_PREFIX}/bases ${DRWEB_PREFIX}/doc \
- ${DRWEB_PREFIX}/lib ${DRWEB_PREFIX}/updates
- ${SED} 's#%INSTALL%#${DRWEB_PREFIX}#g' \
- < ${WRKSRC}/usr/local/drweb/update/update.pl \
- > ${DRWEB_PREFIX}/update/update.pl
- ${CHMOD} 750 ${DRWEB_PREFIX}/update/update.pl
- ${SED} 's#%INSTALL%#${DRWEB_PREFIX}#g' \
- < ${WRKSRC}/usr/local/etc/drweb/drweb32.ini \
- > ${PREFIX}/drweb/drweb32.ini-distr
- ${RM} -f ${PREFIX}/bin/drweb
- if [ ! -f ${PREFIX}/drweb/drweb32.ini ] ; then \
- ${CP} ${PREFIX}/drweb/drweb32.ini-distr \
- ${PREFIX}/drweb/drweb32.ini; \
+ --exclude "*.static" --exclude "doc"
+ ${TAR} -cf - -C ${WRKSRC}/var/drweb/ . | \
+ ${TAR} -xf - -C ${DRWEB_VARPREFIX}
+ ${INSTALL_DATA} -m 0640 ${WRKSRC}${LOCALBASE}/etc/drweb/drweb32.ini \
+ ${PREFIX}/etc/drweb/drweb32.ini-distr
+ if [ ! -f ${PREFIX}/etc/drweb/drweb32.ini ] ; then \
+ ${CP} ${PREFIX}/etc/drweb/drweb32.ini-distr \
+ ${PREFIX}/etc/drweb/drweb32.ini; \
fi
- ${SED} 's#%INSTALL%#${DRWEB_PREFIX}#g' \
- < ${FILESDIR}/drweb.sh \
- > ${WRKDIR}/drweb
- ${INSTALL_SCRIPT} ${WRKDIR}/drweb ${PREFIX}/bin
- ${SED} 's#%INSTALL%#${DRWEB_PREFIX}#g' \
- < ${WRKSRC}/usr/local/etc/rc.d/00.drwebd.sh \
- > ${PREFIX}/etc/rc.d/00.drwebd.sh
- ${CHMOD} 750 ${PREFIX}/etc/rc.d/00.drwebd.sh
- ${INSTALL_DATA} ${WRKSRC}/usr/local/etc/drweb/email.ini \
- ${PREFIX}/drweb/email.ini-distr
- if [ ! -f ${PREFIX}/drweb/email.ini ] ; then \
- ${CP} ${PREFIX}/drweb/email.ini-distr \
- ${PREFIX}/drweb/email.ini; \
+ ${INSTALL_DATA} -m 0640 ${WRKSRC}${LOCALBASE}/etc/drweb/email.ini \
+ ${PREFIX}/etc/drweb/email.ini-distr
+ if [ ! -f ${PREFIX}/etc/drweb/email.ini ] ; then \
+ ${CP} ${PREFIX}/etc/drweb/email.ini-distr \
+ ${PREFIX}/etc/drweb/email.ini; \
fi
+ ${INSTALL_SCRIPT} -m 0750 -b ${WRKSRC}${LOCALBASE}/etc/rc.d/00.drwebd.sh \
+ ${PREFIX}/etc/rc.d/00.drwebd.sh
post-install:
- PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${TAR} -cf - -C ${WRKSRC}${LOCALBASE}/drweb/doc . | \
+ ${TAR} -xf - -C ${DOCSDIR}
+.endif
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL ${DRWEB_PREFIX} ${DRWEB_VARPREFIX}
.include <bsd.port.post.mk>
diff --git a/security/drweb/distinfo b/security/drweb/distinfo
index 182dcc5e721b..3f6b700550c9 100644
--- a/security/drweb/distinfo
+++ b/security/drweb/distinfo
@@ -1,4 +1,4 @@
-MD5 (drweb-4.32.2-freebsd49.tar.gz) = f9c901fecbd4829dab3766c79784ea1b
-SIZE (drweb-4.32.2-freebsd49.tar.gz) = 2356661
-MD5 (drweb-4.32.2-freebsd53.tar.gz) = 03e928d696b6a5e42fdfbf966f5ab795
-SIZE (drweb-4.32.2-freebsd53.tar.gz) = 2768664
+MD5 (drweb-4.33-freebsd411.tar.gz) = 389a65d58c2563f86a7d3297d2bd4e50
+SIZE (drweb-4.33-freebsd411.tar.gz) = 3345689
+MD5 (drweb-4.33-freebsd54.tar.gz) = 0376869752653ee075af8a7044eaf57d
+SIZE (drweb-4.33-freebsd54.tar.gz) = 3850792
diff --git a/security/drweb/files/drweb.sh b/security/drweb/files/drweb.sh
deleted file mode 100644
index e8b97f4031bf..000000000000
--- a/security/drweb/files/drweb.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-exec /usr/local/drweb/drweb -ini=%INSTALL%/drweb32.ini $*
diff --git a/security/drweb/files/patch-aa b/security/drweb/files/patch-aa
deleted file mode 100644
index 804887486496..000000000000
--- a/security/drweb/files/patch-aa
+++ /dev/null
@@ -1,145 +0,0 @@
---- usr/local/etc/drweb/drweb32.ini.orig Thu Oct 7 17:04:33 2004
-+++ usr/local/etc/drweb/drweb32.ini Thu Oct 7 17:22:05 2004
-@@ -15,34 +15,34 @@
- ; also used by the updating module to update the search module. You
- ; may specify relational path, but it is strongly recommended to make
- ; it absolute.
--EnginePath = "/usr/local/drweb/lib/drweb32.dll"
-+EnginePath = "%INSTALL%/lib/drweb32.dll"
-
- ;VirusBase = { list of the paths (masks) to the files, usual extension is vdb }
- ; Masks for the loaded virus bases. This parameter is also used by
- ; the updating module to update antivirus' bases. A few masks can be
- ; enumerated.
--VirusBase = "/var/drweb/bases/*.vdb", "/var/drweb/bases/*.VDB"
-+VirusBase = "%INSTALL%/bases/*.vdb", "%INSTALL%/bases/*.VDB"
-
- ;UpdatePath = { path }
- ; This parameter is used by update script. This is a place for files
- ; (except drweb32.dll and bases) has been downloaded by update script.
--UpdatePath = "/var/drweb/updates"
-+UpdatePath = "%INSTALL%/updates"
-
- ;TempPath = { path }
- ; This path is used by antivirus engine for creating temporary files.
- ; /tmp would been used if TempPath is not defined.
- ; Normally, the daemon attempts to avoid using of TempPath.
--TempPath = "/var/drweb/spool"
-+TempPath = "/tmp"
-
- ;LngFileName = { path to the language resource file, usual extension - dwl }
- ; Localization file location.
--;LngFileName = "/usr/local/drweb/lib/russian.dwl"
-+;LngFileName = "%INSTALL%/lib/russian.dwl"
-
- ;Key = {path to the file, usual extension is key }
- ; Location of the file with the registration key. You may specify
- ; relational path, but it is strongly recommended to make it
- ; absolute.
--Key = "/usr/local/drweb/drweb32.key"
-+Key = "%INSTALL%/drweb32.key"
-
- ;MailAddressesList = {path to the file}
- ; This file is used only if you have bought e-mail license for
-@@ -50,7 +50,7 @@
- ; Location of file with list of licensed email addresses.
- ; Format of file: one address per line. Address can be in local
- ; or local@fqdn form. See default email.ini for examples.
--MailAddressesList = "/usr/local/etc/drweb/email.ini"
-+MailAddressesList = "%INSTALL%/email.ini"
-
- ;TrafficEqualPerHour = { Yes | No }
- ; This parameter is used only if you have bought traffic license.
-@@ -108,7 +108,7 @@
- ; Default value:
- ; "/var/run/drwebd.pid" (Attention!!! Only the programs executed
- ; with the root rights have write access to /var/run).
--PidFile = "/var/drweb/run/drwebd.pid"
-+PidFile = "%INSTALL%/run/drwebd.pid"
-
- ;BusyFile = { path to file }
- ; Daemon's busy file name: it is created by the scanning "copy" of
-@@ -117,7 +117,7 @@
- ; every "copy" of the daemon gets expanded with a point and ASCIIZ
- ; representation of PID (e.g., /var/run/drwebd.bsy.123456).
- ; Default value: absent (file does not get created)
--BusyFile = "/var/drweb/run/drwebd.bsy"
-+BusyFile = "%INSTALL%/run/drwebd.bsy"
-
- ;MaxChildren = "value"
- ; Sets maximum amount of simultaneously working child (scanning)
-@@ -220,13 +220,13 @@
- ;MoveFilesTo = { path }
- ; Path to quarantine directory.
- ; This feature is used only by Dr.Web VFS for Samba.
--MoveFilesTo = "/var/drweb/infected"
-+MoveFilesTo = "%INSTALL%/infected"
-
- ;BackupFilesTo = { path }
- ; Path to directory is used for backup infected files
- ; if curing has been requested. No backup copies will
- ; be created if parameter was not been defined.
--;BackupFilesTo = "/var/drweb/infected"
-+;BackupFilesTo = "%INSTALL%/infected"
-
-
- ; ====================
-@@ -244,7 +244,7 @@
- ;LogFileName = "syslog"
- ;SyslogFacility = "Daemon"
- ;SyslogPriority = "Info"
--LogFileName = "/var/drweb/log/drwebd.log"
-+LogFileName = "/var/log/drwebd.log"
-
- ;LimitLog = { Yes | No }
- ; Enable/Disable limit for log file size. Parameter
-@@ -435,34 +435,34 @@
- ; also used by the updating module to update the search module. You
- ; may specify relational path, but it is strongly recommended to make
- ; it absolute.
--EnginePath = "/usr/local/drweb/lib/drweb32.dll"
-+EnginePath = "%INSTALL%/lib/drweb32.dll"
-
- ;VirusBase = { list of the paths (masks) to the files, usual extension is vdb }
- ; Masks for the loaded virus bases. This parameter is also used by
- ; the updating module to update antivirus bases. A few masks can be
- ; enumerated.
--VirusBase = "/var/drweb/bases/*.vdb", "/var/drweb/bases/*.VDB"
-+VirusBase = "%INSTALL%/bases/*.vdb", "%INSTALL%/bases/*.VDB"
-
- ;UpdatePath = { path }
- ; This parameter is used by update script. This is a place for files
- ; (except drweb32.dll and bases) has been downloaded by update script.
--UpdatePath = "/var/drweb/updates"
-+UpdatePath = "%INSTALL%/updates"
-
- ;TempPath = { path }
- ; This path is used by antivirus engine for creating temporary files.
- ; /tmp would been used if TempPath is not defined.
- ; Normally, the daemon attempts to avoid using of TempPath.
--TempPath = "/var/drweb/spool"
-+TempPath = "/tmp"
-
- ;LngFileName = { path to the language resource file, usual extension - dwl }
- ; Localization file location.
--;LngFileName = "/usr/local/drweb/lib/russian.dwl"
-+;LngFileName = "%INSTALL%/lib/russian.dwl"
-
- ;Key = {path to the file, usual extension is key }
- ; Location of the file with the registration key. You may specify
- ; relational path, but it is strongly recommended to make it
- ; absolute.
--Key = "/usr/local/drweb/drweb32.key"
-+Key = "%INSTALL%/drweb32.key"
-
- ; ========================
- ; = Running settings =
-@@ -614,7 +614,7 @@
- ;LogFileName = "syslog"
- ;SyslogFacility = "Daemon"
- ;SyslogPriority = "Info"
--LogFileName = "/var/drweb/log/drweb.log"
-+LogFileName = "/var/log/drweb.log"
-
- ;LimitLog = { Yes | No }
- ; Enable/Disable limit for log file size. Parameter
diff --git a/security/drweb/files/patch-ab b/security/drweb/files/patch-ab
deleted file mode 100644
index 198e6f4f3b1c..000000000000
--- a/security/drweb/files/patch-ab
+++ /dev/null
@@ -1,20 +0,0 @@
---- usr/local/drweb/update/update.pl.orig Wed Nov 24 13:39:08 2004
-+++ usr/local/drweb/update/update.pl Wed Nov 24 13:39:36 2004
-@@ -20,7 +20,7 @@
- my $ini = $ARGV[0];
- if( $ini eq '' )
- {
-- $ini = '/usr/local/etc/drweb/drweb32.ini';
-+ $ini = '%INSTALL%/drweb32.ini';
- }
-
- my $wget = `which wget 2>&1`;
-@@ -47,7 +47,7 @@
- die 'Bases path is not defined!' unless $bases;
- die 'Update path is not defined!' unless $update;
-
--$pidFile = '/var/drweb/run/drwebd.pid' if $pidFile eq '';
-+$pidFile = '%INSTALL%/run/drwebd.pid' if $pidFile eq '';
-
- my ( $kmd5, $knum ) = parseKey($keyFile);
- $wget = $wget.' -q --header="X-DrWeb-Validate: '.$kmd5.'" --header="X-DrWeb-KeyNumber: '.$knum.'" -O';
diff --git a/security/drweb/files/patch-ac b/security/drweb/files/patch-ac
deleted file mode 100644
index a03fd6c5c98c..000000000000
--- a/security/drweb/files/patch-ac
+++ /dev/null
@@ -1,29 +0,0 @@
---- usr/local/etc/rc.d/00.drwebd.sh.orig Wed Nov 24 13:50:18 2004
-+++ usr/local/etc/rc.d/00.drwebd.sh Wed Nov 24 13:51:57 2004
-@@ -7,21 +7,21 @@
- case "$1" in
- stop)
- echo -n "Shutting down Dr. Web daemon..."
-- kill `cat /var/drweb/run/drwebd.pid | head -1`
-+ kill `cat %INSTALL%/run/drwebd.pid | head -1`
- ;;
- reload)
- echo -n "Reloading Dr. Web daemon..."
-- kill -HUP `cat /var/drweb/run/drwebd.pid | head -1`
-+ kill -HUP `cat %INSTALL%/run/drwebd.pid | head -1`
- ;;
- restart)
- echo -n "Restarting Dr. Web daemon..."
-- kill `cat /var/drweb/run/drwebd.pid | head -1`
-+ kill `cat %INSTALL%/run/drwebd.pid | head -1`
- sleep 1
-- /usr/local/drweb/drwebd
-+ %INSTALL%/drwebd -ini=%INSTALL%/drweb32.ini
- ;;
- start)
- echo -n "Starting Dr. Web daemon..."
-- /usr/local/drweb/drwebd
-+ %INSTALL%/drwebd -ini=%INSTALL%/drweb32.ini
- ;;
- *)
- echo $0: 'start|stop|restart|reload'
diff --git a/security/drweb/pkg-install b/security/drweb/pkg-install
index 47960241a687..cfb303a3d172 100644
--- a/security/drweb/pkg-install
+++ b/security/drweb/pkg-install
@@ -6,12 +6,12 @@ if [ "$2" != "POST-INSTALL" ]; then
exit 0
fi
+DRWEB_PREFIX="$3"
+DRWEB_VARPREFIX="$4"
USER=drweb
GROUP=${USER}
UID=426
GID=${UID}
-BINOWN=root
-BINGRP=wheel
ex=0
if ! pw groupshow "${GROUP}" 2>/dev/null 1>&2; then
@@ -27,7 +27,7 @@ fi
if ! pw usershow "${USER}" 2>/dev/null 1>&2; then
if pw useradd ${USER} -u ${UID} -g ${GROUP} -h - \
- -s "/sbin/nologin" -d "/nonexistent" -c "Dr. Web Scanner"
+ -s "/sbin/nologin" -d "/nonexistent" -c "DrWeb Antivirus Software"
then
echo ""
echo "Added user \"${USER}\"."
@@ -41,15 +41,15 @@ fi
echo ""
echo "You may also add this lines to your /etc/syslog.conf:"
echo "!drwebd"
-echo "*.* /var/log/drwebd.log"
+echo "*.* ${DRWEB_VARPREFIX}/drwebd.log"
echo ""
echo "You may also add this crontab entry to /etc/crontab"
-echo "0 12 * * * ${BINOWN} ${PKG_PREFIX}/drweb/update/update.pl"
+echo "0 12 * * * root ${DRWEB_PREFIX}/update/update.pl"
echo ""
[ "$ex" = "1" ] && exit 1
-install -dv -m 0755 -o ${USER} -g ${BINGRP} ${PKG_PREFIX}/drweb/run
-install -dv -m 0700 -o ${USER} -g ${BINGRP} ${PKG_PREFIX}/drweb/infected
-install -dv -m 0755 -o ${BINOWN} -g ${BINGRP} ${PKG_PREFIX}/drweb/updates
+chown -R ${USER}:${GROUP} ${DRWEB_PREFIX}
+chown -R ${USER}:${GROUP} ${DRWEB_VARPREFIX}
+chmod 0750 ${DRWEB_VARPREFIX}
exit 0
diff --git a/security/drweb/pkg-message b/security/drweb/pkg-message
deleted file mode 100644
index d0794641598e..000000000000
--- a/security/drweb/pkg-message
+++ /dev/null
@@ -1,8 +0,0 @@
-To gain the full functionality (desinfection, checking for archived and
-packed files and email databases) please order the registration key at:
-
-http://drweb.imshop.de/index_e.htm
-
-or
-
-http://www.drweb.ru/buy.shtml
diff --git a/security/drweb/pkg-plist b/security/drweb/pkg-plist
index 792789b7d9f7..4935340476ca 100644
--- a/security/drweb/pkg-plist
+++ b/security/drweb/pkg-plist
@@ -1,37 +1,54 @@
-bin/drweb
-drweb/bases/drw43201.vdb
-drweb/bases/drwebase.vdb
-drweb/doc/ChangeLog
-drweb/doc/FAQ
-drweb/doc/FAQ.rus
-drweb/doc/readme.daemon
-drweb/doc/readme.daemon.rus
-drweb/doc/readme.license
-drweb/doc/readme.license.rus
-drweb/doc/readme.scanner
-drweb/doc/readme.scanner.rus
+@unexec if [ -f /var/drweb/run/drwebd.pid ] ; then %D/etc/rc.d/00.drwebd.sh stop ; fi
drweb/drweb
-@unexec if [ -f %D/drweb/drweb32.ini ] && cmp -s %D/drweb/drweb32.ini %D/drweb/drweb32.ini-distr; then rm -f %D/drweb/drweb32.ini; fi
-drweb/drweb32.ini-distr
-@exec if [ ! -f %D/drweb/drweb32.ini ] ; then cp -p %D/%F %B/drweb32.ini; fi
drweb/drwebd
drweb/drwebdc
-@unexec if [ -f %D/drweb/email.ini ] && cmp -s %D/drweb/email.ini %D/drweb/email.ini-distr; then rm -f %D/drweb/email.ini; fi
-drweb/email.ini-distr
-@exec if [ ! -f %D/drweb/email.ini ] ; then cp -p %D/%F %B/email.ini; fi
drweb/getkey.HOWTO
drweb/getkey.rus.HOWTO
drweb/lib/drweb32.dll
-drweb/lib/russian.dwl
-drweb/update/readme.update
-drweb/update/readme.update.rus
+drweb/lib/ru_daemon.dwl
+drweb/lib/ru_scanner.dwl
+drweb/read_signed
drweb/update/update.pl
+@unexec if [ -f %D/etc/drweb/drweb32.ini ] && cmp -s %D/etc/drweb/drweb32.ini %D/etc/drweb/drweb32.ini-distr; then rm -f %D/etc/drweb/drweb32.ini ; fi
+etc/drweb/drweb32.ini-distr
+@exec if [ ! -f %B/drweb32.ini ] ; then cp -p %B/%F %B/drweb32.ini ; fi
+@unexec if [ -f %D/etc/drweb/email.ini ] && cmp -s %D/etc/drweb/email.ini %D/etc/drweb/email.ini-distr; then rm -f %D/etc/drweb/email.ini ; fi
+etc/drweb/email.ini-distr
+@exec if [ ! -f %B/email.ini ] ; then cp -p %B/%F %B/email.ini ; fi
etc/rc.d/00.drwebd.sh
-@dirrm drweb/updates
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/FAQ
+%%PORTDOCS%%%%DOCSDIR%%/FAQ.rus
+%%PORTDOCS%%%%DOCSDIR%%/daemon/readme.daemon
+%%PORTDOCS%%%%DOCSDIR%%/daemon/readme.daemon.rus
+%%PORTDOCS%%%%DOCSDIR%%/readme.eicar
+%%PORTDOCS%%%%DOCSDIR%%/readme.eicar.rus
+%%PORTDOCS%%%%DOCSDIR%%/readme.license
+%%PORTDOCS%%%%DOCSDIR%%/readme.license.rus
+%%PORTDOCS%%%%DOCSDIR%%/scanner/readme.scanner
+%%PORTDOCS%%%%DOCSDIR%%/scanner/readme.scanner.rus
+%%PORTDOCS%%%%DOCSDIR%%/update/readme.update
+%%PORTDOCS%%%%DOCSDIR%%/update/readme.update.rus
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/update
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/scanner
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/daemon
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm etc/drweb
@dirrm drweb/update
-@dirrm drweb/run
@dirrm drweb/lib
-@dirrm drweb/infected
-@dirrm drweb/doc
+@dirrm drweb
+@cwd /var
+drweb/bases/drw43300.vdb
+drweb/bases/drw43301.vdb
+drweb/bases/drw43302.vdb
+drweb/bases/drwebase.vdb
+drweb/bases/drwnasty.vdb
+drweb/bases/drwrisky.vdb
+drweb/bases/update.drl
@dirrm drweb/bases
+@dirrm drweb/infected
+@dirrm drweb/log
+@dirrm drweb/run
+@dirrm drweb/spool
+@dirrm drweb/updates
@dirrm drweb