aboutsummaryrefslogtreecommitdiff
path: root/security/drwebd
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2002-05-10 12:58:42 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2002-05-10 12:58:42 +0000
commit39fcd6da87c0597b6b38958dfcc848c254a24396 (patch)
tree31c5626d1db2023606402d34cb59f645f5354032 /security/drwebd
parentac877db9e78e336ed33fb0a97d3fc791c115490a (diff)
downloadports-39fcd6da87c0597b6b38958dfcc848c254a24396.tar.gz
ports-39fcd6da87c0597b6b38958dfcc848c254a24396.zip
Notes
Diffstat (limited to 'security/drwebd')
-rw-r--r--security/drwebd/Makefile40
-rw-r--r--security/drwebd/files/drweb-0.sh22
-rw-r--r--security/drwebd/pkg-comment1
-rw-r--r--security/drwebd/pkg-plist3
4 files changed, 66 insertions, 0 deletions
diff --git a/security/drwebd/Makefile b/security/drwebd/Makefile
new file mode 100644
index 000000000000..05b9f140c051
--- /dev/null
+++ b/security/drwebd/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: drwebd
+# Date created: 10.05.2002
+# Whom: Andrey A. Chernov <ache@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= drwebd
+PORTVERSION= 1.0
+CATEGORIES= security
+EXTRACT_ONLY=
+
+MAINTAINER= ache@FreeBSD.org
+
+DESCR= ${PORTSDIR}/security/drweb/pkg-descr
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+RUN_DEPENDS= ${LOCALBASE}/drweb/drwebd:${PORTSDIR}/security/drweb
+
+checksum:
+ @${DO_NADA}
+
+do-fetch:
+ @${DO_NADA}
+
+do-patch:
+ ${SED} "s#%PREFIX%#${PREFIX}#g" < ${FILESDIR}/drweb-0.sh \
+ > ${WRKSRC}/drweb-0.sh
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/drweb-0.sh \
+ ${PREFIX}/etc/rc.d/drweb-0.sh-dist
+ if [ ! -f ${PREFIX}/etc/rc.d/drweb-0.sh ]; then \
+ ${INSTALL_SCRIPT} ${WRKSRC}/drweb-0.sh \
+ ${PREFIX}/etc/rc.d/drweb-0.sh; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/security/drwebd/files/drweb-0.sh b/security/drwebd/files/drweb-0.sh
new file mode 100644
index 000000000000..e38ed7cf8018
--- /dev/null
+++ b/security/drwebd/files/drweb-0.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+case "$1" in
+start)
+ if [ -x %PREFIX%/drweb/drwebd ]; then
+ rm -f %PREFIX%/drweb/run/drwebd.sock;
+ %PREFIX%/drweb/drwebd -ini:%PREFIX%/drweb/drweb32.ini && \
+ echo -n ' drwebd';
+ fi
+ ;;
+stop)
+ if [ -r %PREFIX%/drweb/run/drwebd.pid ]; then
+ kill `cat %PREFIX%/drweb/run/drwebd.pid` >/dev/null 2>& 1;
+ echo -n ' drwebd';
+ fi
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0
diff --git a/security/drwebd/pkg-comment b/security/drwebd/pkg-comment
new file mode 100644
index 000000000000..99cf2fbc45db
--- /dev/null
+++ b/security/drwebd/pkg-comment
@@ -0,0 +1 @@
+Satellite port to activate DrWeb daemon
diff --git a/security/drwebd/pkg-plist b/security/drwebd/pkg-plist
new file mode 100644
index 000000000000..b4127ec5098b
--- /dev/null
+++ b/security/drwebd/pkg-plist
@@ -0,0 +1,3 @@
+@unexec if cmp -s %D/etc/rc.d/drweb-0.sh %D/etc/rc.d/drweb-0.sh-dist; then rm -f %D/etc/rc.d/drweb-0.sh; fi
+etc/rc.d/drweb-0.sh
+@exec [ -f %B/drweb-0.sh ] || ( cp %B/%f %B/drweb-0.sh; chmod 755 %B/drweb-0.sh )