aboutsummaryrefslogtreecommitdiff
path: root/security/dsniff/Makefile
diff options
context:
space:
mode:
authorEugene Grosbein <eugen@FreeBSD.org>2019-04-05 01:12:59 +0000
committerEugene Grosbein <eugen@FreeBSD.org>2019-04-05 01:12:59 +0000
commit59e05fbee973a577a6150e81aaaf280b089335ee (patch)
tree11baea86345b2675bf3f1af9f3c425e9538c224f /security/dsniff/Makefile
parent744e3b750e1fdeb309757b94468a88588eb8ebe1 (diff)
downloadports-59e05fbee973a577a6150e81aaaf280b089335ee.tar.gz
ports-59e05fbee973a577a6150e81aaaf280b089335ee.zip
Notes
Diffstat (limited to 'security/dsniff/Makefile')
-rw-r--r--security/dsniff/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 9ab2954a9027..ecb024c212b1 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -14,13 +14,10 @@ COMMENT= Various sniffing utilities for penetration testing
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_SSL= openssl111
-BROKEN_SSL_REASON_openssl111= incomplete definition of type 'struct rsa_st'
-
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:net/libnids
LIB_DEPENDS= libnet.so:net/libnet
-USES= gettext pkgconfig ssl
+USES= gettext gnome pkgconfig
USE_GNOME= glib20
GNU_CONFIGURE= yes
@@ -37,9 +34,25 @@ X11_CONFIGURE_WITH=x
.include <bsd.port.pre.mk>
-.if ${SSL_DEFAULT} == base
-BROKEN_FreeBSD_12= incomplete definition of type 'struct rsa_st'
-BROKEN_FreeBSD_13= incomplete definition of type 'struct rsa_st'
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200085
+USES+= ssl
+.endif
+
+.if (${OPSYS} == FreeBSD && ${OSVERSION} >= 1200085) || ${SSL_DEFAULT} == openssl111
+# Requires LibreSSL for old SSL interface
+BUILD_DEPENDS+= ${NONEXISTENT}:security/libressl:stage
+CPPFLAGS+= -nostdinc -I/usr/include -I${WRKDIR}/libressl/include
+LDFLAGS+= -L${WRKDIR}/libressl/lib
+CONFIGURE_ARGS+= --with-openssl=${WRKDIR}/libressl
+
+# Don't use COPYTREE_SHARE here as it hard links files, and the original files
+# are owned by root, which creates problems of its own.
+pre-configure:
+ @cd `${MAKE} -V STAGEDIR -C ${PORTSDIR}/security/libressl`${PREFIX} \
+ && ${FIND} -E . ! -name *.so\* | ${CPIO} -dump ${WRKDIR}/libressl >/dev/null 2>&1
+.else
+BROKEN_SSL= openssl111
+BROKEN_SSL_REASON_openssl111= incomplete definition of type 'struct rsa_st'
.endif
post-patch: