aboutsummaryrefslogtreecommitdiff
path: root/security/easy-rsa
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2018-09-15 15:30:23 +0000
committerMatthias Andree <mandree@FreeBSD.org>2018-09-15 15:30:23 +0000
commit837c8d04db3bc453a7c93b83ba6ccf2ba8c0dde5 (patch)
tree99f220dc747306ac1103d2f4321b873ecb7832db /security/easy-rsa
parent16601cd5db8e9e4f43fff39f49dbc9f560695f50 (diff)
downloadports-837c8d04db3bc453a7c93b83ba6ccf2ba8c0dde5.tar.gz
ports-837c8d04db3bc453a7c93b83ba6ccf2ba8c0dde5.zip
Notes
Diffstat (limited to 'security/easy-rsa')
-rw-r--r--security/easy-rsa/Makefile3
-rw-r--r--security/easy-rsa/files/patch-easyrsa46
-rw-r--r--security/easy-rsa/files/patch-zgit-c5ff31e8 (renamed from security/easy-rsa/files/patch-c5ff31e8)0
3 files changed, 47 insertions, 2 deletions
diff --git a/security/easy-rsa/Makefile b/security/easy-rsa/Makefile
index 08613dcc33c0..aa2c27d0dba7 100644
--- a/security/easy-rsa/Makefile
+++ b/security/easy-rsa/Makefile
@@ -2,6 +2,7 @@
PORTNAME= easy-rsa
DISTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= security net-mgmt
MASTER_SITES= https://github.com/OpenVPN/easy-rsa/releases/download/v${DISTVERSION}/
DISTNAME= EasyRSA-nix-${DISTVERSION}
@@ -15,8 +16,6 @@ LICENSE= GPLv2
CONFLICTS_INSTALL=easy-rsa2-*
-BROKEN= regression for common configurations, patch in a few hours
-
USES= tar:tgz
NO_BUILD= yes
diff --git a/security/easy-rsa/files/patch-easyrsa b/security/easy-rsa/files/patch-easyrsa
new file mode 100644
index 000000000000..88970077412b
--- /dev/null
+++ b/security/easy-rsa/files/patch-easyrsa
@@ -0,0 +1,46 @@
+--- easyrsa~ 2018-09-14 23:21:19.000000000 -0500
++++ easyrsa 2018-09-15 10:21:49.241886000 -0500
+@@ -415,7 +415,6 @@
+
+ # init-pki backend:
+ init_pki() {
+- vars_source_check
+
+ # If EASYRSA_PKI exists, confirm before we rm -rf (skiped with EASYRSA_BATCH)
+ if [ -e "$EASYRSA_PKI" ]; then
+@@ -432,6 +431,11 @@
+ for i in private reqs; do
+ mkdir -p "$EASYRSA_PKI/$i" || die "Failed to create PKI file structure (permissions?)"
+ done
++
++ if [ ! -f "$EASYRSA_PKI/openssl-easyrsa.cnf" -a -f "$EASYRSA/openssl-easyrsa.cnf" ];
++ then
++ cp "$EASYRSA/openssl-easyrsa.cnf" "$EASYRSA_PKI/openssl-easyrsa.cnf"
++ fi
+
+ notice "\
+ init-pki complete; you may now create a CA or requests.
+@@ -1180,18 +1184,15 @@
+ set_var EASYRSA_REQ_CN ChangeMe
+ set_var EASYRSA_DIGEST sha256
+
+- # Detect openssl config, preferring EASYRSA_PKI over EASYRSA
+- if [ -f "$EASYRSA_PKI/openssl-easyrsa.cnf" ]; then
+- set_var EASYRSA_SSL_CONF "$EASYRSA_PKI/openssl-easyrsa.cnf"
+- set_var EASYRSA_SAFE_CONF "$EASYRSA_PKI/safessl-easyrsa.cnf"
+- else set_var EASYRSA_SSL_CONF "$EASYRSA/openssl-easyrsa.cnf"
+- set_var EASYRSA_SAFE_CONF "$EASYRSA/safessl-easyrsa.cnf"
+- fi
++ set_var EASYRSA_SSL_CONF "$EASYRSA_PKI/openssl-easyrsa.cnf"
++ set_var EASYRSA_SAFE_CONF "$EASYRSA_PKI/safessl-easyrsa.cnf"
+
+ # Same as above for the x509-types extensions dir
+ if [ -d "$EASYRSA_PKI/x509-types" ]; then
+ set_var EASYRSA_EXT_DIR "$EASYRSA_PKI/x509-types"
+- else set_var EASYRSA_EXT_DIR "$EASYRSA/x509-types"
++ else
++ #TODO: This should be removed. Not really suitable for packaging.
++ set_var EASYRSA_EXT_DIR "$EASYRSA/x509-types"
+ fi
+
+ # EASYRSA_ALGO_PARAMS must be set depending on selected algo
diff --git a/security/easy-rsa/files/patch-c5ff31e8 b/security/easy-rsa/files/patch-zgit-c5ff31e8
index b5dbcbb7c0bb..b5dbcbb7c0bb 100644
--- a/security/easy-rsa/files/patch-c5ff31e8
+++ b/security/easy-rsa/files/patch-zgit-c5ff31e8