aboutsummaryrefslogtreecommitdiff
path: root/security/easypg
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-02-26 05:58:58 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-02-26 05:58:58 +0000
commita2eafa3950535dd70bf00d8e3ce5a299df11cbd2 (patch)
treecef1b145ce37847996fb8b995539927471ca4a7e /security/easypg
parentc9cd4215f0a0b3c1f42a7a5e4c6fabbfbc2db312 (diff)
downloadports-a2eafa3950535dd70bf00d8e3ce5a299df11cbd2.tar.gz
ports-a2eafa3950535dd70bf00d8e3ce5a299df11cbd2.zip
Notes
Diffstat (limited to 'security/easypg')
-rw-r--r--security/easypg/Makefile53
-rw-r--r--security/easypg/distinfo3
-rw-r--r--security/easypg/pkg-descr8
-rw-r--r--security/easypg/pkg-message5
-rw-r--r--security/easypg/pkg-plist17
5 files changed, 86 insertions, 0 deletions
diff --git a/security/easypg/Makefile b/security/easypg/Makefile
new file mode 100644
index 000000000000..424396bfc3d1
--- /dev/null
+++ b/security/easypg/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: EasyPG
+# Date created: 25 December 2007
+# Whom: Shota Iwazaki <iwazaki8@yahoo.co.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= easypg
+PORTVERSION= 0.0.15
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= epg/27030
+DISTNAME= epg-${PORTVERSION}
+
+MAINTAINER= iwazaki8@yahoo.co.jp
+COMMENT= EasyPG is yet another GnuPG interface for Emacs
+
+RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg1
+
+GNU_CONFIGURE= yes
+USE_EMACS= yes
+
+.if defined(WITH_COMPILED_ELISP)
+PLIST_SUB= COMPILED_ELISP=""
+.else
+PLIST_SUB= COMPILED_ELISP="@comment "
+.endif
+
+INFO= epa
+.if !defined(NOPORTDOCS)
+PORTDOCS= ChangeLog NEWS README
+.endif
+
+do-install:
+ cd ${WRKSRC};\
+ ${MKDIR} ${PREFIX}/${EMACS_SITE_LISPDIR}/epg;\
+ ${INSTALL_DATA} *.el ${PREFIX}/${EMACS_SITE_LISPDIR}/epg
+.if defined(WITH_COMPILED_ELISP)
+ cd ${WRKSRC};\
+ ${INSTALL_DATA} *.elc ${PREFIX}/${EMACS_SITE_LISPDIR}/epg
+.endif
+ cd ${WRKSRC};\
+ ${INSTALL_MAN} epa.info ${PREFIX}/${INFO_PATH}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR};\
+ cd ${WRKSRC};\
+ ${INSTALL_MAN} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/security/easypg/distinfo b/security/easypg/distinfo
new file mode 100644
index 000000000000..b38330b5551d
--- /dev/null
+++ b/security/easypg/distinfo
@@ -0,0 +1,3 @@
+MD5 (epg-0.0.15.tar.gz) = f9b789c1fae02b0dda1517eac68d270a
+SHA256 (epg-0.0.15.tar.gz) = f7c7615c5514451084f45afcc414d12eaf63c276488cf3ec1cc86c6b9babd9ed
+SIZE (epg-0.0.15.tar.gz) = 182396
diff --git a/security/easypg/pkg-descr b/security/easypg/pkg-descr
new file mode 100644
index 000000000000..46f77320e8e7
--- /dev/null
+++ b/security/easypg/pkg-descr
@@ -0,0 +1,8 @@
+EasyPG is an all-in-one GnuPG interface for Emacs. It consists of two
+parts: EasyPG Assistant and EasyPG Library.
+
+EasyPG Assistant is a set of convenient tools to use GnuPG from
+Emacs. EasyPG Library is a sort of an elisp port of GPGME, a wrapper
+library which provides API to access some of the GnuPG functions.
+
+WWW: http://sourceforge.jp/projects/epg/
diff --git a/security/easypg/pkg-message b/security/easypg/pkg-message
new file mode 100644
index 000000000000..0d67247809d8
--- /dev/null
+++ b/security/easypg/pkg-message
@@ -0,0 +1,5 @@
+*****************************************************
+* To use this port, write below to your ~/.emacs: *
+* *
+* (require 'epa-setup) *
+*****************************************************
diff --git a/security/easypg/pkg-plist b/security/easypg/pkg-plist
new file mode 100644
index 000000000000..a760ab8f5022
--- /dev/null
+++ b/security/easypg/pkg-plist
@@ -0,0 +1,17 @@
+%%EMACS_SITE_LISPDIR%%/epg/epa-dired.el
+%%EMACS_SITE_LISPDIR%%/epg/epa-file.el
+%%EMACS_SITE_LISPDIR%%/epg/epa-mail.el
+%%EMACS_SITE_LISPDIR%%/epg/epa-setup.el
+%%EMACS_SITE_LISPDIR%%/epg/epa.el
+%%EMACS_SITE_LISPDIR%%/epg/epg-config.el
+%%EMACS_SITE_LISPDIR%%/epg/epg-package-info.el
+%%EMACS_SITE_LISPDIR%%/epg/epg.el
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epa-dired.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epa-file.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epa-mail.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epa-setup.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epa.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epg-config.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epg-package-info.elc
+%%COMPILED_ELISP%%%%EMACS_SITE_LISPDIR%%/epg/epg.elc
+@dirrm %%EMACS_SITE_LISPDIR%%/epg