aboutsummaryrefslogtreecommitdiff
path: root/security/elixir-jose/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2015-09-29 13:30:49 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2015-09-29 13:30:49 +0000
commitde804b218e5356657444ded0f57af71c6368f26e (patch)
treed052cfd3a31de5029f2659d29bc7a36613848ab5 /security/elixir-jose/Makefile
parentf773c696be2ed4506d40e45ba27fd8d34c3a2dfe (diff)
downloadports-de804b218e5356657444ded0f57af71c6368f26e.tar.gz
ports-de804b218e5356657444ded0f57af71c6368f26e.zip
Notes
Diffstat (limited to 'security/elixir-jose/Makefile')
-rw-r--r--security/elixir-jose/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/security/elixir-jose/Makefile b/security/elixir-jose/Makefile
new file mode 100644
index 000000000000..18e03dd5b8da
--- /dev/null
+++ b/security/elixir-jose/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= elixir-jose
+PORTVERSION= 1.3.0
+CATEGORIES= security
+DISTNAME= ${GH_ACCOUNT}-erlang-jose-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+COMMENT= JSON Object Signing and Encryption (JOSE) for Elixir
+
+LICENSE= MPL
+
+WRKSRC= ${WRKDIR}/erlang-jose-${PORTVERSION}
+ELIXIR_APP_NAME=jose
+USES= elixir
+USE_GITHUB= yes
+GH_ACCOUNT= potatosalad
+
+MIX_BUILD_DEPS= converters/erlang-base64url \
+ security/erlang-jose
+MIX_RUN_DEPS:= ${MIX_BUILD_DEPS}
+
+.include <bsd.port.mk>