aboutsummaryrefslogtreecommitdiff
path: root/security/f-prot/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2004-02-23 01:45:55 +0000
committerMark Linimon <linimon@FreeBSD.org>2004-02-23 01:45:55 +0000
commitc2430908d446d35c08f1c81c4e3e4892b64759af (patch)
tree80477c6b852ca641370cb4ec58bb15a747c65755 /security/f-prot/Makefile
parent115dfbb7056bb00bad957e0a2a8570ed6d4468c0 (diff)
downloadports-c2430908d446d35c08f1c81c4e3e4892b64759af.tar.gz
ports-c2430908d446d35c08f1c81c4e3e4892b64759af.zip
Notes
Diffstat (limited to 'security/f-prot/Makefile')
-rw-r--r--security/f-prot/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/security/f-prot/Makefile b/security/f-prot/Makefile
index 452b29cba405..05d918cb1ab2 100644
--- a/security/f-prot/Makefile
+++ b/security/f-prot/Makefile
@@ -15,7 +15,8 @@ DISTNAME= fp-freebsd-ws-${PORTVERSION}
MAINTAINER= tim@bishnet.net
COMMENT= F-Prot Antivirus for BSD Workstations
-RUN_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
+ ${PREFIX}/f-prot/SIGN.DEF:${PORTSDIR}/security/f-prot-sig
NO_PACKAGE= Free for personal use only
NO_CDROM= Free for personal use only
@@ -29,8 +30,19 @@ MAN1= f-prot.1
ONLY_FOR_ARCHS= i386
do-install:
- cd ${WRKDIR} && ${TAR} -cf - f-prot | ${TAR} -xf - -C ${PREFIX}
+ cd ${WRKDIR} && ${TAR} --exclude man_pages \
+ --exclude doc_ws \
+ --exclude f-prot.sh \
+ --exclude *.DEF \
+ -cf - f-prot | ${TAR} -xf - -C ${PREFIX}
+
${INSTALL_SCRIPT} ${WRKSRC}/f-prot.sh ${PREFIX}/bin/f-prot
${INSTALL_MAN} ${WRKSRC}/man_pages/f-prot.1 ${MANPREFIX}/man/man1/
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${CP} -Rp ${WRKSRC}/doc_ws/* ${DOCSDIR}
+.endif
+
.include <bsd.port.mk>