aboutsummaryrefslogtreecommitdiff
path: root/security/fakeroot/files
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-27 22:21:34 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-27 22:21:34 +0000
commit99606f0b7a7996b759ed34658c619f1f473f1c4e (patch)
tree896d68c550d3737320eecb1a19d6fcf46bda9576 /security/fakeroot/files
parent2fe28174438d5eff68f6d1aa4be6f5ef81556944 (diff)
Notes
Diffstat (limited to 'security/fakeroot/files')
-rw-r--r--security/fakeroot/files/patch-communicate.h12
-rw-r--r--security/fakeroot/files/patch-doc.Makefile18
-rw-r--r--security/fakeroot/files/patch-fakeroot12
-rw-r--r--security/fakeroot/files/patch-libfakeroot.c10
4 files changed, 52 insertions, 0 deletions
diff --git a/security/fakeroot/files/patch-communicate.h b/security/fakeroot/files/patch-communicate.h
new file mode 100644
index 000000000000..efacb33bc0f6
--- /dev/null
+++ b/security/fakeroot/files/patch-communicate.h
@@ -0,0 +1,12 @@
+--- communicate.h Fri Sep 26 04:07:11 2003
++++ communicate.h Thu Mar 11 12:51:34 2004
+@@ -38,7 +38,9 @@
+ #if defined(sun) || __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1)
+ #define STAT64_SUPPORT
+ #else
++#if !defined(__FreeBSD__)
+ #warning Not using stat64 support
++#endif
+ /* if glibc is 2.0 or older, undefine these again */
+ #undef STAT64_SUPPORT
+ #undef _LARGEFILE64_SOURCE
diff --git a/security/fakeroot/files/patch-doc.Makefile b/security/fakeroot/files/patch-doc.Makefile
new file mode 100644
index 000000000000..0a57835e359d
--- /dev/null
+++ b/security/fakeroot/files/patch-doc.Makefile
@@ -0,0 +1,18 @@
+--- doc/Makefile.am Tue Sep 2 06:00:59 2003
++++ doc/Makefile.am Thu Mar 11 13:23:43 2004
+@@ -1,5 +1,4 @@
+ AUTOMAKE_OPTIONS=foreign
+-SUBDIRS = es fr sv
+
+ man_MANS = faked.1 fakeroot.1
+
+--- doc/Makefile.in Sun Feb 22 23:18:19 2004
++++ doc/Makefile.in Thu Mar 11 13:23:47 2004
+@@ -161,7 +161,6 @@
+ target_os = @target_os@
+ target_vendor = @target_vendor@
+ AUTOMAKE_OPTIONS = foreign
+-SUBDIRS = es fr sv
+ man_MANS = faked.1 fakeroot.1
+
+ #another automake bug workaround
diff --git a/security/fakeroot/files/patch-fakeroot b/security/fakeroot/files/patch-fakeroot
new file mode 100644
index 000000000000..3f305273d19a
--- /dev/null
+++ b/security/fakeroot/files/patch-fakeroot
@@ -0,0 +1,12 @@
+--- ../fakeroot-0.8.5/scripts/fakeroot Wed Nov 12 17:07:18 2003
++++ scripts/fakeroot Thu Mar 11 13:40:00 2004
+@@ -16,7 +16,7 @@
+ PREFIX=`dirname ${BINDIR}`
+
+ LIB=libfakeroot.so.0
+-PATHS=${PREFIX}/lib/libfakeroot:${PREFIX}/lib64/libfakeroot
++PATHS=${PREFIX}/lib
+ FAKED=${BINDIR}/faked
+
+ FAKED_MODE="unknown-is-root"
+
diff --git a/security/fakeroot/files/patch-libfakeroot.c b/security/fakeroot/files/patch-libfakeroot.c
new file mode 100644
index 000000000000..dcbbb69c14b9
--- /dev/null
+++ b/security/fakeroot/files/patch-libfakeroot.c
@@ -0,0 +1,10 @@
+--- libfakeroot.c Fri Dec 19 03:38:05 2003
++++ libfakeroot.c Thu Mar 11 12:52:45 2004
+@@ -667,6 +667,6 @@
+ return 0;
+ }
+
+-int setgroups(size_t size, const gid_t *list){
++int setgroups(int size, const gid_t *list){
+ return 0;
+ }