aboutsummaryrefslogtreecommitdiff
path: root/security/fakeroot
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 08:30:27 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 08:30:27 +0000
commitc55ac89dcdd6a84ca67f7888c69ebe78c1dac826 (patch)
tree123ddeae4f07536b3d89acc6409ce124aa06d373 /security/fakeroot
parentf7fc243237d967aba76bb0b8a954cf952eca0693 (diff)
downloadports-c55ac89dcdd6a84ca67f7888c69ebe78c1dac826.tar.gz
ports-c55ac89dcdd6a84ca67f7888c69ebe78c1dac826.zip
Notes
Diffstat (limited to 'security/fakeroot')
-rw-r--r--security/fakeroot/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/security/fakeroot/Makefile b/security/fakeroot/Makefile
index 975acbcade1d..f96e03e5ca98 100644
--- a/security/fakeroot/Makefile
+++ b/security/fakeroot/Makefile
@@ -21,12 +21,10 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-pre-configure:
- @${REINPLACE_CMD} -e '/LIBS=.*-lpthread/s/-lpthread/${PTHREAD_LIBS}/g' \
- ${WRKSRC}/${CONFIGURE_SCRIPT}
-
post-install:
- @${MV} ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so ${STAGEDIR}${PREFIX}/lib/libfakeroot.so.0
- @${LN} -sf ${PREFIX}/lib/libfakeroot.so.0 ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so
+ ${MV} ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so \
+ ${STAGEDIR}${PREFIX}/lib/libfakeroot.so.0
+ ${LN} -sf ${PREFIX}/lib/libfakeroot.so.0 \
+ ${STAGEDIR}${PREFIX}/lib/libfakeroot-0.so
.include <bsd.port.mk>