aboutsummaryrefslogtreecommitdiff
path: root/security/fakeroot
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2005-02-15 10:33:53 +0000
committerVolker Stolz <vs@FreeBSD.org>2005-02-15 10:33:53 +0000
commit3014d27d2f5845cc824b19a87ba63e49cdd31cf3 (patch)
treee3cbdc704935c4ac1221e5b788f2aea122906223 /security/fakeroot
parent3c60e2499a365bcc5b38a68827aa010085c27c39 (diff)
downloadports-3014d27d2f5845cc824b19a87ba63e49cdd31cf3.tar.gz
ports-3014d27d2f5845cc824b19a87ba63e49cdd31cf3.zip
Notes
Diffstat (limited to 'security/fakeroot')
-rw-r--r--security/fakeroot/Makefile3
-rw-r--r--security/fakeroot/distinfo4
-rw-r--r--security/fakeroot/files/patch-communicate.h12
-rw-r--r--security/fakeroot/files/patch-doc.Makefile18
-rw-r--r--security/fakeroot/files/patch-fakeroot12
-rw-r--r--security/fakeroot/files/patch-libfakeroot.c10
-rw-r--r--security/fakeroot/pkg-plist1
7 files changed, 4 insertions, 56 deletions
diff --git a/security/fakeroot/Makefile b/security/fakeroot/Makefile
index cf9981bcf6b2..4957a50fc8f1 100644
--- a/security/fakeroot/Makefile
+++ b/security/fakeroot/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= fakeroot
-PORTVERSION= 0.9.6
+PORTVERSION= 1.2.4
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_DEBIAN}
MASTER_SITE_SUBDIR= pool/main/f/fakeroot
@@ -15,6 +15,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= Meno.Abels@Adviser.com
COMMENT= Simulate the root user behaviour
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/security/fakeroot/distinfo b/security/fakeroot/distinfo
index 8fa5c13c2fae..0c0f78dc2344 100644
--- a/security/fakeroot/distinfo
+++ b/security/fakeroot/distinfo
@@ -1,2 +1,2 @@
-MD5 (fakeroot_0.9.6.tar.gz) = 7e54cb1ac258908ca5eecf244bd1d680
-SIZE (fakeroot_0.9.6.tar.gz) = 851101
+MD5 (fakeroot_1.2.4.tar.gz) = 2c3e6dd5ad7adf2e5c1e28c40177509f
+SIZE (fakeroot_1.2.4.tar.gz) = 1132622
diff --git a/security/fakeroot/files/patch-communicate.h b/security/fakeroot/files/patch-communicate.h
deleted file mode 100644
index efacb33bc0f6..000000000000
--- a/security/fakeroot/files/patch-communicate.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- communicate.h Fri Sep 26 04:07:11 2003
-+++ communicate.h Thu Mar 11 12:51:34 2004
-@@ -38,7 +38,9 @@
- #if defined(sun) || __GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1)
- #define STAT64_SUPPORT
- #else
-+#if !defined(__FreeBSD__)
- #warning Not using stat64 support
-+#endif
- /* if glibc is 2.0 or older, undefine these again */
- #undef STAT64_SUPPORT
- #undef _LARGEFILE64_SOURCE
diff --git a/security/fakeroot/files/patch-doc.Makefile b/security/fakeroot/files/patch-doc.Makefile
deleted file mode 100644
index 0a57835e359d..000000000000
--- a/security/fakeroot/files/patch-doc.Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- doc/Makefile.am Tue Sep 2 06:00:59 2003
-+++ doc/Makefile.am Thu Mar 11 13:23:43 2004
-@@ -1,5 +1,4 @@
- AUTOMAKE_OPTIONS=foreign
--SUBDIRS = es fr sv
-
- man_MANS = faked.1 fakeroot.1
-
---- doc/Makefile.in Sun Feb 22 23:18:19 2004
-+++ doc/Makefile.in Thu Mar 11 13:23:47 2004
-@@ -161,7 +161,6 @@
- target_os = @target_os@
- target_vendor = @target_vendor@
- AUTOMAKE_OPTIONS = foreign
--SUBDIRS = es fr sv
- man_MANS = faked.1 fakeroot.1
-
- #another automake bug workaround
diff --git a/security/fakeroot/files/patch-fakeroot b/security/fakeroot/files/patch-fakeroot
deleted file mode 100644
index 3f305273d19a..000000000000
--- a/security/fakeroot/files/patch-fakeroot
+++ /dev/null
@@ -1,12 +0,0 @@
---- ../fakeroot-0.8.5/scripts/fakeroot Wed Nov 12 17:07:18 2003
-+++ scripts/fakeroot Thu Mar 11 13:40:00 2004
-@@ -16,7 +16,7 @@
- PREFIX=`dirname ${BINDIR}`
-
- LIB=libfakeroot.so.0
--PATHS=${PREFIX}/lib/libfakeroot:${PREFIX}/lib64/libfakeroot
-+PATHS=${PREFIX}/lib
- FAKED=${BINDIR}/faked
-
- FAKED_MODE="unknown-is-root"
-
diff --git a/security/fakeroot/files/patch-libfakeroot.c b/security/fakeroot/files/patch-libfakeroot.c
deleted file mode 100644
index dcbbb69c14b9..000000000000
--- a/security/fakeroot/files/patch-libfakeroot.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- libfakeroot.c Fri Dec 19 03:38:05 2003
-+++ libfakeroot.c Thu Mar 11 12:52:45 2004
-@@ -667,6 +667,6 @@
- return 0;
- }
-
--int setgroups(size_t size, const gid_t *list){
-+int setgroups(int size, const gid_t *list){
- return 0;
- }
diff --git a/security/fakeroot/pkg-plist b/security/fakeroot/pkg-plist
index 8bc7c630b3ed..842f301165cf 100644
--- a/security/fakeroot/pkg-plist
+++ b/security/fakeroot/pkg-plist
@@ -1,6 +1,5 @@
bin/faked
bin/fakeroot
-lib/libfakeroot.la
lib/libfakeroot.so.0
lib/libfakeroot.so
lib/libfakeroot.a