aboutsummaryrefslogtreecommitdiff
path: root/security/fcrackzip/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-17 13:11:47 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-17 13:11:47 +0000
commitb2d845f42979de58dea02c4c763d27f8fd0f4e4f (patch)
tree30a533336adee854eb1d8e402dcffe17257f7e04 /security/fcrackzip/Makefile
parent66424cf8d337a04ed35e4ec9d122bc809f381951 (diff)
downloadports-b2d845f42979de58dea02c4c763d27f8fd0f4e4f.tar.gz
ports-b2d845f42979de58dea02c4c763d27f8fd0f4e4f.zip
Notes
Diffstat (limited to 'security/fcrackzip/Makefile')
-rw-r--r--security/fcrackzip/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/security/fcrackzip/Makefile b/security/fcrackzip/Makefile
new file mode 100644
index 000000000000..8f7d8a747435
--- /dev/null
+++ b/security/fcrackzip/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: fcrackzip
+# Date created: 16 Jul 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fcrackzip
+PORTVERSION= 0.3
+CATEGORIES= security archivers
+MASTER_SITES= http://www.goof.com/pcg/marc/data/
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Portable, fast and featureful ZIP password cracker
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_GETOPT_LONG=yes
+USE_PERL5_BUILD=yes
+USE_REINPLACE= yes
+
+PLIST_FILES= bin/fcrackzip bin/fcrackzipinfo
+.if !defined(NOPORTDOCS)
+MAN1= fcrackzip.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/zipinfo/fcrackzipinfo/g' ${WRKSRC}/zipinfo.c
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/fcrackzip ${PREFIX}/bin/
+ @${INSTALL_PROGRAM} ${WRKSRC}/zipinfo ${PREFIX}/bin/fcrackzipinfo
+.if !defined(NOPORTDOCS)
+ @${INSTALL_MAN} ${WRKSRC}/fcrackzip.1 ${PREFIX}/man/man1/
+.endif
+
+.include <bsd.port.mk>