aboutsummaryrefslogtreecommitdiff
path: root/security/fiked
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /security/fiked
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'security/fiked')
-rw-r--r--security/fiked/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/security/fiked/Makefile b/security/fiked/Makefile
index 7e992dbe0892..fb6c8b874c5e 100644
--- a/security/fiked/Makefile
+++ b/security/fiked/Makefile
@@ -7,6 +7,7 @@
PORTNAME= fiked
PORTVERSION= 0.0.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://dragon.roe.ch/bitsnpieces/fiked/ \
http://home.tiscalinet.ch/roe/fiked/
@@ -16,7 +17,7 @@ COMMENT= A fake IKE PSK+XAUTH daemon based on VPNC
LIB_DEPENDS= gcrypt.13:${PORTSDIR}/security/libgcrypt
.if !defined(WITHOUT_LIBNET)
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
.endif
USE_BZIP2= yes
@@ -29,8 +30,14 @@ PLIST_FILES= bin/fiked
MAN1= fiked.1
PORTDOCS= README NEWS
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+
post-patch:
- @${REINPLACE_CMD} -e 's|=-g|=|' ${WRKSRC}/${MAKEFILE}
+ @${REINPLACE_CMD} -e \
+ 's|=-g|=|; \
+ s|-lnet|`${LIBNET_CONFIG} --libs`|; \
+ s|-DWITH_LIBNET|& `${LIBNET_CONFIG} --cflags`|' \
+ ${WRKSRC}/${MAKEFILE}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fiked ${PREFIX}/bin