aboutsummaryrefslogtreecommitdiff
path: root/security/finger_mysql
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 11:04:08 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-04-02 11:04:08 +0000
commit4f5ee6a36b0c720747ac354d226aa15aaa353111 (patch)
treed2a519869b9c6699470c7eeab78ed84237b74219 /security/finger_mysql
parenta85b62794098ed5a9746114c94a5a37693c19821 (diff)
downloadports-4f5ee6a36b0c720747ac354d226aa15aaa353111.tar.gz
ports-4f5ee6a36b0c720747ac354d226aa15aaa353111.zip
Notes
Diffstat (limited to 'security/finger_mysql')
-rw-r--r--security/finger_mysql/Makefile34
-rw-r--r--security/finger_mysql/distinfo1
-rw-r--r--security/finger_mysql/pkg-descr5
-rw-r--r--security/finger_mysql/pkg-plist1
4 files changed, 41 insertions, 0 deletions
diff --git a/security/finger_mysql/Makefile b/security/finger_mysql/Makefile
new file mode 100644
index 000000000000..e5a69c400684
--- /dev/null
+++ b/security/finger_mysql/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: finger_mysql
+# Date created: 03 Mar 2003
+# Whom: Yonatan <Yonatan@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= finger_mysql
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://www.fsix.net/crew/ \
+ http://www.zone-h.org/files/49/ \
+ http://downloads.securityfocus.com/vulnerabilities/exploits/
+DISTNAME= finger_mysql.c
+EXTRACT_SUFX= #none
+EXTRACT_ONLY= #none
+
+MAINTAINER= Yonatan@xpert.com
+COMMENT= Threaded MySQL scanner
+
+LIB_DEPENDS= mysqlclient:${PORTSDIR}/databases/mysql323-client/
+
+NO_WRKSUBDIR= yes
+
+post-extract:
+ ${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}/
+
+do-build:
+ ${CC} ${CFLAGS} -L${PREFIX}/lib/mysql -I${PREFIX}/include ${PTHREAD_LIBS} -lmysqlclient -o ${WRKSRC}/finger_mysql ${WRKSRC}/${DISTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/finger_mysql ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/finger_mysql/distinfo b/security/finger_mysql/distinfo
new file mode 100644
index 000000000000..88e6610fdba6
--- /dev/null
+++ b/security/finger_mysql/distinfo
@@ -0,0 +1 @@
+MD5 (finger_mysql.c) = 780669d83a76c63f40efab6e34716508
diff --git a/security/finger_mysql/pkg-descr b/security/finger_mysql/pkg-descr
new file mode 100644
index 000000000000..62b0cd40c34f
--- /dev/null
+++ b/security/finger_mysql/pkg-descr
@@ -0,0 +1,5 @@
+This is a threaded C class IP MySQL scanner that will attempt to login
+and extract the hashes from a vulnerable MySQL daemon. See
+http://online.securityfocus.com/bid/5503 for all the details.
+
+WWW: http://www.fsix.net/crew
diff --git a/security/finger_mysql/pkg-plist b/security/finger_mysql/pkg-plist
new file mode 100644
index 000000000000..243f200ea509
--- /dev/null
+++ b/security/finger_mysql/pkg-plist
@@ -0,0 +1 @@
+bin/finger_mysql