aboutsummaryrefslogtreecommitdiff
path: root/security/fpc-hash
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-03-03 16:08:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-03-03 16:08:11 +0000
commit7bfb394b24e6129e0a1a46eaaa0d8189cb87c627 (patch)
treec16b099295d0dbdfd77dd90f127621e0cbee0c99 /security/fpc-hash
parent9f76b90a32069495ace27de0705ce13274a51377 (diff)
downloadports-7bfb394b24e6129e0a1a46eaaa0d8189cb87c627.tar.gz
ports-7bfb394b24e6129e0a1a46eaaa0d8189cb87c627.zip
Notes
Diffstat (limited to 'security/fpc-hash')
-rw-r--r--security/fpc-hash/Makefile46
-rw-r--r--security/fpc-hash/distinfo2
-rw-r--r--security/fpc-hash/pkg-descr8
-rw-r--r--security/fpc-hash/pkg-plist4
4 files changed, 60 insertions, 0 deletions
diff --git a/security/fpc-hash/Makefile b/security/fpc-hash/Makefile
new file mode 100644
index 000000000000..b18d4567fc33
--- /dev/null
+++ b/security/fpc-hash/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: fpc-md5
+# Date created: 8 February 2004
+# Whom: John Merryweather Cooper
+#
+# $FreeBSD$
+#
+
+PORTNAME= md5
+PORTVERSION= 1.0.10
+CATEGORIES= security lang
+MASTER_SITES= http://www.borgsdemons.com/distfiles/
+PKGNAMEPREFIX= fpc-
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal unit for MD5 hash routines
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKDIR}/packages/base/md5 -name "Makefile*" | \
+ ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKDIR}/packages/base/md5 all
+
+do-install:
+ @${SETENV} ${MAKE_ENV} ${GMAKE} -C \
+ ${WRKDIR}/packages/base/md5 install
+
+.include <bsd.port.mk>
diff --git a/security/fpc-hash/distinfo b/security/fpc-hash/distinfo
new file mode 100644
index 000000000000..63335e3a52a3
--- /dev/null
+++ b/security/fpc-hash/distinfo
@@ -0,0 +1,2 @@
+MD5 (md5-1.0.10.tar.gz) = 45a5474d459a8bc481749f276566f0e5
+SIZE (md5-1.0.10.tar.gz) = 10675
diff --git a/security/fpc-hash/pkg-descr b/security/fpc-hash/pkg-descr
new file mode 100644
index 000000000000..e1e2b8a7b5a9
--- /dev/null
+++ b/security/fpc-hash/pkg-descr
@@ -0,0 +1,8 @@
+The md5 unit is part of the base packages for Free Pascal,
+a 32-bit Turbo Pascal/Delphi compatible compiler. This unit
+provides MD5 hash routines.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/security/fpc-hash/pkg-plist b/security/fpc-hash/pkg-plist
new file mode 100644
index 000000000000..b37dc5e394e6
--- /dev/null
+++ b/security/fpc-hash/pkg-plist
@@ -0,0 +1,4 @@
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/md5.o
+lib/fpc/%%PORTVERSION%%/units/freebsd/md5/md5.ppu
+@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/md5